DVD fails to start

  • Have you figured out what exactly has been changed in this specific build???


    It woild give us both an idea in what direction we need to investigate and what logs are required. I cannot find the changelog of this day. How can I find it?

  • DaVu have you been able to figure out what components have been changed? I guess this is just dvd nav that has been upgraded. So if we can create a build with just one component downgraded we can identify the source that is causing the bug. Than the release notes can be reviewed and maybe dvd nav has already such a known bug.

  • marc.bau


    Have you ever read that?

    How could we?


    You never gave us some full log files (because YOU don´t want that), you don´t provide samples, we can´t reproduce your issue (and we tried hard to do. We tried native discs, we tried DVD ISOs and we tried DVD folders navigating to the IFO-file and using that for playback and I (personally) re-ripped multiple DVDs in hope to get one which fails, which wasn´t the case)...so yeah, for the given combination of the mentioned things, we can´t do anything for you. Sorry.

  • DaVu : I have, but this is not my point. I only asked for changelog and commit history and the changes inside. This does not require that you are able to reproduce the bug or I need to share dvds with you. I guess this is not legal.


    If we know what has been changes in this ***one*** day, we may already have the root cause - at least the component. Than we can look for known bugs in the changed component. I do not expect many changes within one day! Something that should be easy to identify. And again this does not require any repro - it is only a question what code changes have committed.


    Than we can reduce the debugging to related stuff.

  • DaVu Ok. I see VideoPlayer has 63 commits and it looks like this is the component that is involved.


    Here is the system debug log you asked for. I also start playing the DVD in this log (end of file).


    Would it be helpful to share the VIDEO_TS.IFO only for repro or are there more files required?

  • If you want to share something, please provide the full DVD structure in that case. PM me if needed.

  • Create a Kodi trac ticket and include as much info as possible. FernetMenta is the developer you want to talk to about VideoPlayer issues. Posting here is not the way to get things fixed in Kodi.

  • smp


    I´m a TeamKodi member as well (so is milhouse ). Generally you are correct and Fernet is the correct person to speak to if it comes to video player related issues. But I don´t want to annoy him with tickets which we (Team LE) can´t reproduce. As already mentioned I couldn´t reproduce any issue while using full DVD structures or DVDs ripped into ISOs. So getting the same structure as the user in question uses could help a lot as I can try to reproduce on LE, Linux, Windows and OSX.


    marc.bau


    At the top right next to the "search"-symbol there´s a button called "conversations". Click on that and at the pulldown menu you will see some "+" sign to create a new converstation. I´ll PM you and you can answer on that message.

  • You requested the logs from me. Have you found something helpful?

    Not sure if I interpret your log correctly. But it seems you disabled debug logging before the error comes up:


    21:16:46.962 T:140286368405696 NOTICE: Disabled debug logging due to GUI setting. Level 0.

    21:16:46.963 T:140286368405696 NOTICE: Log level changed to "LOG_LEVEL_NORMAL"

    21:17:02.243 T:140283515614976 ERROR: Read - Error( -1, 110, Connection timed out )

    21:17:02.245 T:140283515614976 WARNING: underflow: Error reading file - assuming eof

    21:18:07.124 T:140283515614976 ERROR: Read - Error( -1, 110, Connection timed out )

    21:18:07.124 T:140283515614976 WARNING: underflow: Error reading file - assuming eof

    21:19:07.168 T:140283515614976 ERROR: Error on dvdnav_open

    21:19:07.168 T:140283515614976 ERROR: CVideoPlayer::OpenInputStream - error opening [smb://*******/*******/VIDEO_TS/VIDEO_TS.IFO]


    Not sure where the underflow error comes from. But as it´s a PITA to get a full and unedited log from you, I would like to have those exact files you are using. I won´t inverstigate anything for that kind of issue I can´t reproduce with my own files anymore until we have some samples.

  • Debugging has been disabled AFTER the issue occurred. I'm not stupid. The file has no changes in order. Only internal hostnames/mac addresses and folder/filenames are changed.

  • Again, this issue ONLY exists on LibreElec Linux. Not on Windows. Kodi 17.6 on Windows plays the same DVD without issues.

  • This is where the issue is.


    A few lines later you see



    That is because the complete interface hanged and I pressed some keys on my remote to see if it reponds. But the complete interface hanged. Something you can see in the timestamps - there was nothing written.

  • marc.bau can you test with a recent LE9.0 build


    Some of the errors you are seeing ("Connection timedout" etc.) can be triggered by SMB chunk size which has been reduced in late Jan 2018 from 1MB to 64KB in order to improve BD ISO performance.


    We are experiencing some bugs in latest LE9/Kodi 18 test builds but please give it a test and see if your experience with SMB is any better/worse/unchanged.