(Implemented) Pi-Hole

  • I have now created a fresh profile and got it running such that I can see the configuration GUI (see screenshot). Log here http://ix.io/1i6q

    Few noob questions

    The RPI2 is on a static IP.

    I have set an admin password in the config window. Do any of the other settings need to be changed?

    I typed in <ip address>/admin on chrome but no luck.

    What needs to be done to open port 53?

    • Official Post

    Not too sure what you are doing wrong. I've just installed Pi-Hole on 8.2.5 and it works perfectly. As you've got the settings page, everything has installed. Are you sure you WAITED for the Pi-Hole contained to be downloaded at the end of the installation? It can take a while.

    Was this a fresh install or an upgrade/downgrade?

  • I was in a similar situation a month back, trying to get pihole working on CoreELEC.

    Gave up and set up the container manually. Heres the command:

    Set your server IP, webpassword and timezone, then just paste the command and hit enter. Your pihole will be up and running, with a working DHCP component if you want to use that too.

    The problem with my setup after doing this was that after a reboot, pihole would try to run before the network was ready, so i added a delay by doing the following:
    Create 2 files:


    ExecStart=/storage/.kodi/addons/service.system.docker/bin/docker start -a pihole
    ExecStop=/storage/.kodi/addons/service.system.docker/bin/docker stop -t 2 pihole


    Description=Runs pihole

    Then copy these files to your \Configfiles\system.d folder (i used SMB share)

    FInally, run this command using SSH to enable the timer so that it starts pihole 30s after boot.

    systemctl enable pihole.timer    
  • Pardon my stupidity. I believe that this addon will block ads on all devices connected to my router.Is that correct?

    I have it running, can see the web GUI, can see that some standard block lists are installed, but still get ads on my connected devices (eg youtube ads on android tablet). Where might I be going wrong?

    • Official Post

    Hi @all,

    How can i upgrade the piHole Docker from diginc/pi-hole to pihole/pihole?

    They are the same thing - just renamed. Here

    At the moment the LE addon is using pihole V 3.3 to use V4 you'll need to disable the pihole LE addon.

    Download the new container:

    docker pull pihole/pihole:latest

    Then create and run a new script

    docker run -d \

       --name pihole \

       -p 53:53/tcp \

       -p 53:53/udp \

       -p 80:80 \

       -e DNS1= \

       -e DNS2= \

       -v /etc/localtime:/etc/localtime \

       -v /storage/.config/pihole/:/etc/pihole \

       -v /storage/.config/pihole/dnsmasq.d/:/etc/dnsmasq.d \

       -v /storage/.config/pihole/html/:/var/www/html/html/ \

       -h $(cat /etc/hostname) \

       -e ServerIP=$(ip route get | awk '{ print $NF; exit }') \

       -e WEBPASSWORD=libreelec \

       --restart=unless-stopped \


    That will get you running on 4.0. There may be issues as noted by @aptalca

  • I've been running pihole in docker for a while. The v3.3 digic images worked, but since the update for 4.0, they havent worked. User Vashiru on github made a special 4.0 image which was working for me until last week when it again started giving the error.

    You can try his image here: https://hub.docker.com/r/vashiru/pihole/

    It might work for you, the problem may be at my end. But the pihole/pihole images do not work on LE or CE, i'm guessing it has something to do with the docker version we have (17.10)