Intel NUC Apollo Lake / Kaby Lake hdmi passthrough patch

  • i just had a weird decode bug on hevc 10 bit content (dont know if other was affected too, bit in all hevc movies). I could see the decode pattern form time to time resulting in a blocky image. Reboot didnt solve it. any how, it was gone as is restored a backup with exactly the same settings.


    Edit. Seems like x265 is broken (blocky decode) once I had played one TV channel with deinterlace (method deinterlace, not vaapi). After reboot its fine again. But any how all other vaapi deinterlace methods kinda suck. ill test it anyway. Lets see if all of them break it or only a specific one


    Edit. other methods like VAAPI Motion compensate seems not to have that issue.

  • Just started to use InputStream Adaptive but whenever the material is 23.X FPS i get blocks all over the screen. 25p runs fine from Aprime. Same for the most trailers in normal movie library. vp9 seems to be the issue. x265 is fine. same as x264.


    Ideas`?


    Edit: updated to latest release from 14th. VP9 seems to be fine now in trailers, but seems like that my EID issue came back. Sometimes once it switches the display refresh rate on my LG, the signal is gone. I can stop the playback and it returns as switching again, but sometimes it simply loses my display.

  • and TVHeadend is broken :/


    /storage/.kodi/addons/service.tvheadend42/bin/tvheadend: error while loading shared libraries: libva.so.1: cannot open shared object file: No such file or directory

  • Hi - have installed the LibreELEC-Generic.x86_64-8.2-devel-20171205 version on a NUC7I5BNH


    passthrough works perfectly with ,my DENON receiver


    ATMOS / DTS-HDMA / DTS AC3


    tested a variety of sources


    great work - thanks

    ASUS Chromebox

    NUC7i5BNH

  • here is the list of tested media for reference:


    XXXX -4K.UHD.HFR.60fps.FLAC.WEBDL.2160p.X264_ZMachine.mkv

    YYYY-1080p.BluRay.REMUX.AVC.DTS-HD.MA.7.1.mkv

    ZZZZ- 1080p bluray-ATMOS 7.1.m2ts

    AAAA-4k -UHD -2160p-ATMOS 7.1 .mkv

    BBBB-1080p.BluRay.REMUX.AVC.DTS-MA.7.1-FGT.mkv

    CCCC-.DTS.HD.MA-VISIONPLUSHDR1000.mp4

    DDDD-4K24p_HEVC_10Mbits.mkv

    EEEE-4K.HDR.10bit.BT2020.Dolby.True.HD.Atmos-VISIONPLUSHDR1000.mp4

    FFFF-1080p.BluRay.x264.TrueHD.7.1.Atmos-HDC.mkv

    ASUS Chromebox

    NUC7i5BNH

  • pass through for dolby digital and dts work fine with "adjust display refresh rate" on, but the HD-audio only passes through if its set to off, or at least the last time i checked it was that way.

  • pass through for dolby digital and dts work fine with "adjust display refresh rate" on, but the HD-audio only passes through if its set to off, or at least the last time i checked it was that way.

    Are you confusing "Adjust display refresh rate" with "Sync playback to display"? Enabling the latter will disable audio passthrough - this is by design. The refresh rate setting should have no effect on passthrough, HBR audio or not.

  • i'm pretty sure i got it right, its the option that changes the tv refresh rate to mach the video


    see your post mentioning it here: Intel Apollo Lake

    Ah, so that's what you're on about.


    The mixed up channels and lack of audio in early LE8.2 test builds due to the HBR patches were the primary reason those patches did not ship with official LE8.2 - "Adjust refresh rate to display" may have been implicated as one possible cause but there was never any point investigating further as backporting the HBR patches to the older 4.11.y kernel was clearly a bad idea.


    The HBR patches in LE9.0 (with a more recent kernel) are working fine and to the best of my knowledge "Adjust refresh rate to display" is not causing any issues.

  • Which current custom release does contain the Apollo Lake Patch? - The Version escelade postet is from 2016 as far as I see...


    I am running the "official" Version of LE 8.2.3 currently - how can I switch?

    The post was edited 1 time, last by Crady ().