SMB Share Passwords

  • Has anyone come across this, just did the update from LE 8.0.2 to LE 8.1.0, only problem is it keeps asking for the access username and pasword for the sources, on my router and pc sources.


    I repeatidly enter them but with no effect, checked sources with pc and can access no problem, but for now i had to downgrade back to LE 8.0.2 and can now access everything without a problem.


    hardware is RPi 3, router is asus dsl-ac68u with 4tb usb3 drive as main source, additional sources on windows 10 machines, could this be related to smb3 config issue?


    ideas welcome, will try again and enable logging on next attempt.


    Andy

  • You might need to force the SMB client in Kodi (in Kodi settings) to use a maximum of SMB1 for compatibility with an older Samba version in the router. Kodi settings > services > smb client

  • To access the windows shares you need to have a password protected user account on windows...you can create a second account if you hate entering passwords to access windows like I do...to set it up force smb1 in Kodi settings > services > smb client...then when done go back to none.. in For the router shared drive I have no idea to be honest but you may have few settings to play with on the router's side...username and password may easily be the same ones you use to login your router setting...probably admin for both


    Altough needing some setup this new smb update made a massive change to how libreelec handles shares...I used to only see very few of the files I have on shared hdds if any...now it's working perfectly...

  • Hi Mario, windows 10 shares are set for access with username/pasword user account, with Idetical username and password on router, also windows 10 has ntlm2 registy hack applied.


    The samba server on the router has had users added with names and paswords to match windows accross lan, TV, PS3,XBOX1,laptop,tablets and phones can all access sources on pc's and router either internal or external (from public net via vpn & dydns) without issue.


    the sources on the external drive have had permisions applied to folders needed (chmod 644).


    as for default passwords on routers or machines it's a bad idea, I have always changed them as a matter of prinicple since using RHEL 5, it is also why i never buy/accepth the isp supplied routers, you never now what they have done with them, a while back in the city i live in the isp failed to isolate remote admin attack, and quite a few hundred or more routers were infected with the mirai worm, in the end they had to replace the routers.

  • i have the same setup (windows 10 shared folders and dsl-ac68u shared hdd). After the update to 8.1.0 i experienced the same issues like yogensha did. I managed to make windows shares to be visible from libreelec but didn't with the dsl-ac68u, router always asks for password with no access to the folders. I tried to change the the samba version with no success. Finally i downgrade to 8.0.2 where everything works fine.

  • If you change samba version to 1 and restart in 8.1.0 it should work exactly the same as 8.0.2..

  • The 8.2.0 release with have zero changes from 8.1.0 (and shortly 8.1.1) so you'd best read #6 again.

  • i tried again but still no luck (smbv1 -> reboot). Windows shares work fine but asus dsl-ac68u always asks for username/password

    Edited once, last by chrispe ().

  • i tried again but still no luck (smbv1 -> reboot). Windows shares work fine but asus dsl-ac68u always asks for username/password

    Did you try adding source manually in sources.xml with Ip address?Is the passwords.xml being created when you enter password for router?Try to have a look in userdata for passwords.xml...

    If you don't find it add it manually like this passwords.xml.txt

  • where are these files?


    ok, i found them. Passwords were already stored in the xml. I replaced dsl-ac68u with it's local ip in both files but no change

    Edited 2 times, last by chrispe ().

  • Ok do you have a kodi 17.4 installed on the windows 10 machine?can you add source your router hdd from kodi windows and match those xmls?

  • windows kodi settings are copy-paste from my libreelec setup, so the 2 xml files are exactly the same (before make the last changes). Windows kodi has no problem to read router's files

  • On the router hdd sharing settings can you disable require username and password and allow anonymous full access?If yes force SMB1 in LE settings and try again...?

  • disabling username/password on router smb settings i was able to see the files but that's not a solution. A second thought was to delete all the lines about router on sources.xml and password.xml and after libreelec reboot i added again the router hdd on my sources but still keep on asking smb credentials

  • We r getting somewhere...leave it disabled for now...and add source of hdd from kodi file manager as usual with force SMB1 in kodi settings...make sure you can see the shared folders of your hdd...when done enable the require username and password on router and change SMB1 to "None" in kodi LE and restart...