Librespot addon

  • Excellent, will test and report back. I am really busy now, but will do my best.

    Do you plan to release a version for LE 8.2.5? Would be great. Or at least to support that branch if a fix is required.

    Thank you for testing.

    I will maintain Librespot for LibreELEC 8.2 until LibreELEC 9.0 is released.

    Librespot revision 112 uses features of Kodi 18 (especially updateInfoTag) which are not available in Kodi 17. I can therefore not backport it to LibreELEC 9.0.

  • I had 111q run for a while today on my Wetek Play 2, CoreElec 8.95.1, Kodi audio mode.

    One time it just stopped in the middle of a song. I think it was around this log lines

    20:57:13.073 T:3839869808 NOTICE: Librespot: a playback stopped

    20:57:13.073 T:3839869808 NOTICE: Librespot: restarting librespot

    20:57:13.073 T:3839869808 NOTICE: Librespot: systemctl restart

    The log (reduced, it was huge) can be found here:

    I think I never experienced this with 111m. But it was not reproducible either. I played the same songs/album again and all worked well.

  • Librespot log messages preceding the ones you mention show that the librespot daemon requested to stop the daemon. This usually happens when the playing app connects to another device (and therefore disconnects from Librespot).

    20:57:12.323 T:3943469936 NOTICE: Librespot: named pipe received ['stop', '0nOeN35vWJ8ZRheA61QOWt']
    20:57:12.323 T:3943469936 NOTICE: Librespot: stopping librespot playback
  • It was just playing an album, the mobile laid untouched on the table. Maybe a quirk in the spotify app. I will keep an eye on this, if its occurs again, but will be away for three weeks.

  • Hi,

    I recently got Spotify Premium and tried this addon, however its not working, no connection.

    I'm using latest LE on S905x AML ( by kszaq) and installed latest librespot from official repo(v110).

    Heres the log:

    Display Spoiler

    librespot --name TEST

    INFO:librespot: librespot b55e08e (2018-02-28). Built on 2018-02-28. Build ID: n1z5kitr

    *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    *** WARNING *** Please fix your application to use the native API of Avahi!

    *** WARNING *** For more information see <>

    INFO:librespot_core::session: Connecting to AP ""

    INFO:librespot_core::session: Authenticated as "xxxx" !

    INFO:librespot_playback::audio_backend::alsa: Using alsa sink

    INFO:librespot_core::session: Country: "DE"

    thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: WireError(InvalidEnumValue(14))', /checkout/src/libcore/

    stack backtrace:

    0: 0xab0e2fcf - <unknown>

    1: 0xab0defef - <unknown>

    2: 0xab0e7087 - <unknown>

    3: 0xab0e6d73 - <unknown>

    4: 0xab0e7607 - <unknown>

    5: 0xab0e744f - <unknown>

    6: 0xab0e73d3 - <unknown>

    7: 0xab0e736b - <unknown>

    8: 0xab12ff5b - <unknown>

    9: 0xaada0993 - <unknown>

    10: 0xaadacf33 - <unknown>

    11: 0xaadbf30f - <unknown>

    12: 0xaad26caf - <unknown>

    13: 0xaad3c9a3 - <unknown>

    14: 0xab0f1363 - <unknown>

    15: 0xab0e7b83 - <unknown>

    16: 0xf717c5db - __libc_start_main

    at /home/kszaq/

    On github I read that "InvalidEnumValue(14)" means I need to upgrade, but v111 and newer are Leia only, correct? I tried Coreelec for testing purposes and there it works great, but for reasons I don't want to switch to Kodi18 yet, copying the binaries / whole addon from CE to LE didnt't work (obviously). Any chance to get it working in Krypton?

    Cheers chaiuwe

  • No, sorry

    Latest revision uses Leia features...

  • Hi,

    since a few days, librespot doesn't show up as connect device in the spotify app anymore. Can someone confirm that? Maybe there where some changes with the latest spotify update

  • Hi,

    with Version 9.0.112 I get an error:

    deleting cache/reinstalling the addon didn't help

    thanks for help

  • Hi,

    with Version 9.0.112 I get an error:

    deleting cache/reinstalling the addon didn't help

    thanks for help

    What system? What LE version?

  • Device not always visible in Spotify


    I think my issue fits best in this thread...

    using LibreELEC 8.90.005 on Raspberry pi, Librespot 9.0.112

    In the spotify app on my android phone I ONLY see the "librespot@kodi"(as available device) if nothing is playing on KODI.

    So if my default radio is playing on Kodi I cannot "overwrite" this with my spotify client because it does not show as available device.

    As soon as I stop the radio on kodi the device shows up as available in the spotify app.

    I would like to see the device always available in spotify no matter if its playing something.



  • Hi Pieter,

    The addon is programmed to behave as you describe.

    In summary, a LibreELEC device only behaves as a Spotify Connect client while it is not playing a media.

    Last time I checked, a PS4 behaves the same: it will not play Spotify while a game is played.

    It makes sense when parents and teenagers share such devices ;)

    The addon could be updated to switch this behaviour on or off, but I neither have time or a need for it. Contributions are welcome.

  • IIRC milhouse builds use a different kernel than the latest beta, and some addons may therefore have to be rebuilt

    okay I changed to the official beta channel and now I am using 8.90.005 but I get the same error

    could you please build the addon for the official beta versions?