Librespot addon

  • Dear All,


    I´ve noticed that with librespot under libreelec on rpi4b, the sound is by default compressed. I´m not talking about compression as in mp3 or such, but when using a compressor for decreasing the dynamics of the file in order to increase its loudness.

    On some stuff, especially music from before the 90´s, this can have horrible consequences. How do I disable this?

    Please note that the latest available version from the libreelec repository is 9.0.115, and this could be something that has been made optional in later releases. I wouldn´t know how to install newer versions though, so if this is a solution, please advise. I assume that none of the settings in the settings.xml file has any impact on this...
    And, I should add that libreelecs spotify service (which fails to impress in any other way compared to librespot) does NOT add this compression, so it´s not like a thing spotify always does that can´t be turned off.


    Example: spotify:track:5BSkUsTWQWfctzP5EF8XnK - that´s really not how that song should sound!

    I´m playing it now through tuneblade, a decent alternative to play all pc audio through kodi, and this sounds how it should. I think I do recall though that it has some bugs with suddenly stopping to work, so I´d prefer librespot to not use compression.

    Also, tuneblade makes it impossible for me to have a chat over my headset while listening to spotify, since what I´m using here in my living room is a raspberry that´s RDPing into my PC on the 2nd floor, and that solution only allows one audio device, meaning that I´d get the party I´m calling talking through the libreelec raspberry.

    Edited 3 times, last by jazzlpunk ().

  • Dear all,

    I'm using LibreELEC 9.0.2 on two RPi3s, same setup with only one difference: One is playing audio via ALSA, the other via PULSE. On the former, Librespot is playing directly to sysdefault card via ALSA with no user mode switched on. Anything works well if I choose this output device on my mobile with Spotify app running. On the latter, Librespot is configured to play via "Kodi" output mode with no user mode either, it could be found as valid output device if nothing else is currently playing. First, it shows up with a different symbol (screen icon instead of loudspeaker icon) in Spotify app, second, if I try to switch to it, the app switches indeed, but only for a very short time and then switches back to the mobile device itself. "journalctl -u service.librespot" just tells me that the service is stopped after successful authentication with my spotify credentials. The other RPi using ALSA tells me instead that tracks are loaded and played successfully at the same place of the log dump.


    Thus it seems as if PULSE output is causing this problem. Does someone have similar issues?


    Best

  • I want to run Librespot on a Amlogic S905X box, but it doesn't work. On my other S905W it works fine.

    The S905X uses Alsa audio instead of Pulse, but there's no alsa support in the current amlogic version 'Invalid backend' ?

    Can you please build a version to test alsa on a Amlogic S905x ?


    S905W:


    S905X

  • Hi


    is the Addon Python3 ready?

    I have Libreelec and Milhouse on a Pi4.

    But only i get an error Message.


    Best Greedings

    Sorry, I use the google translator


  • It will take some time to build, if I have enough space on my build system. Check here again tomorrow.

    Hello,

    I'd like to download this new version too, if that's okay. I have same hardware.

    Thank you very much for your work so far. :)

  • after having solved the above issue, I received an update for the librespot addon (version 118), throught the update channel.


    this update again delivered a non functional binary:

    after replacing the binary with the version I compiled myself ... everything is back to normal.


    If I was on a custom linux installation I could understand such issues ... but as I am under libreelec my freedom to screw up my system config is quite limited ....


    So I wonder why noone else seems to have this problem ....

  • Could you please share your binary so I can try it out as well?


    I tried compiling it myself as well but the build process failed. Maybe I didn't have all the required dependencies? Anyways, it would be nice if I could try your binary! :)

  • However, revision 119 of the addon will bring back an ALSA backend to librespot.

    It will then be possible to start librespot for ALSA with a separate custom system.d service

    I'm on LibreELEC 9.2.0 on RPi2.arm. Will version 119 also be released for this combination?