Librespot addon

  • addon version 117

    LE: 9.1.501

    Raspberry Pi 4

    Connection: Wifi

    Yes, Spotify premium

    Is wifi stable?


    The output of 'journalctl -u service.librespot' should provide more information about your problem.


    You could also try 'user mode' in addon settings, with Spotify username and password, in case the problem lies with avahi.

    @

  • Hi, i am new here.


    how can I play spotify through Pulse on LibreElec 9.1,501?. I can not see _Librespot in the Spotify to Connect.

    Thank you


    addon version 117

    LE: 9.1.501

    Raspberry Pi 4

    Connection: Wifi

    Yes, Spotify premium

    Edited once, last by Javicampos ().

  • Librespot for LibreELEC should be advertised as 'Kodi (LibreELEC)' or 'Kodi (the_name_you_gave_to_your_libreelec_system)'

    @

  • Running Kodi Leia on Libreelec and added your addon successfully. No username or password entered (if I do then "kodi lounge" cannot be seen in the list on my phone. I have a free Spotify account.


    I see "kodi lounge" as an option on my phone and can click connect but always stays at "connecting" and never connects.


    My son comes over for a visit and bam he can connect straight away and it works awesomely. He has a Premium Spotify account. If he is connected and then I try connecting then it kicks him off but I still stay at "connecting" until it times out.


    Both our phones are Android.


    I also have a PC running on Fedora Linux and can see "kodi lounge" but same result ... always "connecting".

    No problems from my phone or PC to my Google Home speaker.

    Edited once, last by duncang92: Did some more googling and remote logged into my htpc running kodi and looked at the journal ...... addon requires a Premium account. I will be getting myself a premium account. Awesome addon .... thanks so much. ().

  • Hi there!


    Librespot stopped working for me since 3 or 4 days ago. The system is not visible as a playback device in Spotify anymore. Neither on my smartphone, nor laptop, and even after several re-activations of the add-on as well as restarts of the whole system. I updated a few plug-ins, but didn't change anything else before that or since then. Maybe something on Spotify's side changed?


    Thanks a lot for all the great work you put into this add-on! :)

  • Hi there!


    Librespot stopped working for me since 3 or 4 days ago. The system is not visible as a playback device in Spotify anymore. Neither on my smartphone, nor laptop, and even after several re-activations of the add-on as well as restarts of the whole system. I updated a few plug-ins, but didn't change anything else before that or since then. Maybe something on Spotify's side changed?


    Thanks a lot for all the great work you put into this add-on! :)

    Please describe your setup: version of LibreELEC and Librespot. The output of 'journalctl -u service.librespot' could also be useful.

    @