Posts by donski

    Hi there,


    is there any chance of installing the newest librespot version on LE 9?

    Could it even be backported into the official LE 9 Add-on repo so it auto-updates on LE 9?


    Thanks a lot!

    I'm running it on the new version 122 on a Raspberry Pi 3 using a nightly build from Milhouse and it works pretty well. Artwork is displayed and I also listened to a podcast, jumping in time etc.


    One issue: When I want to play a track from the auto-suggestions displayed below a playlist, it stops working (I removed timestamps etc.):

    Code
    [librespot_connect::spirc] Fetching autoplay context uri
    [librespot_connect::spirc] Autoplay uri resolved to <"spotify:station:playlist:1rxlGK8SOz1PJgavHOXY7p">
    [librespot_playback::player] Loading <Lesser Known Good> with Spotify URI <spotify:track:3vGnW6Pg1LCFDwHAMnHuXX>
    [librespot_connect::spirc] Resolved 50 tracks from <"spotify:playlist:1rxlGK8SOz1PJgavHOXY7p">
    [librespot_playback::player] <Lesser Known Good> (300972 ms) loaded
    [librespot_connect::spirc] Fetching autoplay context uri
    thread 'main' panicked at 'Spotify servers returned an error. Restart librespot.', core/src/mercury/mod.rs:201:13

    Please describe your setup: version of LibreELEC and Librespot. The output of 'journalctl -u service.librespot' could also be useful.

    Code
    Kodi (18.2-RC1 Git:c67eb3a). Platform: Linux ARM 32-bit

    It's the Milhouse build that is identical with LibreELEC 18.2

    The error keeps repeating until systemd stops restarting it.

    Hi there!


    Librespot stopped working for me since 3 or 4 days ago. The system is not visible as a playback device in Spotify anymore. Neither on my smartphone, nor laptop, and even after several re-activations of the add-on as well as restarts of the whole system. I updated a few plug-ins, but didn't change anything else before that or since then. Maybe something on Spotify's side changed?


    Thanks a lot for all the great work you put into this add-on! :)