Librespot addon

  • According to your logs, the addon is installed and the Kodi addon is started.

    The system.d unit should therefore also be enabled and attempt to start.

    Please try again to log into LibreELEC and type journalctl -u service.librespot (exactly like this).

    @

  • According to your logs, the addon is installed and the Kodi addon is started.

    The system.d unit should therefore also be enabled and attempt to start.

    Please try again to log into LibreELEC and type journalctl -u service.librespot (exactly like this).

    Hey man,


    I've ctrl+c/ctrl+v it and, again, the result is -- no entries --


    Thanks


  • Then try these commands:

    systemctl enable /storage/.kodi/addons/service.librespot/system.d/service.librespot.service


    systemctl start /storage/.kodi/addons/service.librespot/system.d/service.librespot.service


    journalctl -u service.librespot

    @

  • Ok,


    This is what I have after inputing the second command:


    Failed to start storage-.kodi-addons-service.librespot-system.d-service.librespo t.service.mount: Unit storage-.kodi-addons-service.librespot-system.d-service.li brespot.service.mount not found.

  • Ok,


    This is what I have after inputing the second command:


    Failed to start storage-.kodi-addons-service.librespot-system.d-service.librespo t.service.mount: Unit storage-.kodi-addons-service.librespot-system.d-service.li brespot.service.mount not found.

    Then try systemctl start service.librespot

    @

  • Then try systemctl start service.librespot

    Hey man,


    After typing systemctl start service.librespot I typed journalctl -u service.librespot and this is what I have:



    -- Logs begin at Tue 2018-11-06 18:28:51 -02, end at Tue 2018-11-06 19:31:43 -02. --

    Nov 06 19:29:56 CoreELEC systemd[1]: Started librespot.

    Nov 06 19:29:56 CoreELEC sh[13639]: INFO:librespot: librespot 582a7b5 (2018-10-04). Built on 2018-10-04.

    Nov 06 19:29:57 CoreELEC sh[13639]: INFO:librespot_core::session: Connecting to AP "guc3-accesspoint-b-vg

    Nov 06 19:29:58 CoreELEC sh[13639]: thread 'main' panicked at 'Authentication failed with reason: Premium

    Nov 06 19:29:58 CoreELEC sh[13639]: stack backtrace:

    Nov 06 19:29:58 CoreELEC sh[13639]: 0: 0xab11b393 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 1: 0xab123feb - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 2: 0xab11d6e3 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 3: 0xab11d343 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 4: 0xab11dfa7 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 5: 0xab11dcdf - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 6: 0xab11dc2b - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 7: 0xaadc73df - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 8: 0xaad76ef3 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 9: 0xaadb86a7 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 10: 0xaae158e3 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 11: 0xaacbecb3 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 12: 0xaac9f047 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 13: 0xaac9f2ab - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 14: 0xaaca654b - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 15: 0xaaca9adf - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 16: 0xaaca6b47 - <unknown>

    standard input lines 1-23


    That's weird, because I do own a premium account...Maybe I should try it again without choosing to login into my account?

  • At least the service is enabled and started.

    I still do not understand why this was not done automatically.


    To use the credentials from your Spotify app, delete username/password in the addon settings.

    @

  • At least the service is enabled and started.

    I still do not understand why this was not done automatically.


    To use the credentials from your Spotify app, delete username/password in the addon settings.

    Ok, so I removed my Spotify credentials, unistalled and reinstalled Librespot, then I've sent journalctl -u service.librespot via PuTTy and this is what I have:


    Nov 07 08:44:51 CoreELEC systemd[1]: Started librespot.

    Nov 07 08:44:51 CoreELEC sh[18061]: INFO:librespot: librespot 582a7b5 (2018-10-04). Built on 2018-10-04. Build ID: 4eE7k6KS

    Nov 07 08:44:51 CoreELEC sh[18061]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:44:51 CoreELEC librespot[18079]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:44:51 CoreELEC librespot[18079]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:44:51 CoreELEC sh[18061]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:44:51 CoreELEC sh[18061]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:44:51 CoreELEC librespot[18079]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:44:55 CoreELEC systemd[1]: Stopping librespot...

    Nov 07 08:44:55 CoreELEC systemd[1]: Stopped librespot.

    Nov 07 08:45:00 CoreELEC systemd[1]: Started librespot.

    Nov 07 08:45:00 CoreELEC sh[18102]: INFO:librespot: librespot 582a7b5 (2018-10-04). Built on 2018-10-04. Build ID: 4eE7k6KS

    Nov 07 08:45:00 CoreELEC sh[18102]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:45:00 CoreELEC librespot[18123]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:45:00 CoreELEC sh[18102]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:45:00 CoreELEC librespot[18123]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:45:00 CoreELEC sh[18102]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:45:00 CoreELEC librespot[18123]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:45:10 CoreELEC systemd[1]: Stopping librespot...

    Nov 07 08:45:10 CoreELEC systemd[1]: Stopped librespot.

    Nov 07 08:45:11 CoreELEC systemd[1]: Started librespot.

    Nov 07 08:45:11 CoreELEC sh[18165]: INFO:librespot: librespot eb5f246 (2018-10-24). Built on 2018-10-25. Build ID: AoGSVp99

    Nov 07 08:45:11 CoreELEC sh[18165]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:45:11 CoreELEC librespot[18183]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:45:11 CoreELEC librespot[18183]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:45:11 CoreELEC sh[18165]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:45:11 CoreELEC sh[18165]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:45:11 CoreELEC librespot[18183]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>


    PS: But now, after removing my Spotify credentials, it's working!

    Edited 2 times, last by Morguito ().

  • I am happy that it now works for you.


    The messages you see are normal.


    I still do not understand why the system.d service was not automatically enabled/started as it should have.


    Nevertheless, enjoy!

    @

  • Hi!


    Thanks for this add-on! It mostly works for me. There are some hiccups and I was wondering if there is any way they could be fixed.

    I am running Libreelect 8.2.5 and the only service I have installed is the latest librespot addon 8.2.111 on my RPi2.


    My first hiccup is that I have to restart my Pi every time I want to start streatming. I probably just need to restart the service, but I just unplug and replug power to the Pi since it is headless. Otherwise the LibreSpot doesnt appear under available devices.


    Also, it seems to be only available to one user at a time. If my wife uses it on the ipad, I wont see it appear on my phone for a few days, and the opposite is also true.


    Any ideas?

    cheers

  • Hi morglum


    1. Try to set Wait for Network in LibreELEC network settings


    2. Use Discovery Mode in Librespot settings (no userid/password)

    @

  • Hello,

    i intalled Librespot addon 8.2.107 on Libreelec 8.2.5

    When I start the addon, i cannot see it in my Spotify as a device to connect to.

    This is what i get by journalctl -u service.librespot command:


    Nov 21 19:47:38 LibreELEC systemd[1]: Started librespot.

    Nov 21 19:47:38 LibreELEC sh[4309]: INFO:librespot: librespot a9bda247a7 (2017-10-30). Built on 2017-10-30. Build ID: nyjfWjYt

    Nov 21 19:47:38 LibreELEC sh[4309]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 21 19:47:38 LibreELEC sh[4309]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 21 19:47:38 LibreELEC sh[4309]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>

    Nov 21 19:47:38 LibreELEC librespot[4325]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 21 19:47:38 LibreELEC librespot[4325]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 21 19:47:38 LibreELEC librespot[4325]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>

    Nov 21 19:47:38 LibreELEC sh[4309]: thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: DNSError(Unknown)', /checkout/src/libcore/result.rs:860:4

    Nov 21 19:47:38 LibreELEC sh[4309]: note: Run with `RUST_BACKTRACE=1` for a backtrace.

    Nov 21 19:47:38 LibreELEC systemd[1]: service.librespot.service: Main process exited, code=exited, status=101/n/a

    Nov 21 19:47:38 LibreELEC systemd[1]: service.librespot.service: Unit entered failed state.

    Nov 21 19:47:38 LibreELEC systemd[1]: service.librespot.service: Failed with result 'exit-code'.

    Nov 21 19:47:39 LibreELEC systemd[1]: service.librespot.service: Service hold-off time over, scheduling restart.

    Nov 21 19:47:39 LibreELEC systemd[1]: Stopped librespot.

    Nov 21 19:47:39 LibreELEC systemd[1]: service.librespot.service: Start request repeated too quickly.

    Nov 21 19:47:39 LibreELEC systemd[1]: Failed to start librespot.

    Nov 21 19:47:39 LibreELEC systemd[1]: service.librespot.service: Unit entered failed state.

    Nov 21 19:47:39 LibreELEC systemd[1]: service.librespot.service: Failed with result 'exit-code'.


    Any idea what could be wrong?

    Thank you

  • Librespot starts before the network is ready.


    To solve this problem, go to LibreELEC network settings and set wait for network.

    @

  • I have the wait for network checkbox checked (with timeout of 20 sec).

    Any other idea?

    Thank you


    EDIT: I did not have Avahi service enabled. After enabling, I can see the device in spotify, but i am not abe to connect to it:


    Nov 24 12:59:43 LibreELEC sh[3205]: INFO:librespot: librespot a9bda247a7 (2017-10-30). Built on 2017-10-30. Build ID: nyjfWjYt

    Nov 24 12:59:43 LibreELEC sh[3205]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 24 12:59:43 LibreELEC sh[3205]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 24 12:59:43 LibreELEC sh[3205]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>

    Nov 24 12:59:43 LibreELEC librespot[3221]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 24 12:59:43 LibreELEC librespot[3221]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 24 12:59:43 LibreELEC librespot[3221]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>

    Nov 24 12:59:43 LibreELEC sh[3205]: INFO:librespot_core::session: Connecting to AP "gew1-accesspoint-b-b8ng.ap.spotify.com:4070"

    Nov 24 12:59:44 LibreELEC sh[3205]: INFO:librespot_core::session: Authenticated as "--I removed the login--" !

    Nov 24 12:59:44 LibreELEC sh[3205]: INFO:librespot::audio_backend::alsa: Using alsa sink

    Nov 24 12:59:44 LibreELEC sh[3205]: INFO:librespot_core::session: Country: "CZ"

    Nov 24 12:59:44 LibreELEC sh[3205]: thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: WireError(InvalidEnumValue(13))', /checkout/src/libcore/result.rs:860:4

    Nov 24 12:59:44 LibreELEC sh[3205]: note: Run with `RUST_BACKTRACE=1` for a backtrace.

    Nov 24 12:59:44 LibreELEC systemd[1]: service.librespot.service: Main process exited, code=exited, status=101/n/a

    Nov 24 12:59:44 LibreELEC systemd[1]: service.librespot.service: Unit entered failed state.

    Nov 24 12:59:44 LibreELEC systemd[1]: service.librespot.service: Failed with result 'exit-code'.

    Nov 24 12:59:44 LibreELEC systemd[1]: service.librespot.service: Service hold-off time over, scheduling restart.

    Nov 24 12:59:44 LibreELEC systemd[1]: Stopped librespot.

    Edited once, last by kibkib ().

  • Hi together,


    I'm struggling for hours now and cannot get it running on my raspi3, LE9.0 Milhouse builds.

    Earlier in this thread it seemed Milhouse builds are not captured by this addon. However, this is shoud not the case for librespot 9.0.113 (received through installing from repo) any more, right?


    IIRC milhouse builds use a different kernel than the latest beta, and some addons may therefore have to be rebuilt


    Milhouse nightlies are based on LibreELEC master (9.0), Librespot 8.1.102b is based on LibreELEC 8.1: your configuration is unlikely to work at all, because of mismatched libraries.

  • Hi together,


    I'm struggling for hours now and cannot get it running on my raspi3, LE9.0 Milhouse builds.

    Earlier in this thread it seemed Milhouse builds are not captured by this addon. However, this is shoud not the case for librespot 9.0.113 (received through installing from repo) any more, right?

    Hi


    Librespot is known to run under LibreELEC 8.2 and 9.0


    You need a Spotify premium account


    Once Librespot is installed, select it from one of your Spotify apps and play tracks


    Known issues:

    - libespot starts before network is available: set wait for network in LibreELEC settings

    - wrong credentials: leave username and password blank

    - no sound: increase volume from Spotify app, select audio device or switch to Kodi mode


    Also, describe your issue in more details:

    - LibreELEC system and version

    - Spotify app system and version

    - describe what you do and where you think you have a problem

    @