Posts by kibkib

    I unistalled the plugin, deleted the settings folder, installed again, but i still get the same error.

    I have the wait for network checkbox checked (with timeout of 20 sec).

    Any other idea?

    Thank you


    EDIT: I did not have Avahi service enabled. After enabling, I can see the device in spotify, but i am not abe to connect to it:


    Nov 24 12:59:43 LibreELEC sh[3205]: INFO:librespot: librespot a9bda247a7 (2017-10-30). Built on 2017-10-30. Build ID: nyjfWjYt

    Nov 24 12:59:43 LibreELEC sh[3205]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 24 12:59:43 LibreELEC sh[3205]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 24 12:59:43 LibreELEC sh[3205]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>

    Nov 24 12:59:43 LibreELEC librespot[3221]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 24 12:59:43 LibreELEC librespot[3221]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 24 12:59:43 LibreELEC librespot[3221]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>

    Nov 24 12:59:43 LibreELEC sh[3205]: INFO:librespot_core::session: Connecting to AP "gew1-accesspoint-b-b8ng.ap.spotify.com:4070"

    Nov 24 12:59:44 LibreELEC sh[3205]: INFO:librespot_core::session: Authenticated as "--I removed the login--" !

    Nov 24 12:59:44 LibreELEC sh[3205]: INFO:librespot::audio_backend::alsa: Using alsa sink

    Nov 24 12:59:44 LibreELEC sh[3205]: INFO:librespot_core::session: Country: "CZ"

    Nov 24 12:59:44 LibreELEC sh[3205]: thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: WireError(InvalidEnumValue(13))', /checkout/src/libcore/result.rs:860:4

    Nov 24 12:59:44 LibreELEC sh[3205]: note: Run with `RUST_BACKTRACE=1` for a backtrace.

    Nov 24 12:59:44 LibreELEC systemd[1]: service.librespot.service: Main process exited, code=exited, status=101/n/a

    Nov 24 12:59:44 LibreELEC systemd[1]: service.librespot.service: Unit entered failed state.

    Nov 24 12:59:44 LibreELEC systemd[1]: service.librespot.service: Failed with result 'exit-code'.

    Nov 24 12:59:44 LibreELEC systemd[1]: service.librespot.service: Service hold-off time over, scheduling restart.

    Nov 24 12:59:44 LibreELEC systemd[1]: Stopped librespot.

    Hello,

    i intalled Librespot addon 8.2.107 on Libreelec 8.2.5

    When I start the addon, i cannot see it in my Spotify as a device to connect to.

    This is what i get by journalctl -u service.librespot command:


    Nov 21 19:47:38 LibreELEC systemd[1]: Started librespot.

    Nov 21 19:47:38 LibreELEC sh[4309]: INFO:librespot: librespot a9bda247a7 (2017-10-30). Built on 2017-10-30. Build ID: nyjfWjYt

    Nov 21 19:47:38 LibreELEC sh[4309]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 21 19:47:38 LibreELEC sh[4309]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 21 19:47:38 LibreELEC sh[4309]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>

    Nov 21 19:47:38 LibreELEC librespot[4325]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 21 19:47:38 LibreELEC librespot[4325]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 21 19:47:38 LibreELEC librespot[4325]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>

    Nov 21 19:47:38 LibreELEC sh[4309]: thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: DNSError(Unknown)', /checkout/src/libcore/result.rs:860:4

    Nov 21 19:47:38 LibreELEC sh[4309]: note: Run with `RUST_BACKTRACE=1` for a backtrace.

    Nov 21 19:47:38 LibreELEC systemd[1]: service.librespot.service: Main process exited, code=exited, status=101/n/a

    Nov 21 19:47:38 LibreELEC systemd[1]: service.librespot.service: Unit entered failed state.

    Nov 21 19:47:38 LibreELEC systemd[1]: service.librespot.service: Failed with result 'exit-code'.

    Nov 21 19:47:39 LibreELEC systemd[1]: service.librespot.service: Service hold-off time over, scheduling restart.

    Nov 21 19:47:39 LibreELEC systemd[1]: Stopped librespot.

    Nov 21 19:47:39 LibreELEC systemd[1]: service.librespot.service: Start request repeated too quickly.

    Nov 21 19:47:39 LibreELEC systemd[1]: Failed to start librespot.

    Nov 21 19:47:39 LibreELEC systemd[1]: service.librespot.service: Unit entered failed state.

    Nov 21 19:47:39 LibreELEC systemd[1]: service.librespot.service: Failed with result 'exit-code'.


    Any idea what could be wrong?

    Thank you