Shuttle Wireless Card Keeps dropping connection

  • Hi There


    I have two Shuttle machines both have different Realtek wireless cards. However the wireless cards keeps losing/dropping off the network. Both machines are in different locations in the house one is in the same room as the router and the other is upstairs. When they drop of the network (at different times) other wireless devices are fine like laptops, phones etc So I know its not the Wi-Fi itself.


    One machine is a Shuttle XH97v


    Shuttle Global - XH97V


    wireless card is WLN-P - WLAN-ac / Bluetooth Combo Kit (Mini PCI-Express type)


    Shuttle Global - WLN-P


    Driver is here - WLAN_Realtek_8821AE
    Shuttle Global - WLN-P



    The other is a Shuttle XH81V
    Shuttle Global - XH81V/XH81


    Wireless card is WLN-S - WLAN Kit for Shuttle Slim PC
    Shuttle Global - WLN-S


    Driver here - Wireless_Realtek_RTL8192CE
    Shuttle Global - WLN-S


    Both machines have intel i3 4130T with 4 GB of Ram


    We were running Openelec with 15.2 version of Kodi which the wireless was stable without dropping out everything worked perfectly. Once you all left OpenElec created LibreELEC I upgraded both machines and it became unstable. Now that the new version is out (LibreELEC Krypton v8.0.1 MR) I was hoping this might get fix but I'm still having issues with it. I don't really want to go back to OpenElec. I found if I reboot the machine a few times it will re-connect. I use Yatse as my remote for my machine on my phone and I can be half way through watching something and then the machine loses it connection and I then can't control the machine unless I plug a mouse into it to reboot it which can be frustrating at times.


    How do I provide with logs etc to prove there is a problem with the drivers built into LibreELEC?


    Happy to try what you need me to do to resolve this.


    Kind Regards
    Greg
    [font]LibreELEC (Krypton) v8.0.1 MR[/font]

  • Realtek drivers have had problems in Linux OS'es off and on. It can be a lottery at times. So if there is any possibility to use network cables, please do so.


    In LibreELEC (as in OpenELEC), there is an option in the Network tab window in the Settings add-on, called "Wait for network". Enable it. PC's can be sometimes too fast during booting LibreELEC.


    Uploading Kodi log files via SSH is the quickest and simplest way:
    HOW TO:Provide Logfile - LibreELEC


    Also via SSH, supply a dmesg listing via the following command:

    Code
    1. dmesg | pastebinit


    And share the URL with us here.

  • Are you sure it's still stable if you go back to OE with Kodi 15.2?


    The thing about wifi is that it can be affected by the environment, ie. a neighbour may have started transmitting on the same wifi channel and your two Realtek devices are simply marginal signal-wise and now lose connection because of the overlapping neighbour. You could try using a different channel, preferably one that is relatively free of other users/neighbours (there'll be an app for that - some sort of wifi-scanner app).


    You could try my test builds (based on LE9) as these include slightly updated Realtek drivers, and more recent kernel, but honestly. LibreELEC Testbuilds for x86_64 (Kodi 18.0)


    Failing that, Powerline/Homeplug works really well...


  • Thanks for the reply, I have the setting "Wait for Network" enable even if set to 60 secs sometime it still doesn't connect and a couple of reboots and then it will connect but for how long is different each time. The Ethernet port on the back of the machine is also Realtek 8111G X1 so I expect I have issues with that as well. Thanks for the link to provide logs I shall do that later today and share it with you.


    Thanks for you help
    [hr]


    Thanks for your reply, its defiantly stable with OE with Kodi 15.2, I can go back to that and make sure and maybe then upgrade to OE 16.1 and see if it changes. I was running OE 15.2 for a long time as I was waiting to see when they where to release 16.1 but then realised most of the Devs had gone and created LE so I moved over.


    Both machine have DHCP client reservations and I've checked the Wi-Fi and our Wi-Fi is the only one on channel 11 for 2.4GhZ and our Virgin media router doesn't support 5Ghz. One machine is -50dBm and the other is -69dBm so I know its not the signal strength. I've also tested one of the machines at a friends house to rule out the Wi-Fi and it did the same there.


    I'll try the test build as well as see if that makes any difference.


    Thanks

  • Ethernet cable connects, even when using Realtek nic's, should be far more stable that any wifi connection.


    The question for me is: if Kodi 15.2 was/is working fine, why upgrade now? ("If it isn't broken, don't fix it").


  • Hiya here is the URL as requested YdCN
    Thanks for having a look
    [hr]


    Ethernet cable connects, even when using Realtek nic's, should be far more stable that any wifi connection.


    The question for me is: if Kodi 15.2 was/is working fine, why upgrade now? ("If it isn't broken, don't fix it").


    I know it would be more stable than wifi


    I upgraded as I thought OE was dead and everyone was moving over to LibreELEC. I wanted to upgrade to the latest where the skins have change etc but I do get where your coming from though. Don't really want to go back to OE if I don't have to. I will try the nightly build you suggested once you've had a look at the pastebin URL


    Appreciate your help.

  • Hi


    I solved the issue myself, I purchased an Intel® Dual Band Wireless-AC 3160 M2 card for both machines from Amazon and the wireless has been perfect.


    On the Shuttle website it shows that these two models WLN-P & WLN-S are the only wireless cards supported for the XH97V and XH81V but that's not true.


    I thought I'd update this post for other shuttle users if there having the same issues. At the end of the day Realtek drivers for Linux Sucks!


    Please mark this post as solved.


    Thanks to everyone that tried to help.