LibreELEC builds with nVidia 304.xx driver

  • thank you

    can you build or tell me ( noobie in this) haw to buiild or add hauppage dvb-s drivers in this version ?

  • Unfortunately, the 304.xxx driver does not work for nvidia 9200M GS, I tried ubuntu with 340.106 and it worked well. Could you anyone give me some idea as how to compile with driver 340.106, I will be very thankful. :)

  • Hi chewitt,


    Thanks for your reply. I've tried however the Generic image does not work for me. There no sound over hdmi, so I'd like to compile the code with 340.160 to give it a try. I don't know how.

  • Hi chewitt,


    Thanks for your reply. I've tried however the Generic image does not work for me. There no sound over hdmi, so I'd like to compile the code with 340.160 to give it a try. I don't know how.

    It might be worth trying to restart kodi via ssh first. Sometimes kodi loads before the soundcard is initialised causing issues.


    If the sound starts working after you restart kodi via ssh then you can usually fix this issue by adding a delay at startup in the autostart.sh file:

    Shell-Script
    1. #!/bin/sh
    2. sleep 10; \
  • Thanks a lot for the info. I will try this. Yes, I meant 340.106. I tested 340.106 in ubuntu and it works well.

  • Hi Chewitt,


    Thanks for for info. Could you please give me the command to compile the source code. I tried the following code in ubuntu 18.04 but it did not work.


    PROJECR=Nvidia_Legacy ARCH=x84_64 make image


    Thanks,

    Clarbee

  • Ubuntu 16.04.x (LTS) is recommended for the build host.

    The command should be:

    PROJECT=Generic ARCH=x86_64 make image

  • Hi Sam3,


    Thanks for the info. I will try Ubuntu 16.04x, if I use the command I guess I need to modify xf86-video-nvidia/package.mk to use 340.104, right?


    Thanks,
    Clarbee

  • I've tried with 304.xx driver, but there is no sound through hdmi and there is very load noise on my laptop speaker. I think if the following code(PROJECT=Generic ARCH=x86_64 make image) is used then xf86-video-nvidia/package.mk will be used instead of xf86-video-nvidia-legacy/package.mk , please correct me if I am wrong.

  • I've tried with 304.xx driver, but there is no sound through hdmi and there is very load noise on my laptop speaker. I think if the following code(PROJECT=Generic ARCH=x86_64 make image) is used then xf86-video-nvidia/package.mk will be used instead of xf86-video-nvidia-legacy/package.mk , please correct me if I am wrong.

    Both the legacy and current nvidia driver are built/included in Libreelec generic build and Libreelec will choose the appropriate driver for your card on boot. This list shows which devices use the current driver (the rest will use the legacy driver) LibreELEC.tv/96-nvidia.rules at libreelec-8.2.5-gpu-legacy · sammy2142/LibreELEC.tv · GitHub


    The 9200m gs will use the lgacy driver so this is the file you need to edit

  • Your welcome ;)


    Also the older official LibreElec build 8.2.3 uses the 340.104 nvidia driver so you can probably download/try this version before to test if it works.

    Ps. you mentioned you needed 340.106 in an earlier post and then 340.104 in a later post???

    I've tried with 304.xx driver, but there is no sound through hdmi and there is very load noise on my laptop speaker.

    Does the menu still work or does the computer freeze?