RPi3 LibreELEC Freeze

  • My RPi3 occassionally freezes when idle and screen is off.


    Power and SD card LED are just permanently on then instead of the SD card LED flashing every few seconds.
    I can not reach my Pi via network and screen is also blank when I turn it on.
    Only turning the power off and on helps then to reset the Pi.


    My Kodi log just goes back to around 2am this morning but it still worked later at 9am so it doesn't make sense to post it here.


    Any ideas?

    Edited once, last by boulder ().

  • Does the RPi freeze around the same time you turn the TV off?
    If so have a look at System -> Input -> Peripherals -> CEC adapter -> and change "When the TV is switched off" to ignore.

  • No, unfortunately not. It also doesn't freeze immediately after I turn my TV off.


    At 2am I turned my TV off, at 9am I could still access the Pi over the network but didn't use Kodi and then between 9am and 1pm it just froze without any interaction.


    CEC is set to stop playback on TV standby.

  • It just froze again when it wasn't even in use. I disabled LibCEC in Kodi completely to see if that was the cause but apparently it isn't.


    Doesn't it freeze for anyone else?

  • I have had the same issue after upgrading mx RPi 2 to an RPi 3.
    The only thing which helped is to make a hard reset in LibreElec Config Tool and rescan all my Media.
    Now everything works without any freezes


  • Doesn't it freeze for anyone else?


    Here!!
    Your problem sounds very similar to my problem, although I am using OSMC. I'm here to fill a second SDCard with LE and then cross check, if the problem is distribution related or Kodi 17.x related.


    I am using:

    • "confluence skin"
    • "TvHeadend" plugin (TVheadend Server is a big iron)
    • SMB/CIFS shares from a linux server (xubuntu 14.04 LTS)
    • ah, and last but not least in the master bedroom we have the plugin "videodevil" (with redtube and the stuff, for times when the kids are out and mom and dad are home alone, you know)


    Same setup is in the master living room - expcept the Pi is RPi2 and ethernet'ed, while it's an RPi3 with WiFi in the master bedroom.


    Both setups have this trouble since upgrading to Kodi 17, while 2 more RPi1 boxes (last release of RaspBMC + Kodi 15, I guess) are still working and working ... just trashing the SD file system once a year, but never hang or reboot in the middle of the night.
    So I am quite sure, the hardware is okay (swapped the RPi2 3 times, rotated the PSUs mulötiple times, no effect on the issue, issue is still bound to Kodi17 devices)


    this are my 5 cents,
    Laser Man

  • I'm using nothing special and don't have any media in my database. Maybe it's not even related to Kodi but rather Kernel or LE bug.


    It freezes about every 1-2 days.

  • I guess if you don't intend to use Kodi for a couple of days, shut Kodi down with "systemctl stop kodi" and leave the RPi running. If all seems Ok after that then it's probably Kodi, if not then the Kernel.