TBS Drivers LibreElec 8

  • Hello World,


    I've installed the LibreElec 8.01. It's my first step with LE precedently I have used OE.
    It's also my first step with estonny interface.


    I've search in Wiki and Forum without success.


    I want to install Crazycat drivers (TBS), but I can't see a contexte menu to do that.


    Thanks in advance for your help


    Olivier

    HTPC 1 : ASUS E35M1-I DELUXE AMD E350 - ISK 310-150 - LE 8.2.5 + TVHEADEND (PXE NFS)
    HTPC 2 : ASUS AT3N7A-I ATOM N330 ION - ISK 300-150 - LE 8.2.5 (PXE NFS)
    HTPC 3 : ASROCK J4105-ITX - ISK 300-150 - LE 8.9.009 (UEFI PXE NFS)
    HTPC 4 : Raspberry PI2 - LE 8.2.5


  • I do not know what is exactly crazycat but it seems to be available on github
    With a ssh connection, you must be able to download

  • Hi beckysat,


    May be a daft response the official TBS drivers are automatically included in LE 8, so there should be no need for those non official TBS drivers unless you were having problems with your TBS equipment.


    Post correction, see next post below from CvH.


    I have used Crazycat drivers pre LE 8 (excellent they are too) there was a post in one of the forums from crazycat (can't find it now) about open source and official TBS drivers which said to go with official TBS drivers from LE 8 as they were part of the core kernel build.


    If I'm wrong on the crazycat post content - crazycat I do then apologise in advance.


    I've been using the official TBS drivers in LE 8 and have not had any problems when using with TvH 4.0 and TBS 4 tuner card 6985.


    Here is a link from one of crazycat's posts ljalves/linux_media to the page that has the open source drivers for TBS cards.

  • Just for clarification, we use currently (LE8) CrazyCats fork of the TBS drivers - so any TBS card just "just work" ot of the box.

  • Hi


    I am currently running Libreelec RPi2 8.0.2and have a TBS5990, and it is being detected by Tvheadend. The problem I have is that when I add mux it won't scan and and I get "Fail". Even when I add IPTV channels it won't add them and give me a Fail. Tested on Tvheadend backend 4.2. Seems there is an issue with this Tvheadend, cause I'm running Tvheadend on other devices, even when I do not add a DVB-S to it, and just add an IPTV channel it would work.

  • Hi CvH


    After couple of testing on my Raspberry Pi 2 using TBS5990 and Tvheadend 4.2 please find my findings:


    1. Libreelec v7.0.2 "LibreELEC-RPi2.arm-7.0.2-dvbdrivers.img" - (from this website LibreELEC (unofficial) Kodi builds for additional DVB Drivers which I think it is yours) works for on both IPTV channels as well as DVB-S channels (booth audio and video). At first Tvheadend wouldn't recognize TBS5990 and in order to make it recognizable I used a trick (don't know what the reason is but this method works. I had to go to "DVB Drive Configuration" and select CrazyCat (official TBS driver) 3 times, each time it had to reboot and then the 4 time I had to select Official TBS open source drivers (formerly ljalves). With this trick TBS5990 becomes visible and I can add my IPTV & DVB-S channels and everything works fine here.


    P.S. Just notised that after shutting down and opening Libreelec v7.0.2 all settings are lost :(


    2. Libreelec official 8.0.1 - TBS5990 is immediately recognized by tvheadend, however when setting it up I can only add DVB-S, but the problem with this is only video would work with no audio (tested on HD channels) and when changing the channels its not smooth and would struggle around 10 seconds or so to change the channel. IPTV channels I wasn't able to add it, it would give me fail.


    3. Libreelec official 8.0.2 - TBS5990 is recognized but when when trying to add both DVB-S and IPTV channels it would only fail.



    4. I also tried to hook it up with Synology and using a Docker TVheadend from LinuxServer.io and it was not recognized as well.


    I hope I could run it with Raspberry Pi 2 Libreelec v 8.0.2 but as mentioned cannot be setup.

    Edited 2 times, last by next2non ().

  • CvH


    Update - I did more testing now and reinstalled Libreelec v8.0.2 - SD channels work fine with both Audio and Video to the channels. Changing SD channels is fast and acceptable.


    HD channels cannot be streamed, don't know why I get the following error in Tvheadend


    Code
    2017-06-20 18:04:16.390 TS: Bader/10730V/LBC HD: H264 @ #371 Continuity counter error (total 1)

    Code
    2017-06-20 18:04:16.392 TS: Bader/10730V/LBC HD: MPEG2AUDIO @ #372 Continuity counter error (total 1)

    Code
    2017-06-20 18:04:26.414 TS: Bader/10730V/LBC HD: H264 @ #371 Continuity counter error (total 4346)

    Code
    2017-06-20 18:04:26.582 TS: Bader/10730V/LBC HD: MPEG2AUDIO @ #372 Continuity counter error (total 188)

    Code
    2017-06-20 18:04:26.983 TS: Bader/10730V/LBC HD Transport error indicator (total 1)

    Code
    2017-06-20 18:04:36.430 TS: Bader/10730V/LBC HD: H264 @ #371 Continuity counter error (total 8681)

    Code
    2017-06-20 18:04:36.574 TS: Bader/10730V/LBC HD: MPEG2AUDIO @ #372 Continuity counter error (total 376)

    Code
    2017-06-20 18:04:43.606 TS: Bader/10730V/LBC HD Transport error indicator (total 4)

    Code
    2017-06-20 18:04:44.063 tbl-base: cat: 10730V in Bader: invalid checksum (len 55, errors 1)

    I tried to stream it to my iPhone instead of the TV and on my iPhone it streams but breaks a lot that its not viewable. Do you think HD channels cannot be streamed to either TV or iPhone due to the capability of RPi2?


    Regards

  • Do you think HD channels cannot be streamed to either TV or iPhone due to the capability of RPi2?

    this should work, Continuity error are due HW problems (unlikely because SD is working), softwareproblems (kind of unlikely) - I would bet at some bandwidth limitation at RPi side. Try to disable the second tuner and only use 1 tuner if it works then - it is maybe because the bandwidth is over the limit. The RPi didn't have that much overall bandwith because USB + LAN is over one connection and that is rather limited.


    You could try to record a HD channel if it works then (no other interaction wit the rpi in the meanwhile).

  • Hi CvH


    So I disabled the the second tuner but the same results I even swapped the tuners but HD won't stream at all. Any suggestions?

  • Hi CvH


    I did more testing it seems HD channels DVB-S/S2 with modulation QPSK will run fine where as HD channels with modulation 8PSK will not run. Seems the 8PSK modulation is bandwidth limiting factor. Do you think there is a way to overcome this?


    Streaming the 8PSK channels from a different device running Tvheadend (Wetek play 2) runs fine on RPi 2.

  • I think this is driver problem, it shouldn't be such a great impact at the bandwidth.

    Are you sure they send something that the RPi can actually handle (no 4k or HEVC ?)

  • maybe we misunderstand us :D

    you should do a recording (without playback) at the rpi from the channel that makes problem, then copy the recorded file to some pc and try if the same errors are there too (this rules out that the RPi playback is the problem).


    I created an Image with the latest tbs drivers that maybe (maybe not) fix the problem IF it is a driver problem.

    LibreELEC-RPi2.arm-8.0.2-tbs-driver-test.img.gz

    pls make a backup before

  • Hi CvH


    Sorry for the misunderstanding :) I tested the file on my iPhone (VLC) and it looks exactly like the one I sent to you. I also tested your file but whenever I scan tvheadend says "scan no data, failed". Just to verify the version you sent is 8.0.1 Libreelec (community) (as per Koid->Libreelec->About)


    So does the video file indicate error with drive or RPi 2 capability? What about the file you sent can you re modify it again for another test :)


    Edit: After testing with each reboot some channels would appear, but some mux would give some service, other mix still show 0 service. Also the one mux I put give different channels, not as per what content it should give me.

    Edited 2 times, last by next2non ().