Changing the time of Rpi

  • How do you change the time on a raspberry pi?


    I have put a couple of pool.ntp.org servers in the relevant settings page and its not using them to set the time.


    How do I get it to do so?

  • If you have the wrong time with the correct location/timezone, it's more a Kodi problem, not LibreELEC.

  • I have a similar problem and have set the wait for network and location settings.


    But the Raspberry Pi doesn't have a way to save the time when you turned it off.


    On the Raspberry Pi, the OS must get the time from a NTP server on a set schedule or on boot so the apps running on top of the OS have the right time.


    Or via a script if the task is left to the user.


    I don't see how this is an issue with Kodi.

    Edited once, last by liyin ().

  • Yes, I can confirm that OSMC (Kodi) does sync reliably with NTP servers at boot time.


    First line when booting OSMC: " [Ok] Started Set Time using HTTP query "


    This is a first after trying several distros over the years.


    But you must use the default Kodi skin (Estuary) or you won't see the Add-ons menu (hidden).


    Can anyone confirm if LibreELEC syncs reliably with NTP servers at boot time on a Raspberry Pi 2/3? (lost a card in the process)

    Edited once, last by liyin ().


  • I have no problems getting the correct time.


    ntp is done through connman not through ntpd itself.

  • Ok sorted it - Goto the Settings/Interface/Regional and set:


    Region Default Format and Timezone Country and it will work fine :)


    Thanks all for the hints...