[8.0.2c] LibreELEC 8.0 builds for KIII Pro (S912)

  • Maybe I'm overlooking something, but none of the receivers show up for me:


    sJ9zkxO.png?1


    sJ9zkxO.png?1

    Sorry, without installation details you can only mindreader ask for help.

    Pls, provide LE and TVHeadend versions and logs.

    Publish links form ssh session:

    Code
    1. dmesg | paste
    2. cat /storage/.kodi/userdata/addon_data/service.tvheadend42/service.log | paste
  • I can't see nothing wrong from your log messages, internal driver is initialized correctly, also tvheadend started with no error messages. The same setup in my KIII Pro is running without any issue. Pls, try clean installation on new SD card or USB stick.

  • I reflashed the Image onto a USB drive, and installed the tvheadend onto Kodi, but I got the same result of no receivers being shown.



    Is there anything else I could possibly do? Maybe theres a USB DVB-S2 stick I can use?

  • Update in #1.

    Thank a million again for your work afl1 :-)


    Would it be possible to include a reference and link to the device tree in the first post? Makes it easier to locate for existing users and new users tend to skip this step because they don't read further than the first post.

    MECOOL KIII Pro (S912)

    Raspberry Pi 2 Model B, overclock mode: 'Pi2' (1000/500/500/2), gpu_mem_1024: '320'

  • Thank a million again for your work afl1 :-)


    Would it be possible to include a reference and link to the device tree in the first post? Makes it easier to locate for existing users and new users tend to skip this step because they don't read further than the first post.

    Device tree is already included in SD image, you needn't replace it for KIII Pro.

  • Device tree is already included in SD image, you needn't replace it for KIII Pro.

    Cheers. Strange thought. When I started using LibreELEC a few weeks back, 8.0.1k with a full clean install, I didn't have the tuners available in tvheadend until I replaced the device tree with the one in the third post manually. Maybe it was just an unlucky combo of other things then.

    MECOOL KIII Pro (S912)

    Raspberry Pi 2 Model B, overclock mode: 'Pi2' (1000/500/500/2), gpu_mem_1024: '320'

  • Hello afl1


    I downloaded the tar update from page 1 says it's for s905


    This does not seem right the KIII is s912?



    regards

  • Hey, I've flashed the latest version onto both USB drives, and onto SD cards, but it doesnt seem to boot up? The K3 just stays stuck on the black and white text "mecool" screen.


    Name:

    LibreELEC-S912.arm-8.0-8.0.2c-I.img.gz


    Link: MEGA


    I plugged it into my PC and the LIBREELEC partition has :


    Code
    1. aml_autoscript kernel.img s905_autoscript SYSTEM.md5
    2. dtb.img kernel.img.md5 SYSTEM

    The title says "s905_autoscript". Maybe your link hasnt been updated?

  • This is correct. aml_autoscript install s905_autoscript. Boot process is same for S905/S912.

    Try to flash previous version. If it starts, try it upgrade putting .tar to '/storage/.update' and reboot box.

    I'll verify SD card version tomorrow.

  • Is there any other advantage to this build, in addition to the 10bit/HDR work that has been done, for the 1080p users?

    Three notable advantages:

    • On default 8 bit output, 10-8 dithering is enabled (fixes the nougat "color banding" that was reported on earlier kszaq nougat builds). Just realized S912 should have had dithering enabled on the old nougat kernel as well, sorry for mixing up a s905 and s912 issue.
    • Some users who had output issues on nougat through AVRs may have them fixed now.
    • It's been reported HDR->SDR conversion is improved.