ssh password

  • Hello,
    What is the usual password on libreelec?
    i try to connect with Putty and allways have "password not aviable" or something like that..
    When i install Jarvis 6.95.3 on my sd card (raspberry pi 2 /3) i type -root paswword -openelec and it works.
    When i came to lmibreelec the first time , i am not sure , but i have seen that password was "libreelec" , am i right?.
    maybe do i use the a head letter somwhere.. i don't know !



    Is anyone can help me for that?
    Thanks

  • Okay I seem to be having a problem here that i cant find the answer to.


    The SSH password: libreelec does not work.
    I have tried log in as [email protected]<ip> i have tried just typing root and still the password doesnt work.
    i have seen that sometime it doesnt show you typing out the password for security reasons and that i can understand but it the password simply doesnt work.


    idk what to do.

  • @ geonet2001
    When typing the password it won't show what you are typing.
    Make sure you are typing exactly this "libreelec" without quotes and all lowercase.
    Also make sure SSH is enabled in the LibreELEC settings and do not enable "Disable SSH Password".

    Edited once, last by vitorp07 ().


  • @ geonet2001
    When typing the password it won't show what you are typing.
    Make sure you are typing exactly this "libreelec" without quotes and all lowercase.
    Also make sure SSH is enabled in the LibreELEC settings and do not enable "Disable SSH Password".


    Different user, same issue. I do not have "Disable SSH Password" checked in the setting menu, and when I attempt to connect, I use 'libreelec' as the password and it does not work. I just get "permission denied, please try again."


  • Different user, same issue. I do not have "Disable SSH Password" checked in the setting menu, and when I attempt to connect, I use 'libreelec' as the password and it does not work. I just get "permission denied, please try again."


    Can we have more info on what you tried?
    -Devices you ssh from and to, on the same network?
    -Are you using latest PuTTY?
    -Verified you are using the correct LibreELEC device's IP address in PuTTY?


    Open PuTTY and try these settings;
    -In "Session" select SSH, type the device IP address, "Port 22".
    -In "Connection->Data" type "root" in Auto-Login and select "Prompt"
    -Back to Session click to highlight "Default Settings" and click "Save" on the right.
    -Click "Open" and type password "libreelec"


  • I'm on the same network, at home. I know my devices IP address, and besides I wouldn't even get a password prompt if it didn't connect. The computer I am remoting from is Arch Linux and I am not using PuTTY, I'm just using ssh in the terminal.


    And isn't port 22 the default for SSH?


    I'm starting to think that maybe I didn't enable SSH when I initially installed LibreElec. But how do I check that?

  • In the LibreELEC settings addon.


    BTW if ssh is not enabled on LibreELEC you should have this answer:

    Code
    ssh: connect to host xxx.xxx.xxx.xxx port 22: Connection refused

    Edited once, last by ozolli ().

  • OK tried all that was posted. Still not getting in.


    I'm using putty release 0.67
    SSH is running on libreelec and I typed in the password multiple times and still getting the access denied prompt


    Just in case this matters I'm using libreelec on my odriod c2

    Edited once, last by geonet2001 ().

  • If someone ever comes across this old topic, I´d like to add something that people may not have realized.. It´s in the putty gui´s host field where you want to type [email protected] Then it will prompt for password next. So don´t simply put the ip address in the host field, where you then will be prompted for both login and password. Should you wish to do it that way, then ONLY type root in the loginname field - not the @ip part.