LibreELEC ODROID-U2/U3 support

  • Hi,

    My Odroid U3+ has worked well over the last few years but now it is outdated and no longer supported I am considering my options:

    Should I attempt a kernel reconfiguration? However, I do not have a Linux based pc which appears to be what is needed. I only have a MacBook Pro an old OX

    ( to be honest, I am daunted by the seemingly complex and time consuming task of kernel rebuilding).


    Should I simply buy a later version like the XU-4?

    While there are obvious benefits for being able to rebuilding a kernel, I do not have the skill or ability and would prefer an easier option if available.

    Any advice would be appreciated.

    I have two EMMC cards so I am able to backup my existing OS.

    Thanks in advance.

  • Hi,

    first I wanny say thank to you fraggle for doing such a good job.

    I am trying out your image on my Odroid U3. And have several issues:

    1. resolution:

    kodi boots up with 1920x1080p and I am not able to change it via the menu. (Menu options disabled). The native resolution of my Beamer is 720p but the odroid is connected via a Denon AVR 1912.

    I tried several options in boot.ini to change to resolution to 720p but without success. I could change to resolution when kodi was running via ssh and xrandr-Command. There was still a picture after that but the GUI was somewhat broken and didn't resize properly.

    Does anyone know of a way to force a resolution? Maybe xrandr-command at startup? Or what exactly to put into boot.ini?

    I was unable to configure the Denon AVR to demand input at 720p. There are no HDMI options like this at all :-(.

    2. CEC

    I hoped that it would be possible to control kodi with my Denon AVR Remote. But nothing has worked so far. I was playing around with the cec-client command on the SSH shell to see if I get an error message, but it say that there is no link. I edited the hdmi_cec_config-File and tried to set sensible settings in the CEC plugin but I don't know exactly what I am doing...

    Can someone recommend a CEC tutorial to get me started?

    There are a few minor things (screen flicker in menu animations, spotify addon, standby activation), but those are the two main problems that keep me from throwing out my old satellite receiver.

    Thanks a lot again and have some nice holidays..

  • With

    1. setenv video_output "drm_kms_helper.edid_firmware=edid/1280x720.bin"

    in the boot.ini file, the desired resolution will be forced.

    For CEC, you'll have to make the port number in /storage/.config/cec-hdmi-port.conf match the one in the Kodi CEC settings and match the HDMI port on the TV. The HDMI port numbering on TV is sometime off-by-one.

  • That is exactly what I tried. But the resolution is still 1080p:

    The device is not directly connected to a TV, but to a Denon AVR. There it is on HDMI Input 1. So this should be correct?

    1. # cat /storage/.config/cec-hdmi-port.conf
    2. CEC_HDMI_PORT=1

    With Kodi CEC settings you mean "System Settings -> Input -> Peripherals -> CEC Adapter -> Physical address (overrules HDMI Port)"? Regardless of what I configure there, after a reboot it is set to 0 again...

    Thanks for your help!

  • Someone can help me? Could you tell me howto install LibreElec on my odroid U3 EmmC?
    Already tried without success (LibreElec seems doesn boot) 2 ways:

    dd if=LibreELEC-Odroid_U2.arm-8.2.2.img of=/dev/sdd bs=4M

    and with LibreELEC.USB-SD.Creator.Linux-64bit.bin selecting and writing the image.

    PS: the sd card version works

    Thanks in adv guys!

  • I just picked up an Odroid XU4. I'm curious to know if this will work with the XU4 model?


  • Hello everyone!

    I am currently working with the ODROID-U3 platform and there were problems with launching

    I use for SD SD image Version 8.2.2

    uart output is as follows:

    if someone knows something tell me how to fix it