LibreELEC ODROID-U2/U3 support

  • Hi,

    My Odroid U3+ has worked well over the last few years but now it is outdated and no longer supported I am considering my options:

    Should I attempt a kernel reconfiguration? However, I do not have a Linux based pc which appears to be what is needed. I only have a MacBook Pro an old OX

    ( to be honest, I am daunted by the seemingly complex and time consuming task of kernel rebuilding).


    Should I simply buy a later version like the XU-4?

    While there are obvious benefits for being able to rebuilding a kernel, I do not have the skill or ability and would prefer an easier option if available.

    Any advice would be appreciated.

    I have two EMMC cards so I am able to backup my existing OS.

    Thanks in advance.

  • Hi,

    first I wanny say thank to you fraggle for doing such a good job.

    I am trying out your image on my Odroid U3. And have several issues:

    1. resolution:

    kodi boots up with 1920x1080p and I am not able to change it via the menu. (Menu options disabled). The native resolution of my Beamer is 720p but the odroid is connected via a Denon AVR 1912.

    I tried several options in boot.ini to change to resolution to 720p but without success. I could change to resolution when kodi was running via ssh and xrandr-Command. There was still a picture after that but the GUI was somewhat broken and didn't resize properly.

    Does anyone know of a way to force a resolution? Maybe xrandr-command at startup? Or what exactly to put into boot.ini?

    I was unable to configure the Denon AVR to demand input at 720p. There are no HDMI options like this at all :-(.

    2. CEC

    I hoped that it would be possible to control kodi with my Denon AVR Remote. But nothing has worked so far. I was playing around with the cec-client command on the SSH shell to see if I get an error message, but it say that there is no link. I edited the hdmi_cec_config-File and tried to set sensible settings in the CEC plugin but I don't know exactly what I am doing...

    Can someone recommend a CEC tutorial to get me started?

    There are a few minor things (screen flicker in menu animations, spotify addon, standby activation), but those are the two main problems that keep me from throwing out my old satellite receiver.

    Thanks a lot again and have some nice holidays..

  • With

    setenv video_output "drm_kms_helper.edid_firmware=edid/1280x720.bin"

    in the boot.ini file, the desired resolution will be forced.

    For CEC, you'll have to make the port number in /storage/.config/cec-hdmi-port.conf match the one in the Kodi CEC settings and match the HDMI port on the TV. The HDMI port numbering on TV is sometime off-by-one.

  • That is exactly what I tried. But the resolution is still 1080p:

    The device is not directly connected to a TV, but to a Denon AVR. There it is on HDMI Input 1. So this should be correct?

    # cat /storage/.config/cec-hdmi-port.conf

    With Kodi CEC settings you mean "System Settings -> Input -> Peripherals -> CEC Adapter -> Physical address (overrules HDMI Port)"? Regardless of what I configure there, after a reboot it is set to 0 again...

    Thanks for your help!

  • Someone can help me? Could you tell me howto install LibreElec on my odroid U3 EmmC?
    Already tried without success (LibreElec seems doesn boot) 2 ways:

    dd if=LibreELEC-Odroid_U2.arm-8.2.2.img of=/dev/sdd bs=4M

    and with LibreELEC.USB-SD.Creator.Linux-64bit.bin selecting and writing the image.

    PS: the sd card version works

    Thanks in adv guys!

    Edited once, last by tgiorgio76 (December 29, 2017 at 6:11 PM).

  • I just picked up an Odroid XU4. I'm curious to know if this will work with the XU4 model?


  • Hello everyone!

    I am currently working with the ODROID-U3 platform and there were problems with launching

    I use for SD SD image Version 8.2.2

    uart output is as follows:

    Display Spoiler

    U-Boot 2016.11 (Dec 27 2017 - 15:07:57 +0100)

    CPU: Exynos4412 @ 1 GHz

    Model: Odroid based on Exynos4412

    Board: Odroid based on Exynos4412

    Type: u3

    DRAM: 2 GiB

    LDO20@VDDQ_EMMC_1.8V: set 1800000 uV; enabling

    LDO22@VDDQ_EMMC_2.8V: set 2800000 uV; enabling

    LDO21@TFLASH_2.8V: set 2800000 uV; enabling


    sdhci_transfer_data: Error detected in status(0x208002)!

    sdhci_transfer_data: Error detected in status(0x208002)!

    CACHE: Misaligned operation at range [bfebaa68, bfebb268]

    sdhci_transfer_data: Error detected in status(0x208000)!

    *** Warning - read failed, using default environment

    Net: No ethernet found.

    Hit any key to stop autoboot: 0

    ** ext4fs_devread read error - block

    Failed to mount ext2 filesystem...

    ** Unrecognized filesystem type **

    ** ext4fs_devread read error - block

    Failed to mount ext2 filesystem...

    ** Unrecognized filesystem type **

    ** ext4fs_devread read error - block

    Failed to mount ext2 filesystem...

    ** Unrecognized filesystem type **

    ** ext4fs_devread read error - block

    Failed to mount ext2 filesystem...

    ** Unrecognized filesystem type **

    ** ext4fs_devread read error - block

    Failed to mount ext2 filesystem...

    ** Unrecognized filesystem type **

    Odroid #

    if someone knows something tell me how to fix it


  • hi!

    I have odroid u3. tried with last 8.2.2 - there are some incompatibility with spotify plugin. Rest of features seems workable, but I stopped on this audio problem..

    Sound just gone from whole kodi if I am starting spotify, and it starts to play, but no sound, and no sound after exit spotify..

    Sound back after reboot (till I will start spotify).

    All this via hdmi. Don't know how to switch to 3,5 jack, maybe need to try. But anyway, problem with hdmi sound stay.

    How to fix this? How I can debufg this issue? I am not so familiar with kodi, but ok with linux ssh.. Where to look and what need to enable to get debug output?..


  • Thanks for the build fraggle! It works really well for the most part. Not sure if you're still working on this since it's been a while since the last update, but I've noticed something super-strange and I figured I'd just post the issue here, maybe someone else will have some pointers.

    When I boot up this build, it defaults to a resolution of 1920x1080. I prefer a lower resolution, partly because it will give me better performance, but also because my odroid is hooked up to a CRT through an HDMI->RCA box and the downscaling works better when starting from a lower resolution. So I've edited to switch the resolution to 720x480 with xrandr. This works, but when I start a video in Kodi, it is really choppy. Probably less than half the intended framerate. Interestingly, the choppiness goes away if I bring up the HUD, then everything is absolutely smooth!

    Even more interestingly, If I use xrandr to change the resolution again (while Kodi is running), the choppiness also goes away! Any resolution except the one I launched Kodi with is smooth! But of course, Kodi doesn't adapt when I change the resolution with xrandr, so I either get a tiny Kodi in the corner of my TV or I only get to see a portion of the Kodi display. But if I change the resolution back to the one I started Kodi with, the choppiness comes back, and if I restart Kodi (systemctl restart kodi) to force it to adapt to the new resolution, the choppiness also comes back, there is no way to win here!

    I also see these two lines in the kodi log when I change the resolution, I assume this is why Kodi doesn't adapt to the new resolution:

    00:23:01.764 T:3017331264   ERROR: CXRandR::Query - unable to open xrandr xml
    00:23:01.764 T:3017331264   ERROR: WinSystemX11::RefreshWindow - failed to query xrandr

    This is on an ODROID U2. Anyone else seen this? Any ideas?

    Edited once, last by Josk: Punctuation (August 18, 2019 at 7:09 AM).