1080p video playback on 720p display

  • I upgraded to LE from OE without any issues, I was worried about upgrading form a slightly different OS, but nothing blew up. Good work LE team.


    After the upgrade my 1080p content is not scaled down to match the scrren resolution of my 720p TV. There is nothing in settings, at least that I could find, that will correct this. 720p and 540p videos play correctly. The 540p video correctly scale up as you would expect. Any suggestions?

    Edited once, last by labzilla ().

  • Does not scale? Have you edited video settings? Try pushing "enter" on keyboard, or "ok" button on remote a few times.


  • Does not scale? Have you edited video settings? Try pushing "enter" on keyboard, or "ok" button on remote a few times.


    I guess a better way to descibe it would be the picture over flows the TV's screen. The picture looks cropped, it's not the capture but how it actually looks on screen. On the bottom, the seek bar is almost completly hidden, and on the top movie information is also cropped.




    Not too sure what hitting 'Ok' is supposed to do, it just pauses the movie. I have Kore remote also.


    Not sure why the video settings would change after the upgrade. I did a reset of the video settings. Not too sure what else to try.


    Thanks for the response & assistance.

    Edited once, last by labzilla ().

  • Thanks, overscan, now I know the proper name. I'll play around with some of the settings on the TV. Though I'm not sure why upgrading from Isengard to Javis would require a settings change on the TV, I haven't changed anything on the TV since Frodo.

  • That sounds odd, I think kodi has, or atleast had some settings to work around overscan.
    System -> System -> Display -> Calibration - Video Calibration.


    I guess settings from here could have been resetted somehow during upgrade. But if possible you should fix this through the tv.


    Edit:


    Also if you do video calibration in kodi because whatever reason, you might need to do it with other refresh rates as well, if you're using adjust refresh rate to match video. Then you'll need to do it for all refresh rates used. As they are calibrated separatly if I'm not mistaken.

    Edited once, last by newphreak ().

  • None of the changes I made to the settings on Kodi or the TV would correct the overscan issue. I decied to bite the bullet and do a fresh install. That worked great, 1080p videos played fine.


    Once everything was set up to my liking I decided to check the Wiki for any tweaks to the Chromebox Chromebox - Official Kodi Wiki.


    BOOM! my over scan issue was back. I discovered that System-->Settings-->Videos-->Playback: Adjust display refresh rate: is off by default. If it's set to anything else, I got the overscan problem.


    My guess this was how it was before I upgrade to LE 7.0.1. Just thought I would report my findings for anyone else, thanks for your help.


  • I upgraded to LE from OE without any issues, I was worried about upgrading form a slightly different OS, but nothing blew up. Good work LE team.


    After the upgrade my 1080p content is not scaled down to match the scrren resolution of my 720p TV. There is nothing in settings, at least that I could find, that will correct this. 720p and 540p videos play correctly. The 540p video correctly scale up as you would expect. Any suggestions?


    When the your video/movie is playing, hit "enter" and go to video settings.
    Select Video Calibration, and here you can adjust your overscan problem.

  • Overscan is a problem of your TV, not of your computer. Unless your TV is of a prehistoric origin ;-)
    It's a souvenir from the old CRT tube TVs.
    So fix your TV first if you can. Using screen calibration inside Kodi must be the last resort.

    Edited once, last by Klojum ().

  • Not true on my "early this century" Polaroid 40" flat screen. Adjusting the TV only scales the overscan to fit the TV window. When I move to a newer flat screen the default overscan calibration is fine.


    I think it has something to do with frequency; Polaroid has 59.4 Hz 1080p, not 60 Hz.

  • I have a similar experience. My 2006 Panasonic 37 inch plasma has 720p as its preferred input resolution via HDMI, but the panel is actually a prehistoric 1024x768 - It was 10 years ago! The TV has no adjustment for overscan so I always have to use the screen calibration in Kodi, pulling in left and right by about 30 pixels on each side, but generally once it is set it stays as I need it. Another more modern TV that I have with a 1080p panel always "just works".


    I keep promising myself a new TV, but the old one still works very well indeed.