S905 builds - general discussion


  • JonSnow tried it by using the update and backup app in android, then selecting update and when it searched for zip files, selecting a zip from the kodi add-ins. When it rebooted, it executed the script on the SD card to be able to boot from SD and load LibreElec. I did the same thing on my MXQ Pro 4k as I was also stuck in your situation and it worked.

  • JonSnow tried it by using the update and backup app in android, then selecting update and when it searched for zip files, selecting a zip from the kodi add-ins. When it rebooted, it executed the script on the SD card to be able to boot from SD and load LibreElec. I did the same thing on my MXQ Pro 4k as I was also stuck in your situation and it worked.


    Can you explain what zip he or you would have selected - was it from the list of files that were listed when you hit the select button? Or a Kodi apk that you used on a usb stick? Thanks

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.


  • Can you explain what zip he or you would have selected - was it from the list of files that were listed when you hit the select button? Or a Kodi apk that you used on a usb stick? Thanks


    I just selected any random zip that was found in the kodi add-ons folder on the local storage, not from SD memory or USB.

  • I just selected any random zip that was found in the kodi add-ons folder on the local storage, not from SD memory or USB.


    OK, thanks, I will give it a go. What a PITA to get LE working on this box. The box was a PITA to start with. No reset, lousy firmware, crappy remote, etc. S905X coming, so fun with that as well, no doubt.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

    Edited once, last by doggyofone ().


  • OK, thanks, I will give it a go. What a PITA to get LE working on this box. The box was a PITA to start with. No reset, lousy firmware, crappy remote, etc. S905X coming, so fun with that as well, no doubt.


    This might cause you issues with TWRP, dunno but you can try it or best option is to load up the stock rom.

  • Can wifi drivers rtl8189 be added in the build os s905.
    I flashed it in mxq pro s905.get openelec but no wifi as mine has rtl 8189 wifi.
    Thanks


    Sent from my SM-N910G using Tapatalk


  • Can wifi drivers rtl8189 be added in the build os s905.
    I flashed it in mxq pro s905.get openelec but no wifi as mine has rtl 8189 wifi.
    Thanks


    Sent from my SM-N910G using Tapatalk


    Drivers for 8189 are included from the first build. You wrote about OpenELEC and this is LibreELEC - are you sure you flashed my build? [emoji6]


    If you have the latest build installed and WiFi doesn't work, please create a bug thread and remember to include logs.

  • This might cause you issues with TWRP, dunno but you can try it or best option is to load up the stock rom.


    Probably worth flashing the original recovery first and giving that a try. The stock rom was terrible. Freezes, random boots, all kinds of problems.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.


  • Probably worth flashing the original recovery first and giving that a try. The stock rom was terrible. Freezes, random boots, all kinds of problems.


    If you have the stock recovery sure go for it. You just need any android firmware that boots properly. I said stock coz even if its terrible your going to replace it with LE anyways.

  • If you have the stock recovery sure go for it. You just need any android firmware that boots properly. I said stock coz even if its terrible your going to replace it with LE anyways.


    gutted there is no s905 x mini m8s 2 hopefully soon


  • @All: Please read and post: LibreELEC


    Hi,
    Did u happen to look at logs i posted in regards to wifi not showing in my box mxq pro 4k using ur libreelec build?
    Logs:
    ijIP


    Using latest librelec build for s905,wifi option dont show in librelec.also when powers on shows debug message lines quickly.


    thanks
    Pls help


    Sent from my SM-N910G using Tapatalk


  • Did u happen to look at logs i posted in regards to wifi not showing in my box mxq pro 4k using ur libreelec build?


    Yes I have. I would rather you posted logs according to my request (LibreELEC) but well... What is full symbol of your WiFi chip? It's 8189 and 2 or 3 letters. If the letter symbol starts with "F" I have omitted drivers for this chip by mistake and it should work in next build.


    when powers on shows debug message lines quickly.


    Don't worry about this.

  • You have to mount internal storage manually, e.g. add these lines to autostart.sh:

    Code
    1. mkdir -p /media/internal
    2. mount /dev/data /media/internal


    Hello there,


    first of all a BIG thank you to @kszag for this great implementation and hard work to bring us a funky solution using kodi on a 905 device without the stress of poorly or not at all supported android boxes. Without your work, i would surely return my box.


    I got libreelec working on my "Bqueel T95-max" box which is a nice box in general (2GB Ram, 32GB eMMC, Android 5.1. S905 020C Revision) but has audio passthrough issues in kodi (everything except standard PCM stereo sound gets drop outs all 4-5 seconds) which really drove me mad. I've done a lot of search on the net and got no really helpful input on that except "get a supported box like the wetek hub, core or play" - unless i found these builds in here.


    I was able to change recovery to TWRP by flashing the build for Minix Neo U1 P200_2G board successfully, so backups are creatable. Flashed it using TWRP-manager app. It told me flashing failed, but after a reboot to recovery it was there and it stays permanent & fully functional.


    There is no update for this box yet (Build date seems to be 2016/05/17, pretty recent), if i could give you my device tree info without an update.zip containing a dbt.img by collecting info of the running system, let me know.


    Anyways, here my findings:


    - LE runs fine using SD-Card installation, screensize perfect, framerate switching perfect on my Panasonic UHD 4k TV.
    - Everything is smooth and running exept Blutooth (although it worked before on another try, maybe my fault anywhere)
    - AC3 5.1, DD, DTS passthrough works perfect
    - DTS-HD, when enabled in Kodi settings, results in silence. When disabled in Kodi settings, it goes to my AVR as DTS (although that yamaha surely supports DTS-HD decoding)
    - TRUE-HD: no sound at all, unless i disable passthrough and get standard PCM 2.0. (my Yamaha also supports TRUE-HD decoding)


    I can live with that, but would be even happier if i'm able to sort that out.


    I was even so happy that i tried to install LE to nand, which also -like others reported- threw me back to [email protected] in Kodi, rendering every other resolution unusable like in the screenshots you've seen before. Hopefully that can be fixed, too.


    But well, my biggest "dissapointment" about the SD installation was the complete non-observance of the fast internal memory (remember 32gb) which made me thinking about switching back to android for a better performance and using pcm 2.0 sound again. Luckily enough i took the time to read all posts in here, so i found the above "mapping" of internal memory to make it visible to kodi. Setting up a path substitution for thumbnails to be created on the internal memory in advancedsettings.xml did the trick, and now i have a super-smooth gui experience AND almost perfect sound


    Again, thank you! I'll be sure to drop you some money for a beer or too..


    Here is a pic of that device:

    cheers,
    azido
    System: Bqueel T95-Max TV Box | 2 GB Ram | 32 GB eMMC | Amlogic S905 Cortex A53 Qcore CPU 2Ghz | GPU Mali-450 5-Core | WLAN 2,4 & 5 Ghz | LAN 1000/100 Mbit
    OS: Android 5.1.1 on Nand |LibreELEC 8.90.4 Build on SD

  • Yes I have. I would rather you posted logs according to my request (LibreELEC) but well... What is full symbol of your WiFi chip? It's 8189 and 2 or 3 letters. If the letter symbol starts with "F" I have omitted drivers for this chip by mistake and it should work in next build.


    Don't worry about this.


    Thanks for reply.
    Its confirmed wifi in box is 8189ftv


    Can u pls add this drivers and send me build to test .
    Thanks



    Sent from my SM-N910G using Tapatalk


  • Kszaq told you that if your 8189 started with an F he forgot the drivers and would add them in his next release. Give him time he will get it worked out for you. Asking for a test build isn't the way to go.


    Sent from my SM-G928W8 using Tapatalk