Subtitles are black in some words

  • Hello,


    My Raspberry Pi 2 with Libreelec V7.0.1 (Kodi 16.1 Git:c327c53 complied May 17, 2016) displays some wrong black word subttile in white sentence. It happens about one over five string; it means 4 strings are correct and 1 string wrong. The font encoding is arial.ttf with utf-8. The subttile is external .srt


    The error does not happen with english subttile.


    I have tried a lot of setting in system->video->subttiles and cannot fix the problem.

  • Have you checked on a different player? VLC for example? To make sure the player is the problem. The srt file could also be the cause of the problem.


    I don't think this is an LibreElec problem. You should post this on the Kodi forum.

  • Subtitle text not displaying correctly
    English sub with no matter, but in Vietnamese subtibles, some Vietnamese sentences 're good, the others 're missed, some text disappear, (2 different sub, one with dual language, one with only Vietnamese)like picture below
    cTfQplh.jpg?1
    It happen in all platforms: RPI, IMX, X86.
    For KODI 16.1 in Windows, OSX, Subtitle displaying works ok with same srt file.
    Please fix, thanks


    Edit: I found that it is Font issue, because when I copy Arial unicode MS Font from Windows to /storage/.kodi/media/Fonts/ , change subtitle font to Arrial unicode MS, subtitle showing good. Hope this help.



    Sent from my iPhone using Tapatalk

    Edited once, last by vvd214 ().

  • Thanks for the guide. I have tried to overide the default "/usr/share/kodi/media/Fonts/arial.ttf" with windows arial.ttf . However, it is in a only read-only mount system.


    mount -o rw,remount /usr


    with error "mount: can't find /usr in /proc/mounts"


    cat /procs/mounts


    does not help how to solve the problem.


    How to remount for read-write the mountpoint /usr/share/kodi/media/Fonts/ ? Thanks


  • The filesystem is read only.


    Use /storage/.kodi/media/Fonts/

  • Hi


    Overide with window arial.ttf cannot fix the problem.


    Decompressed the read-only kodi image by raspbian squashfs-tools:


    sudo mount /dev/mmcblk0p8 /tmp/kodi
    cd /tmp/kodi
    sudo unquashfs SYSTEM # it will create a folder named squashfs-root
    cd squashfs-root
    # change to kodi Fonts directory
    cd /tmp/kodi/usr/share/kodi/media/Fonts/
    ls # it will display three fonts : arial.ttf, DejaVuSans.ttf, teletext.ttf
    #overide with arrial.ttf from windows
    sudo cp /mnt/nas/arial.ttf /tmp/kodi/usr/share/kodi/media/Fonts/
    cd /tmp/kodi
    sudo mv SYSTEM SYSTEM.bak # backup old image
    sudo mksquashfs squashfs-root SYSTEM # recompress the kodi image
    cd /tmp
    sudo umount /tmp/kodi
    sudo reboot # reboot to libreelec -kodi


    Attached with screenshot with remain subtittle problem
    srt.jpg - Google Drive


    Anyway can I try to fix subtittle problem? Thanks

    Edited once, last by HoangLee ().

  • HoangLee: why are you trying to copy the font file into the read-only filesystem when you've been told to copy it into /storage/.kodi/media/Fonts ?


  • HoangLee: why are you trying to copy the font file into the read-only filesystem when you've been told to copy it into /storage/.kodi/media/Fonts ?


    Simply, there is not directory "Fonts" in /storage/.kodi/media/


    I have to use find command line to search where is the font arial.ttf so I did that.


    OK, fixed the missed characters in the default fonts by Window arial.ttf


    Now, I am happy with libreelec -kodi . Thanks a lot.

  • 1. Dont use arial.ttf font, use Arial Unicode MS (arialuni.ttf) in Windows
    2.Dont need decompressed image, waste of time.
    Just simply create new folder name "Fonts" in "storage/.kodi/media/" directory and copy "Arialuni.ttf" font (not Arial.ttf) into it, restart kodi and check subtitle opntion in Video tab.


    Hope someone fix this issue in next release.

    Edited once, last by vvd214 ().

  • So i think u can use some code :
    mkdir /storage/.kodi/media : creat foder media
    cd /storage/.kodi/media : move to media
    wget fontvn.tgz --no-check-certificate : get link font u want to install
    tar xf fontvn.tgz : Install
    rm -f fontvn.tgz


    Reboot box affter that chose u font : System/Videos/Subtitles/Fonts: etc: The font i choose Font Arial Unicode.
    Enjoy this ...
    So difficult for me ... but i'm verry excited.