[9.0.0] LibreELEC builds for MX2/G18

  • Success! What I did was loaded an ancient OpenELEC with these instructions (and files):

    Installing OpenELEC (XBMC @ 1080p) on the G-Box MX2 | Matricom – G-Box Android TV Box – Kodi / XBMC Player

    With that, I was able to get on the network with Samba and SSH. Used SSH with credentials root/openelec to do:

    tune2fs -L LIBREELEC_DISK /dev/data

    Then came in through Samba and dropped the tar file for the new LibreElec release


    in the Update folder, and rebooted.


  • I've just uploaded a new build based on 9.0.2 (Kodi 18.2).


    You can update from previous versions by placing the .tar file to the .update folder and reboot.

    The upstream Kodi 18.2 contains a bunch of fixes for Amlogic from kszaq so the MX2 should now benefit from these as well:

    Amlogic fixes from community builds by kszaq · Pull Request #15859 · xbmc/xbmc · GitHub

    And also this PR is included in the build:

    [Estuary] Fix order of TVShowTitle and Title by DaVukovic · Pull Request #15891 · xbmc/xbmc · GitHub

    crackulator The zip file for 7.95.3 is available in the first post in this thread.

  • The zip file for 7.95.3 is available in the first post in this thread.

    Indeed it is. thank you.

    I just tried the 20190424 build and it broke my box. Says what appears like it's going to attempt a recovery in 120 seconds, then a blur of messages that increment, like they are a sectors. Looks like I have to start over.

    I'd recommend caution...

  • My LE9 builds for MX2 all use the same kernel image and starting from 9.0.0 basically the same underlying OS so if the previous versions worked for you then it is highly unlikely the new build is the cause of your problem. Seems more like a NAND failure to me.

    The new build is basically just a Kodi update.

  • I recovered that box to OpenElec, and then did a direct update to the new build, and that also didn't work, this time fell out to a maintenance shell.

    I tried the update on a different box (identical, but a second instance, was already running previous LibreElec), same result, dead box.

    Could both NANDs have failed? Possible, but doesn't seem likely, they were both nicely working boxes before I applied the update.

    Anyone else boldly going where no man has gone before?

  • I believe the evidence at this point agrees with you: NAND failure. Pretty strange given that both boxes were working fine on the previous release, with no hint of trouble until I attempted the upgrade, but... must be a difference in how the memory is used by the image.

    I tried a number of different combinations on both boxes. For the most part I was able to toothpick to 7.95.3 and then upgrade to 20190226, only running into trouble with 20190424, but then I started to see similar problems even with 20190226.

    I installed to SDCARD and am running 20190424 without issue.

    False alarm, sorry to cast aspersions on your release. Really appreciate your work.

  • Unfortunately I've seen similar behaviour before. The NAND on my first box failed back in OpenELEC days and actually building a custom OE image which could use external SD card instead of the dead NAND was my primary motivation for learning how to build OE from sources.

    My NAND failed after writing a movie on it but there are several reports on the forum of failures after update to various versions.

    The best hypotesis I have is that the NAND usually fails after writing of some bigger files. During normal usage of the box there are only small writes but during the update the NAND gets more stressed and is more likely to fail.

  • With the 20190424 build, the box is frozen when I fast-forward when playing a show. This also happened when I had the last version. Any idea?

    EDIT: I have no issues with 8.0.2 posted. Only with 9.0.x. Thanks.

    Edited 2 times, last by dookie ().

  • Its probably not so much as the Nand is bad as it is that somethings flipped a bit or two in one of the control registers that have it locked.

    I have changed flash chips tons of times over the years on bad boxes and found that once i have them off and put them in a programmer i can recovery them and they work fine after that. once and a while the factories will get a bad batch that usually won't properly checksum cause they are flawed at substrate level but that doesn't happen very often.

    Based on some methods of hacking locked boot sector on certain chips things like over voltage and under voltage in a properly timed sequence will release the locking mechanism's that are built into a lot of chips for security reasons and i think based on a accumulated group of issues that sometimes the in-circuit programming being run by the SoC may be replicating those glitches at times under certain circumstances which results in what appears as bad nand when its really just locked. Most newer boxes i don't see that very often on anymore but the older boxes (especially certain factories) were more prone and usually they were a clone of some type. As well the methods of loading linux on these boxes has somewhat changed and gotten better over the years as well.

  • Hello users😃

    Just wondering if any more work is going to happen with our trusty MX2 box?

    I'm using the lastest build LibreELEC 9.0.1and it's working great.

    Thanks for all your work,help and support👍👊👏


  • I've already moved from MX2 as my daily driver but I'm considering one last update when I got some spare time. Not sure if it is going to be based on LE 9.2 or LE 9.0 though.

  • Hi, KOPRajs

    As I see, your image does not allow to load custom rc keymaps (lack of classes in /sys/class/rc/). As soon as I try to load/test the keymaps generated for non-original rc, I get - no device found...

    mx2:~ # ir-keytable -t

    /sys/class/rc/: No such file or directory

    No devices found

    Can you fix it? It would be nice to get the possibility to use non-original remote controls as it's already done in standart LE9.0 image.


  • This is a little off-topic, but I didn't know where I could ask this. Does anyone know if there are any Ubuntu or Lakka builds available for the Gbox MX2 or if anyone is working on them ?


  • Not sure you'll find to much around other then maybe some old stuff as that box is getting pretty dated now...

    I know LibreELEC and CE will work on them as i still have a couple of them kicking around but stopped aways back trying to play with them as there just for a lack of a better word "old"...

    Lakka i never had much luck with their build system being very stable from version to version so i don't bother checking it anymore...

    I did have a Slackware based system i built years ago running on one but I don't ever recall seeing anything debian/ubuntu related for that box, but maybe others have seen something...

  • No way to run last versions of acestream engine on this buid. I tried hard to no avail.

    Working on S905 devices so far.

  • I don't think you will find support for much of anything to do with acestream on this forum as it involves digital rights violations...

    someone can correct me if i am wrong, but that is my understanding...

  • I'm quite surprised. I can download Aces Stream Media and Ace Stream Engine from Google Play.

    I didn't know it was not legal for LE.