[RESOLVED] S905X Krypton: H264 23.976p frame skips

  • I have frame skips in all 23.976p videos.


    Device type:
    S905X
    Build:
    7.90.beta2
    Device:
    Mini M8S II 2GB/16GB


    How to reproduce:
    Frame rate switching is on (start/stop).
    Menu is on 1080p/60Hz.
    Audio is set to HDMI passthrough.
    Almost everything else is on default.


    -> Start any H264 23.976p video.


    Sample:
    Happens with every clean H264 encode.
    All the encodes tested work fine with 7.0.3.012c or on a RPi2 with any Krypton build.
    Specs from video in log:


    Support logs:
    Attached.
    The video only ran for a few minutes and more than 20 frame skips occurred.

    Files

    Mini M8S II 2G/16G (S905X)

    Edited once, last by jd17 ().

  • Nope, I have the same. But...as far as I know (I could be wrong), with the 8.0 beta builds, fractional refresh rates are not working...yet. Eventually, they should.

  • Well, the last info I got from kszaq is that he does not have any frame skips and the patch for 23.976fps is already implemented since a while...

    Mini M8S II 2G/16G (S905X)


  • Well, the last info I got from kszaq is that he does not have any frame skips and the patch for 23.976fps is already implemented since a while...


    I will try to contact the developer behind the latest improvements to Amlogic hardware decoding, I have some ideas why this might not work.

  • I'm also getting frame skips on 60fps video with krypton builds too, Jarvis is fine. I can't post any logs (if they'd be helpful?) as I've gone back to 7.0.3.012g, sorry.

    Devices: Mecool KI Pro S905D & Beelink MiniMX III 2G/16G S905.

    Edited once, last by Hans Gruber ().

  • Thanks kszaq, that sounds good. :)


    Hans Gruber:
    Maybe you misread the issue... This is about 23.976 frames, not 60 frames video.
    I only had the menu set to 60fps.
    Changing that to 50fps or 30fps does not have any effect on the 23.976fps video for me, as long as frame rate switching is active of course.

    Mini M8S II 2G/16G (S905X)

  • Yeah I was just adding that I get frame skips on 60 and 24fps video. Thought it might be connected.

    Devices: Mecool KI Pro S905D & Beelink MiniMX III 2G/16G S905.

  • with krypton, pulldown correction (pc:1) in codec info (keyboard o) is active even if frame rate switching is on. on jarvis codec info shows (pc:0). if frame rate switching is on. i think this is because kodi drops the "old" am-codec support. since v17 they only use Android Media Codec.


    this is from the kodi forum by a AMLogic Dev.


    "Something maybe I can add, as an internal developer inside Amlogic. XBMC/Kodi runs on Amlogic's chipset in two modes: either through amcodec acceleration, i.e. am-264/265, etc, or through the Android standard MediaCodec API (amc-XXX). If amcodec acceleration is being used, then the video playback is fully controlled in its own pipeline and Android/system does not have any effect over the frame rate conversion. The newer Amlogic's Android release has HDMI refresh rate matching, so 23.97fps source will make HDMI output goes to 23.97hz or 59.97hz accordingly. However, if MediaCodec is used (when the acceleration is off), then the rendering of video frames are all controlled by XBMC/Kodi's logic. When and how the frame rate conversion is made is all controlled by application and normally there is no way for the application to do any HDMI output mode matching without other special hacks on a rooted system."


    i don't know how libreelec will handle this stuff, but with v17 (any version) i never got (pc:0) :-/

  • LibreELEC doesn't have Android's MediaCodec, it uses amcodec and it's the only way available in "pure Linux".

  • thx kszaq, good to know!...but why i get pc:1 in the player debug view (CTRL-SHIFT-o) in version 7.95(v17 RC4)... can this be a bug in the view?

  • Hi guys,


    I think I am seeing this issue over LibreELEC (official) - Version: 8.0.2.

    I am sorry but I am not familiar with project and I do not how to track this issue to the actual fix, nor how to follow the fix to the official releases to verify if this is actually fixed on the official version that I am using or not, but I think it looks like the same thing.


    When I start system I have to change the menu setting from 50fps or 60fps to 24fps (if it is already set at 24fps I need to change to 50 or 60, and then back to 24) in order to get rid of the frame drops described in this thread.


    Please find attached syslog, I sorry If it is too long, but I did not want to cut anything that could be helpful.

    Thanks!

  • Hint - set:


    Kodi Settings > Player > Video > Adjust Display Refresh Rate > Start/Stop


    Do NOT enable Sync Playback to Display

  • Hi wrxtasy,

    Hint - set:


    Kodi Settings > Player > Video > Adjust Display Refresh Rate > Start/Stop


    Do NOT enable Sync Playback to Display

    Thanks for your reply!

    I already had 'Kodi Settings > Player > Video > Adjust Display Refresh Rate' in Start/Stop mode, and 'Sync Playback to Display' disabled.

    So unfortunately that did not solved the issue.


    Shall I posted as a bug in Bug Reports as a new issue since this is already marked as RESOLVED?


    Thanks again for your time.