LibreELEC Krypton/Leia/Agile build for Odroid C2, Rock64, WeTek Hub, WeTek Play2

  • blackride No idea are you building my source?. Looks like you are compiling aarch64. I don't support/test that. Please build official source. Also your log is cut. There is no way to see what the problem is.

  • You need "arm"

    Odroid C2

    Edited once, last by blackride ().

  • chessplayer, are you using the "official" 8.1.1 beta currently, or a community build like Raybuntu's? Thanks!

    Sorry for getting back so late! I am using the "official" beta and everything seems to work just fine (see my post at kodinerds (in German))

    Cheers,


    chessplayer



    Formerly: Intel Atom, Dockstar/Pogoplug (headless PVR Server)

    Production: Wetek Play, RPi3, Cubietruck (headless PVR Server), Nvidia Shield client, XBOX ONE Tuner, Sundtek Media TV Sticks

    Experimental: Various AMLogic S905X (W) devices

  • ( chessplayer, when I follow the instructions you linked to for downloading wide vine, I get an "aarch64 not supported!" message. Really appreciate any pointers. Is there a way we can sidebar so we don't unduly disrupt this thread?)

  • ( chessplayer, when I follow the instructions you linked to for downloading wide vine, I get an "aarch64 not supported!" message. Really appreciate any pointers. Is there a way we can sidebar so we don't unduly disrupt this thread?)

    He is using a Wetek Play which is arm. You are probably using a Wetek Play2 which is only aarch64 in the official builds.

  • Thanks GDPR-1! I'm on the WeTek Hub which I'm assuming is the same deal (aarch64).


    I'll try adding widevine etc to one of your builds instead. You mentioned I should hold off on downloading leia8, so I figure I'll try the latest krypton build instead?

  • hmm, cannot compile your tree, fails on a pynacl, suggestions ?


    BUILD pynacl (target)

    Traceback (most recent call last):

    File "setup.py", line 232, in <module>

    "Programming Language :: Python :: 3.6",

    File "/mnt/4TERA4/Leia9/build.LibreELEC-Odroid_C2.arm-9.0-devel/toolchain/lib/python2.7/distutils/core.py", line 111, in setup

    _setup_distribution = dist = klass(attrs)

    File "build/bdist.linux-x86_64/egg/setuptools/dist.py", line 319, in __init__

    File "/mnt/4TERA4/Leia9/build.LibreELEC-Odroid_C2.arm-9.0-devel/toolchain/lib/python2.7/distutils/dist.py", line 287, in __init__

    self.finalize_options()

    File "build/bdist.linux-x86_64/egg/setuptools/dist.py", line 386, in finalize_options

    File "/mnt/4TERA4/Leia9/build.LibreELEC-Odroid_C2.arm-9.0-devel/pynacl-1.1.2/.eggs/cffi-1.11.1-py2.7-linux-x86_64.egg/cffi/setuptools_ext.py", line 188, in cffi_modules

    add_cffi_module(dist, cffi_module)

    File "/mnt/4TERA4/Leia9/build.LibreELEC-Odroid_C2.arm-9.0-devel/pynacl-1.1.2/.eggs/cffi-1.11.1-py2.7-linux-x86_64.egg/cffi/setuptools_ext.py", line 49, in add_cffi_module

    execfile(build_file_name, mod_vars)

    File "/mnt/4TERA4/Leia9/build.LibreELEC-Odroid_C2.arm-9.0-devel/pynacl-1.1.2/.eggs/cffi-1.11.1-py2.7-linux-x86_64.egg/cffi/setuptools_ext.py", line 25, in execfile

    exec(code, glob, glob)

    File "src/bindings/build.py", line 32, in <module>

    ffi = FFI()

    File "/mnt/4TERA4/Leia9/build.LibreELEC-Odroid_C2.arm-9.0-devel/pynacl-1.1.2/.eggs/cffi-1.11.1-py2.7-linux-x86_64.egg/cffi/api.py", line 46, in __init__

    import _cffi_backend as backend

    ImportError: /mnt/4TERA4/Leia9/build.LibreELEC-Odroid_C2.arm-9.0-devel/pynacl-1.1.2/.eggs/cffi-1.11.1-py2.7-linux-x86_64.egg/_cffi_backend.so: wrong ELF class: ELFCLASS32

    Makefile:9: recipe for target 'release' failed

    Edited once, last by pogo1975 ().

  • I have a seriously stupid question: where is retroplayer?


    I've installed the build and the libretro cores, but I can't seem to find retroplayer itself in the repository. Is it missing, or am I just an idiot?