LibreELEC Krypton/Leia/Agile build for Odroid C2, Rock64, WeTek Hub, WeTek Play2


  • I can bump the package to 3.4 in the repo.


  • Release rb-krypton6 · Raybuntu/LibreELEC.tv · GitHub


    craggy: dvblink was updated too in the repo


    GDPR-1, tested your agile11 build on my Odroid-C2, TVHeadEnd server now works, it didn't work with your previous agile builds (I was using your Kryption builds with USB ATSC TV tuner as TVHeadEnd backend). Thanks so much.


    However, I can't get the NetFlix to work properly, I can browse through the NetFlix video listings under Netflix addon but playback is not possible. Perhaps I need to learn German to get and install the libwidevine to get it work. I already installed InputStream from your repository.

  • GDPR-1, tested your agile11 build on my Odroid-C2, TVHeadEnd server now works, it didn't work with your previous agile builds (I was using your Kryption builds with USB ATSC TV tuner as TVHeadEnd backend). Thanks so much.


    However, I can't get the NetFlix to work properly, I can browse through the NetFlix video listings under Netflix addon but playback is not possible. Perhaps I need to learn German to get and install the libwidevine to get it work. I already installed InputStream from your repository.


    Yeah tvh was broken. I didn't use it that much.
    See if that can help LibreELEC Krypton/Leia/Agile Play2 64bit kernel, 32bit libs - Page 49 - WeTek Community Forum
    I can't really give support for Netflix Addon or Widevine. Beware!! Using this Netflix Addon might be against Netflix "Terms of Service". Also not sure if one is allowed to copy widevine from Chrome.

  • Yeah tvh was broken. I didn't use it that much.
    See if that can help LibreELEC Krypton/Leia/Agile Play2 64bit kernel, 32bit libs - Page 49 - WeTek Community Forum
    I can't really give support for Netflix Addon or Widevine. Beware!! Using this Netflix Addon might be against Netflix "Terms of Service". Also not sure if one is allowed to copy widevine from Chrome.


    Thanks for your head up. As zbigbig20 pointed out, TVHeadEnd backend now works even better than Krypton + TVH42. Setup of backend server is even easier. I admire you guys got 4K x265 TV broadcast in Germany, here in North America we're still using MPEG2 TS for FTA TV broadcast.

  • Just wanted to say I've update my Odroid to the r11 release and its working like a charm. I've installed the netflix plugin to see if it runs and at least it is starting (asking for input with no description what it wants). But I guess widevine will not be needed in the future because of the support of FF without the chrome plugin.
    Yay. I'm happy for the moment.

    Edited once, last by gaelic ().


  • Just wanted to say I've update my Odroid to the r11 release and its working like a charm. I've installed the netflix plugin to see if it runs and at least it is starting (asking for input with no description what it wants). But I guess widevine will not be needed in the future because of the support of FF without the chrome plugin.
    Yay. I'm happy for the moment.


    Firefox uses widevine too. They download it. It will never work without widevine bacause that's the main DRM system. In kodi agile sometimes menus have no texts. After a reboot it should work. Netflix asks for Username and Password on first start. You need a valid legal account.

  • Thanks. And netflix with widevine works perfectly. I thought it would be a lot of work to make it running, but you just have to follow the points on the german homepage (if anyone needs some assitance please contact me or open a new thread).


    Just one thing not working for me: downloading subtitles (e.g. opensubtitles or subcenter) does not work, anyone else experiencing this?

  • No idea. Kodi-Agile is very experimental and the subtitles addon are in Kodi Addon Repo. Whole Addon system was reworked. I guess you need to wait a bit till its fixed.


  • Thanks. And netflix with widevine works perfectly. I thought it would be a lot of work to make it running, but you just have to follow the points on the german homepage (if anyone needs some assitance please contact me or open a new thread).


    Just one thing not working for me: downloading subtitles (e.g. opensubtitles or subcenter) does not work, anyone else experiencing this?


    I experienced the same issue, no subtitles that should be embedded in almost every content. However, this is not my major problem.


    I don't understand German. I just followed the instruction provided by zbigbig20 (in Wetek Forum as pointed out by Raybuntu a few post back) and SSH a line of command and it worked! But I could never got HD quality without severe audio out of sync, stuttering. It kept buffering and then after a few times playback just halted. I did change the settings of VideoInputstream but did not work. Smooth playback is only possible with very low video quality (SD). I thought Netflix use some kind of VP9 that S905 couldn't handle but I was wrong, the videos are coded in H264 and I turned on hardware decoding for H264.


    It should not be problem of network speed as my Odroid is connected thru ethernet and never experience the same playback issue with other devices (e.g. PC or tablet).

  • Oh, yes. The plugin is not 100% at its peak and I also experienced some stutters especially on the audio side and had to restart the whole box to get it working again. So it's not a flawless netflix experience at this point.


    Oh, here's the log when I try to get subtitles from a Series I've stored on the box:

    Code
    1. 19:41:57.769 T:3581256608   ERROR: Unable to create plugin service.subtitles.opensubtitles
    2. 19:41:57.769 T:3581256608   ERROR: GetDirectory - Error getting plugin://service.subtitles.opensubtitles/?action=search&languages=English&preferredlanguage=Unknown
    3. 19:42:12.218 T:3589645216   ERROR: Unable to create plugin service.subtitles.subcentral
    4. 19:42:12.218 T:3589645216   ERROR: GetDirectory - Error getting plugin://service.subtitles.subcentral/?action=search&languages=English&preferredlanguage=Unknown
  • 720p works smooth. Higher resolutions are impossible at the moment. If you still have stutters or stalled streams its due to network issues. We had one user that had a slow netflix cdn server.


  • Oh, yes. The plugin is not 100% at its peak and I also experienced some stutters especially on the audio side and had to restart the whole box to get it working again. So it's not a flawless netflix experience at this point.


    Oh, here's the log when I try to get subtitles from a Series I've stored on the box:

    Code
    1. 19:41:57.769 T:3581256608   ERROR: Unable to create plugin service.subtitles.opensubtitles
    2. 19:41:57.769 T:3581256608   ERROR: GetDirectory - Error getting plugin://service.subtitles.opensubtitles/?action=search&languages=English&preferredlanguage=Unknown
    3. 19:42:12.218 T:3589645216   ERROR: Unable to create plugin service.subtitles.subcentral
    4. 19:42:12.218 T:3589645216   ERROR: GetDirectory - Error getting plugin://service.subtitles.subcentral/?action=search&languages=English&preferredlanguage=Unknown


    As far as I understood, Netflix embedded subtitles in their video stream. I believe it's either Kodi Video Player can't decode the subtitle information or the Netflix addon didn't handle it.


    What we can do right now is wait.