HiFi Berry DAC + supported?


  • OK, the install method looks fine, but it's puzzling why you don't have the overlay file there.


    Some possible reasons:


    1. A corrupted download, though this usually affects more than one file.
    2. A bad/low quality SD card, though like the above it usually affects more than one file.
    3. As the SD card is created on a windows machine it could also be an overzealous virus scanner that quarantined/deleted the overlay file.
    Edit:
    4. It could also be the opposite of number 3: malware messing with the SD card.

    Edited once, last by Grimson ().


  • Thanks Hias the update did the job.


    It's reproducable. I did a fresh install on another SD card, there was no overlay foler.
    Updated it and there was the overlay folder including the overlays for Hifiberry.


    Thanks for the feedback!


    If it's reproducible could you please do a fresh installation and then list the contents of flash ("ls -lR /flash | paste")? Would be interesting to know what exactly is going on there. The directory listing might give a clue.


    so long,


    Hias

  • 1. A corrupted download, though this usually affects more than one file.
    2. A bad/low quality SD card, though like the above it usually affects more than one file.
    3. As the SD card is created on a windows machine it could also be an overzealous virus scanner that quarantined/deleted the overlay file.
    Edit:
    4. It could also be the opposite of number 3: malware messing with the SD card.


    1. I tried several SD cards
    2. Samsung & Sandisk
    3. I've created cards on both Windows and Mac
    4. I don't think so
    [hr]


    If it's reproducible could you please do a fresh installation and then list the contents of flash ("ls -lR /flash | paste")? Would be interesting to know what exactly is going on there. The directory listing might give a clue.


    This one is from a fresh install YUVJ

    Edited once, last by Trombone ().


  • 1. I tried several SD cards
    2. Samsung & Sandisk
    3. I've created cards on both Windows and Mac
    4. I don't think so


    I've mounted and checked all the RPI image files from the download page, and they all contained the complete overlays folder. So it must be something on your side.


    Seeing your last edit: Have a look at this thread: LibreELEC

    Edited once, last by Grimson ().


  • I've mounted and checked all the RPI image files from the download page, and they all contained the complete overlays folder. So it must be something on your side.


    It works, so I'm happy

  • Strange,
    When I add "dtoverlay hifiberry-dacplus" in /flash/config.txt of my LibreElec 7.0.1, lsmod yields:

    Code
    1. snd_soc_pcm512x_i2c     2051  0
    2. snd_soc_pcm512x        16309  1 snd_soc_pcm512x_i2c
    3. snd_soc_hifiberry_dacplus     3652  0
    4. snd_soc_bcm2835_i2s     5868  0
    5. snd_soc_core          102747  3 snd_soc_pcm512x,snd_soc_bcm2835_i2s,snd_soc_hifiberry_dacplus
    6. snd_pcm_dmaengine       2879  1 snd_soc_core
    7. snd_pcm                66625  4 snd_soc_pcm512x,snd_soc_core,snd_pcm_dmaengine,snd_soc_hifiberry_dacplus
    8. snd_timer              17221  1 snd_pcm
    9. snd                    40668  3 snd_soc_core,snd_timer,snd_pcm


    What is your version of LibreElec? If it is 7.0.1, please provide your config.txt and a log; otherwise upgrade.


    Dear LibreELEC support,


    I using LibreELEC 7.0.2 with RPi 2 and the poor audio output from the HDMI output.


    In order to improve the quality of sound I purchased the PiFi DAC v2.0. This seems to be a Chinese clone of the HiFiBerry DAC Plus.


    I wish to seek your advice on how I can enable the PiFi DAC to work with the RPi 2 and channel the analog audio output to my audio system.


    Thank you.


  • I've got a PiFi Digi and I use dtoverlay=hifiberry-digi and it works well.


    I would start out with dtoverlay=hifiberry-dac and see if that works.



  • You complain about the poor audio quality via hdmi (which I don't agree, I think the audio is great) yet you buy a cheap Chinese knock off? Hmmm.

  • You complain about the poor audio quality via hdmi (which I don't agree, I think the audio is great) yet you buy a cheap Chinese knock off? Hmmm.


    [hr]
    Sir,


    Thank you for the comments.


    Of course when I mentioned HDMI i was refering to routing the RPi 2 through my low-end Samsung TV.


    But do you really feel that the cheap Chinese HiFiBerry clone would output poor quality sound.


    Thank you.

    Edited once, last by manicam ().