Justboom Digi Zero / Passthrough

  • I've recently got a Justboom Digi Zero and installed to a Raspberry Pi Zero, and after a bit of wrestling I managed to get the soundcard detected in LibreELEC (modifying the config.txt) and could get some sound out the toslink port. However what I'm after is using this to play movies and get 5.1 surround sound on a connected amp with speakers, I've used LibreELEC on a computer no problem, but the issue with using it on a Pi is that I cannot select the relevant passthrough device needed.


    In the settings menu I can set the audio output to the Justboom card and at least get 2.0 sound from it (however no sound on anything that uses DTS or AC3), but the one issue I have is the passthrough device menu is greyed out and completely unselectable which is set to the default (PI: HDMI).


    What's the word on Justboom compatibility? Is it possible to override this menu?

  • can you post a kodi debug log and a screenshot of your audio settings

  • Hi there,


    Firstly - thanks for buying JustBoom. Super keen to get this working for you as there is no hardware reason why this should not work. We have had customers report success with getting 5.1 audio out, but not sure how they did it! Once we find out, or get it working we will make a guide as we have had this question a couple of times now.


    Also - LibreElec devs - if you want us to send you all of our hardware to test/play with then please send us a PM with the address(es) to send to so that we can sort you out with some goodies. We are super keen to support JustBoom in great open source software like yours.


    One interesting thread I found from a search was this one - LibreELEC


    Could you try passing through 5.1 audio using the 2.0 passthrough setting as suggested by Popcornmix in that thread? Or some of the other advice? One particular one that may help is commenting out the congfig.txt statement dtparam=audio=on by putting a # in front of it. Or put dtparam=audio=off in that file.


    Thanks!

  • The ALSA audio driver needs to report passthrough support for kodi to be able to use it.


    It is possible to do this through an alsa configuration file. It would like something like this (this is the HifiBerry version)
    LibreELEC.tv/HifiberryDigi.conf at master · LibreELEC/LibreELEC.tv · GitHub


    But would need device name changed to JustBoom.
    You can't write to /usr/share/alsa/cards/ in LE, but I think a file placed in /storage/.config/asound.conf will be used.

  • JustBoom it's the same for Kodi running under Raspbian (and probably OSMC as well), passthrough is only available if the soundcard provides an iec958 pcm (check with aplay -L).


    Testing with Raspbian might be easiest for you (just adapt the conf file and store it in /usr/share/alsa/cards). If you have a working conf file drop us a line and we can include it in LibreELEC.


    BTW: for the Hifiberry Digi we had to add a .driver_name to the kernel driver, otherwise ALSA would not have been able to distinguish between Hifiberry DAC (analog card) and Digi (SPDIF card).
    linux/hifiberry_digi.c at rpi-4.9.y · raspberrypi/linux · GitHub


    If no .driver_name is present ALSA falls back to using .name with underscores removed and truncated to 15 characters - which is too short if .name is snd_rpi_hifiberry_digi. You probably need to do the same for your justboom Digi/Dac drivers.


    so long,


    Hias


  • Thanks a lot for that. Is this a better way than having it natively in the driver?


    I will pass all this info onto our dev team for them to sort and write a tutorial up about.


    Is there a way to have this work "out of the box" in Kodi/LE/OSMC etc etc?


    Cheers
    [hr]


    Posted the last message before seeing this! Ok I will send this info through to dev team to fix.


    Where should we drop you a line? By PM?


    Also - are you interested in having some of our boards/cases/remotes to play with / test with at all? More than happy to send a full bundle of them over to your dev team.


    Cheers


  • Could you try passing through 5.1 audio using the 2.0 passthrough setting as suggested by Popcornmix in that thread? Or some of the other advice? One particular one that may help is commenting out the congfig.txt statement dtparam=audio=on by putting a # in front of it. Or put dtparam=audio=off in that file.


    Thanks!


    Just had a quick go at playing some videos with the audio output set to 2.0 only and it seems there still wasn't any passthrough, plus any video which used DTS encoding wouldn't play sound at all. The only other notable thing is that disabling passthrough would play anything in 2.0 at least.


    I've also got the config.txt edited for the relevant overlay, this on the latest LibreELEC alpha build but I've done the same on all different OS/media players I've used;


  • Just had a quick go at playing some videos with the audio output set to 2.0 only and it seems there still wasn't any passthrough, plus any video which used DTS encoding wouldn't play sound at all. The only other notable thing is that disabling passthrough would play anything in 2.0 at least.


    I've also got the config.txt edited for the relevant overlay, this on the latest LibreELEC alpha build but I've done the same on all different OS/media players I've used;




    It seems from the two messages above our previous one, that we need to make a few tweaks to the driver and add an ALSA config file in to get this working right. Our devs are literally rebuilding our driver and testing this as we speak.


    We, at the moment, do not have a 5.1 surround system (just about to buy a cheap second hand one on ebay for testing) so can't test it functionally. Would you be happy to help us with this?


    Thanks so much

  • By all means!


    If you could throw me an image I can put on an SD card, or any of the relevant config files when they're ready and where to put them I'll give it a whirl and report back what happens.

  • Make sure that the option "sync playback to display" is disabled as that will disabled pass through audio.


  • By all means!


    If you could throw me an image I can put on an SD card, or any of the relevant config files when they're ready and where to put them I'll give it a whirl and report back what happens.


    Sorry this took so long, bit of a busy weekend!


    We have now got the kernel changes sorted, I think, but obviously need you to help testing.


    We sent the kernel diffs to the LibreElec Devs and I think they are going to spin a test image for you pretty soon but I know they're super busy working on a new release.


    We also have 5.1 speakers and decoder arriving tomorrow so we can test it out here too :-)


    Thanks for your patience

  • Have tested this now and it seems to be working fine with a 5.1 DTS sample I downloaded from here - DTS Demo Trailers (DTS:X, DTS-HD MA, DTS 7.1, DTS 5.1) .


    Here is a picture of the settings used:



    And here is the link to the PR on Raspberry Pi GitHub, for future reference - Add driver_name properties to JustBoom drivers by shawaj · Pull Request #1787 · raspberrypi/linux · GitHub


    This testing was done on a B+ with the Digi HAT a cheap Chinese 5.1 decoder from Amazon and a set of Creative Inspire T6300 speakers.


    Chameleon - can you confirm it is working ok for you now too?


    Thanks