Posts by JustBoom

    OK we've done some more testing today.

    Tested with both 7.0.3 and 7.95.2 as the base OS and reproduced the problem. Updated these with #213 and the problem is fixed.

    So all looks good :-)

    Sorry all, don't think we had notifications turned on so think we missed these messages!

    @Hias - thanks for all the testing and glad you got the Pi Zero we sent :-)

    With regards to moving forward, saw the update from Phil on GitHub.

    For the time being should we just use the console=serial0 fix, until such time as that official patch works its way though to LibreELEC?

    OK we have tried the 7.0.3 you've suggested and Kodi gets stuck at startup on the splash screen with or without our card on the Pi Zero.
    Not much else to do here as I don't even get to SSH to it.

    I had a few minutes to play with the new build, 7.95.2. I see the same issue with the screen blanking after idle time.

    What I found suspicious was the short duration of time. I timed it, and it was almost exactly a minute. Under the audio settings is the "Keep audio device alive" setting, which defaults to one minute. I changed it to two minutes and tested again. The time to blank the screen moved to two minutes. When set to always, I haven't seen the issue occur, and I've been running it for a good while now. The screen does go dim, as expected, and can be 'woken' from the dim screen, as expected.

    Thanks again!

    Interesting so it is definitely a software issue then somewhere - what happens if instead of dtoverlay=justboom-dac you put in dtoverlay=hifiberry-dac ? Does the same issue occur?

    what happens if you try and load some audio over the command line once the screen goes blank after keep alive?

    @ Hias - will test that sure!

    Only thing is though - why would that I2S thing effect the Pi Zero but not the Pi B+ or any of the others?

    Just finished testing with #131 and #130 as advised above.

    They both were updated from 7.0.3 and they both worked fine.

    Unfortunately after a bit that I wasn't using the interface the screen blanks again. This is only happening if the JustBoom card is stacked on the Raspberry Pi Zero. This new problem happens with #131, #130 (20170130225444) and v7.95.1 BETA.
    As far as something is playing or I use the interface all works just fine.

    The 7.0.3 build on the downloads page (downloads – LibreELEC) is working fine in all tests.

    Seems this is just an issue introduced by the latest Kodi/LibreELEC updates. Not that this helps the OP who is trying to use 7.90.010, however, just thought it may help to isolate the cause of the issue.


    @ HiassofT - sure thing, we will perform those tests tomorrow and report back with results once done.

    We've got a few Pi Zeros kicking around if that would be helpful to you?

    I can test with the other kernels this weekend if this isn't resolved by then.

    Thanks JustBoom for confirming the issue! You guys have a great product, and I can't wait for it to be working with LibreELEC.

    Thanks very much - glad you like it and appreciate the kind words :-)

    Hopefully with the help of the fantastic LibreELEC team we can work out the issue pretty quickly! More testing tomorrow :-)

    Update 31-01-17 - We have carried out a series of tests and managed to replicate the issue.
    LibreELEC -> Raspberry Pi B+ -> DAC HAT No issues
    LibreELEC -> Raspberry Pi B+ -> DAC Zero No issues
    LibreELEC -> Raspberry Pi Zero -> DAC HAT Blank screen
    LibreELEC -> Raspberry Pi Zero -> DAC Zero Blank screen

    Other Kodi based OS are working fine with all of the combinations above.
    This happens when selecting the card under Settings - Audio, the screen goes immediately blank despite the rest of the system being still up and running. No changes with or without dtparam=audio=off.

    Can somebody from LibreELEC please help?

    The should definitely not blank the display when playing audio through the DAC Zero.

    Could you try it without this setting in the config:

    1. dtparam=audio=off

    I don't think it should need that to operate, and perhaps is what is causing the issue.

    Then you should be able to go to the LibreELEC menu and select the audio output as in this image - screenshot011.png

    On a side note, we are going to try and replicate the issue tomorrow, and see if we can find anything (when I am back at office - as don't have a Pi Zero at home)

    Change "Settings Level" from Basic > Advanced > Expert in the bottom-left corner of the screen.

    Aha, perfect!

    Ah mine only appears different as I applied a different skin to it (Confluence). I did some more testing and things pretty much seem dead on, everything I threw at it that was 5.1 capable played perfectly and anything that was stereo only would upmix to all speakers.

    All around great!

    Fantastic news. Thanks for bringing this to our attention and thanks to all the LibreElec people for helping us to get these updates and test images pushed out so quickly.

    Perfect, glad to hear it!

    Yes with the Digi Zero pHAT, it does not have an EEPROM on board, so you will still have to do the config.txt update to get it working.

    I was testing with a Digi HAT, which does have the EEPROM so auto configures itself.

    Your version seems to have a different menu system with a lot of extra options in the settings when compared to the beta I was testing with - maybe that's from the config update you did?

    Have tested this now and it seems to be working fine with a 5.1 DTS sample I downloaded from here - DTS Demo Trailers (DTS:X, DTS-HD MA, DTS 7.1, DTS 5.1) .

    Here is a picture of the settings used:

    And here is the link to the PR on Raspberry Pi GitHub, for future reference - Add driver_name properties to JustBoom drivers by shawaj · Pull Request #1787 · raspberrypi/linux · GitHub

    This testing was done on a B+ with the Digi HAT a cheap Chinese 5.1 decoder from Amazon and a set of Creative Inspire T6300 speakers.

    Chameleon - can you confirm it is working ok for you now too?