Tvheadend nightly builds for LE

  • You have to unpack 9.80.11-Generic-x86_64-service.tvheadend43-9.80.11.100.zip and install from the included zip.

  • if you want to play with the unfinished toys you need to be a bit more patient :)

    btw it is already there for LE10Beta1 (not yet released) so everything is fine

    Sorry, I'm confused. Does this mean there is a TVH 4.3 test build for LE10 for RPi4? I wasn't able to find it.

  • Sorry, I'm confused. Does this mean there is a TVH 4.3 test build for LE10 for RPi4? I wasn't able to find it.

    There is a TVH 4.3 test build that will come along with LE10beta1. Beta1 is not yet released, but will be soon...

  • Just installed but unfortunately I see a serious issues in Tvheadend 4.3 configuration

    - invisible Network name in menu Configuration - Networks despite it's there

    - Services from one MUX (originally added as second one) are missing in Services list despite the Network Force Scan show detected Services on it (16)... I tried to Map all services - mapped all except the "invisible" Services from that specific MUX and the Map report said "16 ignored" which is the count of Services from that MUX - really strange, I did not encounter something like that on Tvheadend 4.2. I tried to delete the affected MUX and recreate it but the issue is still same.

    So it seems Tvheadend 4.3 would be hardly usable in my case but i'll keep trying...

    Edited 4 times, last by ghtester ().

  • So it seems Tvheadend 4.3 would be hardly usable in my case but i'll keep trying...

    I have been using a TVH 4.3 build with LE 9.2.6 for a while now on a Pi4 and had no problems.


    Which build, which LE version, which hardware?

  • Tvheadend Server 4.3 (Alpha) 9.80.11.100 - Build: 4.3-1940 ~ LibreELEC Tvh-addon v9.80.11.100 (2021-03-10T21:50:53+0100)

    LE 10 Nightly, build 20210313, RPi 4B / 2GB RAM, boot from 2,5" HDD / USB-SATA adapter.

  • if you want to play with the unfinished toys you need to be a bit more patient :)

    btw it is already there for LE10Beta1 (not yet released) so everything is fine

    you surely intended to write "won't" instead of "want", won't you ? ;)

    - okay, english isn't my native language too. You'll surely find enough "JoeAverage" statements that bullet proof that -


    anyway, I was only kidding, see the smiley:

    WACKO | meaning in the Cambridge English Dictionary

    wacko is me !

    anyway 2, I completely switch to nightly.

    well, all (seems) fine here, - with some ${expected hiccup's}, though -

    DigiBit R1, NUC8i3BEH

    Edited 5 times, last by JoeAverage ().

  • - okay, english isn't my native language too. You'll surely find enough "JoeAverage" statements that bullet proof that -

    wenn du den letzten scheiß haben willst musst du aber auch damit rechnen das es nicht so easy peasy geht :)

  • OK, so after several hours of testing Tvheadend Server 4.3 (Alpha) 9.80.11.100 - Build: 4.3-1940 ~ LibreELEC Tvh-addon v9.80.11.100 (2021-03-10T21:50:53+0100) on LE 10 Nightly, build 20210313 running on RPi 4B / 2GB RAM, boot from 2,5" HDD with USB-SATA adapter, I'll have to revert from Tvheadend 4.3 Alpha to Tvheadend 4.2 due to several serious issues in my case:


    - invisible Network name in menu Configuration - Networks despite it's there

    - Services from one MUX (originally added as second one) are missing in Services list despite the Network Force Scan show detected Services on it (16)... I tried to Map all services - mapped all except the "invisible" Services from that specific MUX and the Map report said "16 ignored" which is the count of Services from that MUX - really strange, I did not encounter something like that on Tvheadend 4.2. I tried to delete the affected MUX and recreate it but the issue is still same. Tried to reboot & reconfigure but could not fix that, it's really strange and the MUX with specific frequency couldn't be used anymore.

    - Kodi sometimes gets frozen or restarted

    - the Timeshift offset point still sometimes jumps outside of Timeshift borders during seek and gets messed

    - still encountered Timeshift data unexpected cleanup

    - subtitles not displayed despite enabled on some channels

    - some EPG items corrupted (cut at start), the same issue was in Tvheadend 4.2


    So no positive change in my case but many additional and serious issues with Tvheadend 4.3 Alpha


    Edit:

    - I have "fixed" the MUX with invisible Services issue - needed to create exactly the same MUX more times, after second - 4th addition the Services from that MUX appeared by magic, then deleted the previous - not working MUXes.

    - subtitles works on most channels but on some does NOT work

    - I have reduced the Timeshift RAM buffer to 500 MB only to try improving Kodi / Timeshift seek stability. Unfortunately it did not help and I have seen again the Timeshift data unexpected clean & Timeshift stop

    - the Network name missing in Configuration - Networks menu is related to web browser version. In older Chrome it's OK, in Chrome 87.0.4280.141 build it's missing.


    Edit2:

    There's a serious bug in the mentioned Tvheadend version - at least in my HW/SW configuration the Maximum size (MB): option in Timeshift settings is ignored so it may lead to unpredictable results.

    Edited 9 times, last by ghtester ().

  • Yes I can but I am afraid it won't fix the configuration issues at all...

    I could also try to uninstall it and install again to see if at least the strange trouble with MUX is the same...

  • I’ve been using le10 in a raspberry pi4..

    No issues with tvheadend - I’ve just copied the config from the old tvheadend42 to tvheadend43


    But I have a bad video payback due to the loss of deinterlace with the DRM_PRIME (received the info from another thread).


    I just have 2 questions:


    Will it be expected to have deinterlace ability in DRM_PRIME ?

    Alternatively won’t it be possible to choose between DRM_Prime and omx/mmal, to have deinterlace available ?

  • Will it be expected to have deinterlace ability in DRM_PRIME ?

    Alternatively won’t it be possible to choose between DRM_Prime and omx/mmal, to have deinterlace available ?

    this has absolutely nothing todo with Tvheadend :)