Tvheadend nightly builds for LE

  • you can do it at the settings without an problem

    Thanks...couldn't find it...I ll have another good look now knowing setting is there somewhere...is it in configuration menu?

    Edited 2 times, last by Mario77 ().

  • I was only confused because it resetted two IPTV channels and it deleted the tv_grab_wg++ I created under .kodi/addons/service.tvheadend/bin. Will this be deleted everytime I update via install from zip?


    I suppose. You should put your own things somewhere else e.g, directly in /storage or a subdirectory of it (which won't be saved when you make a backup) or in .kodi/userdata/addon_data/service.tvheadend42 (which should be preserver in a backup).

  • Oh, I use an external grabber (webgrabplus) and send data to the fifo once it has run (the webgrabplus package will check for a before.sh script to run before the grab and an after.sh script to run, well, after, both of them in .kodi/userdata/addon_data/service.webgrabplus)

  • I use Webgrabplus too. Webgrabplus creates a guide.xml in userdata/addon_data/service.webgrabplus/ and this is processed by the tv_grab_wg skript run by tvheadendserver. Maybe one can also save this script somewhere else and set it up in tvheadend. But if a future update wouldn't kill it I am fine with this. Otherwise I have to check it out. But currently the missing of Picons in Kodi is more annoying.

  • Enable the external xmltv grabber in tvheadend, then place this in .kodi/userdata/addon_data/service.webgrabplus/after.sh (and make it executable)


    Shell-Script
    1. #!/bin/bash
    2. curl -d @guide.xml -X POST -m 5 --unix-socket /storage/.kodi/userdata/addon_data/service.tvheadend42/epggrab/xmltv.sock http://google.com


    It won't connect to google but curl needs an url, any url, it will just send the data to the tvheadend's socket.


    Edit: found here: HOWTO: Three ways to use xmltv.sock

  • I will check it out. I only use webgrabplus for one channel that isn't available over DVB-T2 and hesitated for a longer time to do so. That EPG thing is really one of the most annoying things to set up. I did it once before so this time it went quite well, but the first time was really a struggle.

  • Thanks...couldn't find it...I ll have another good look now knowing setting is there somewhere...is it in configuration menu?

    Still can't find the change ports option in the settings...looked everywhere...I m using a raspberry pi 2..thanks

  • I still couldn't get Picons to work in LibreELEC. It's not the biggest issue, but since I spent so much time with it, I would really appreciate to succeed in the end.

  • I think the paths are not the problem, as I have the Icons working perfectly in the browser under epg. I already have the network set to plain and digest.


    Might it be a problem that Server and Client are on the same machine? In the client I didn't used the 127.0.0.1 IP but the IP of the system in the LAN.

  • As I am using the service name picons for me it's something like this file:///storage/picons/tvh/daserstehd.png

    But as I said in the browser looking at the details in EPG the Picons are there. Also http://serverip:9981/imagecache/20 shows the correct image for channel 20. So for some reason it's not making the way to Kodi. Also setting up a path to the picon folder in Kodi doesn't work.

  • I know this setting is the config for the generation of the paths under settings/channels for each channel. This is working already the paths are leading to correct locations on the machine. And the Picons are there but only on Kodi I only see a TV-Symbol in the main view and in EPG the space for the logo is empty.

  • "Settings/Pvr-Live Tv/Menu Osd/Channel Logo" if this section is open, close this section.

    In the "/storage/.kodi/userdata/" section, delete the "Thumbnails" folder and reboot.