[OSX] app is very slow

  • App works on OSX El Capitan but it is very slow, every action takes several seconds, beachball shows frequently.
    When action is executed, everything works.
    Any idea?
    I tried to disable "App Nap" for the app, but it's the same.

    Nexbox A95x (S905X) running kszaq's LE 8.1.10 build

  • Same problem here. Frequent wait (coloured wheel).

    • Selecting dropdown boxes takes a very long time to respond.
    • If you move the app windows around the drop down list may stay behind on its own
    • No indication of new selection until drop close. i.e. one cannot see what you are selecting other than where the mouse pointer is pointing at.
    • From when I physically click a button e.g. download, until visual confirmation (orange highlight the button) takes several seconds (5+).
    • After several minutes waiting with no indication of a download in progress clicked again download. it then (with the usual tardiness and frequent spinning wheel) progressed through the dialogs to the point of downloading.
    • Download speed itself was ok, as long as the app did not have focus (i.e use another app while this one run in the background). The moment this app get focus, the spinning wheels return and the download will stutter.
    • Writing the image had no issues, even while the app had focus.



    I would really love for the app to work.

  • Perhaps reading or writing your images using a simple application for MACOS such as Apple Pi baker from tweakingforall is what you need. I have never had the result I want from any of the in-house usb/sd creators.


  • I have never had the result I want from any of the in-house usb/sd creators.


    Then I think you are in minority.


    The only reason for such behaviour is refreshing USB drives which happens every 1.5 seconds when app has a focus. But others didn't have problems with this.


    Support my work with small (or big) Paypal donation


    Amlogic devices works better with CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)


  • Vpeter - sorry If i gave the wrong impression and no offence meant maybe i just did not explain matters very well.
    I have used the LE usb/sd creator app. But what I find is that on occasion the process fails to complete and the progress bar at the bottom for want of a better word does not fill with a completion message. Using a MAC and pi3s, to see if anything had changed, yesterday i did a fresh install of the app. On the MAC ran the creator app and installed the appropriate LE image. Using a pi3 with LE8.0 saved a backup to usb stick.Popped the fresh sd into pi3 and restored from backup from the usb stick. Seamless and no problem. I then used the creator to write a previously saved .img for a pi1 and again worked no problem. Now to writing a saved .img for a pi3 with exact same process on 2 occasions saw the progress bar hang and process not complete whilst a 3rd attempt saw the process complete. All with brand new Sandisk 8gb sd cards. No complaints but i guess too many variables to say why for me the process works some of the time but not all of the time.

  • I also do have major issues with the app. But you just need to be patient with your clicks. And most of the time the buttons are greyed out although you can click on them.
    So it gets the job done if you only use it once in a while.


    But I think I would prefer command line.