RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • Can someone help me to get my Playstation 1 and 2 games working. Been searching for days. Nothing specific on this issue especially this custom build. Do I have to add a bios? where is the bios for ps2 located? what type of roms do I use? I can clearly see, in the es_system.cfg file, all the game specific file types for the roms. ES will recognize the file but does not run the game. What am I missing? Is it simply the file type I am using for roms? or , do I need to configure something? Where do I begin to trouble shoot? Can not run psp, psx, ps2.

    For ps1 you need 3 bios file: scph5500.bin, scph5501.bin and scph5502.bin. Put them to /roms/bios

    PS2 is too hard for my netbook, i don't try them.

  • For ps1 you need 3 bios file: scph5500.bin, scph5501.bin and scph5502.bin. Put them to /roms/bios

    PS2 is too hard for my netbook, i don't try them.

    Yes, thank you. I did that already. Worked with or without the bios files. But I can only get psx to work with the "pcsx_rearmed_libretro.so" core. Graphics are not so good. Did you get it to work with the default config,"mednafen_psx_libretro.so"? If so, is it a better core? I am running on a Intel i3 4010U with plenty of memory. I dont think ps2 would be a problem. I will put the ps2 bios bundle in the bios folder tonight and see if I can finally get it to work. Thank you.


    Oh yea, when I allow bios logo for scph5500.bin, scph5501.bin and scph5502.bin. It breaks half way through the Playstation Intro. That Sucks! had to leave it disabled.

  • Hey escalade just upgraded to the newest version "20171114" and I seem to having issues with the on-board Bluetooth. I'm working off a fresh install from the image downloaded off your Google drive. I'm not sure what the problem is, but the adapter doesn't seem to find any remote devices. I was able to get it to see my keyboard once but it couldn't connect. Tried scanning for devices with hcitool and resetting the interface but that didn't work either.


    I also noticed something weird in the settings window under Bluetooth connections. If I leave it at the message that says put your device into discovery mode, every minute or so the "Bluetooth is disabled" message pops up for a split second, like it's getting disabled and enabled very quickly. Anyway, I'm going to try the previous build "20171109" as I upgraded from an old build back in June. If you notice at the end of the log file there appears to be a segmentation fault with Bluetooth.


    Let me know what you think, thanks! :)

    Files

    • kodi.log

      (81.11 kB, downloaded 155 times, last: )
  • Edit: My bad, I totally didn't state what hardware I was using in the first post. It's late and that one was definitely on me, so thanks for scolding me! :)


    Oh, and I tried the previous build from 11-09-2017 and that presents the same problem as the newest build. I'm going to try the older version from 08-20-2017 tomorrow and see if that works. This is running on an Intel NUC7i3BNK.

    Edited 2 times, last by cragmuer ().

  • So basically, you still haven't read the first post. Especially the part in red with huge letters.


    1. I don't need your Kodi log, or whatever log you think I need. I need the one I specifically ask for and have linked to in the first post.

    2. You should check against regular LE, as I specifically have asked for.


    Don't really understand why this is so difficult to people. Just makes me less and less inclined to provide any support when people don't even bother to follow directions.

  • I understand, and I did exactly that. I went to "settings" then "system" then "logging" and copy/pasted that output into the kodi.log file I attached to my post. None of the other log files that you reference in your first post existed otherwise I would've posted them. I even searched the entire filesystem to make sure none of those log files existed and that I wasn't missing anything.


    I understand that dealing with support issues can be frustrating, especially when you say the same thing thousands of times day in and day out. That yes, this makes you a lot less included to help and support users, I really get that. But it's also likely that you'll solicit less donations when you jump down people's throats for innocent mistakes. I donated $30 bucks to your cause because I think it's a great build and I want to see you support it in the future. In fact, I'm going to throw another $30 bucks at it because it's been so great these past months and it's exactly what I've been looking to do for many years.


    If this is a simple issue of seeking help and the LE forums then I'll do that, I wasn't sure if that was the case.


    Thanks!

  • While I appreciate the donation, at this point I don't understand how I can make things any more clear. Once you follow the two points I've written to you then I'll try to help you.


    EDIT: The wiki link about the logshare seems to have changed, so I've updated the first post accordingly.

  • 3. Ignore these instructions and you will be ignored (or maybe insulted depending on the mood).

    :D:D:D


    cragmuer it seems your issue is the same I have on one of my hardware with builds since september

    you could try my fix by creating a conf file in /storage/.config/modprobe.d/ with code:

    options iwlwifi bt_coex_active=0

  • So I have been planning to dual boot LE and Lakka... but this build "appears" to do that without the dual boot, is that a fair assessment? Essentially, LAKKA is just a bootable version of Retroarch over OE, from my understanding. So rather than dual booting, this build makes me think I can launch LE and then use all the same retroarch functions and features from there. If I'm wrong, can someone clarify for me on what I'm missing or what the difference would be?


    I suppose the second question I have is does anyone know how hard it would be to get this build installed on the ROCK64? That platform has a working install of both LE and Lakka, so it would seem plausible.