RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • hi, i have been having some audio issues in restroarch kodi works just fine. i configured the asound.conf properly i believe.

    i can get sound to output while retroarch is running using SSH with the command "speaker-test -c 2 -D plughw:0" otherwise no emulator outputs sound.

    i have tried setting the audio device in the retroarch settings to "hw:0,1", ""hw:0,0", and "hw:0" as well as the default blank setting. no joy.

    Am i missing something?

    thanks in advance for any help :D

    edit: i am on a RPI3

  • How do you determine the Retroarch version installed with LibreELEC Community Edition?

    When I go into RetroArch no version info is displayed in the lower-left corner. Not sure if this is a config item, but I can't get it to display.

    I'm trying to compare 2 different LibreELEC installs (1xCommunity, 1x with RetroArch 1.5.0 installed) and wanted to confirm the verison.


  • If you go into the retroarch menu under sound you can change the option by using left or right on the joystick. Pick the correct item then exit save the settings (also in the menu) and exit retroarch. Can be done on a game by game basis.


    ssh in while your in kody use aplay -L (not the capital L) find you what sound card your using. copy that to the asound.conf file.

    i.e. in asound.conf

    # Device name can be found using the command 'aplay -L'
    default "hdmi:CARD=PCH,DEV=0"

    Now find the retroarch.cfg file and change the audio device to the same info.

    i.e. audio_device = "hdmi:CARD=PCH,DEV=0"

    Then give it a try.

  • Found it. To have the Retroarch and core info displayed in the lower-left corner there is an advanced setting to enable.

    To display the version number on the Retroarch Menu follow the following menu configurations:

    1. Settings
    2. User Interface
    3. Show Advanced Settings: ON
    4. Menu
    5. Display core name: ON
  • that is one of the things i said i tried, sorry if i didn't explain it properly.

    with L or l this is what it outputs : "

    **** List of PLAYBACK Hardware Devices ****

    card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]

    Subdevices: 8/8

    Subdevice #0: subdevice #0

    Subdevice #1: subdevice #1

    Subdevice #2: subdevice #2

    Subdevice #3: subdevice #3

    Subdevice #4: subdevice #4

    Subdevice #5: subdevice #5

    Subdevice #6: subdevice #6

    Subdevice #7: subdevice #7

    card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    LibreELEC:~ # aplay -L


    Discard all samples (playback) or generate zero samples (capture)


    bcm2835 ALSA, bcm2835 ALSA

    Default Audio Device"

    that would make the device "hdmi:CARD=ALSA,DEV=1" correct? placing that as the variable in the asound.conf and the as the retroarch.cfg still produces no sound, also the command you stated to use specifically while in Kodi gives the same results as listed above regardless of when i use the command, that would seem to indicate they are using the same devices.

    Edit: the emulation station log outputs this line of text as well "AudioManager Error - Unable to open SDL audio: ALSA: Couldn't open audio device: No such file or directory"

    Edited 2 times, last by lokiwow ().

  • I have the same problem (i5/4GB/nvidea gtx 1050)

    HTPC 1 : Intel Core i7-7700, MSI GTX 1050 2GT LP, 4GB, Asus H170M-E D3, 60GB SSD(LibreELEC 9.x RR),Origen AE S10V

    HTPC 2 : ASRock N3150-ITX , 4GB , 60GB SSD (LibreELEC 9.x RR), Silverstone Lascala LC19B-R

    NAS : Synology DS3617xs , 6 x 8TB WD Red(Movie/Serie) , 4 x 4TB WD Red(Roms/backup)

    Edited once, last by BlaBla1973 ().

  • lokiwow

    RPi doesn't need asound.conf. What you do need is dtparam=audio=on in /flash/cmdline.txt for ALSA to work at all.

    okay i went and removed the asound.conf, i have "dtparam-audio-on" in my cmdline.txt, i had it in the config.txt as well, still no luck i have tried leaving the audio device black and changing, i have tried changing the rate to 48000 and 44100 that didn't help either.

    edit: right after i posted this i removed a few settings and it worked, thank you for the help.

    Edited once, last by lokiwow ().

  • I have the same problem (i5/4GB/nvidea gtx 1050)

    This may not be the same problem at all, since your card is so new, but I was able to get my 600 and 700 series nvidia cards going by using the trick mentioned by Escalade in this thread. Basically you create a file called /storage/.config/ with the following content:

    rm /var/run/xorg-configure.done && /usr/lib/xorg/xorg-configure nvidia-legacy

    The machine will still hang on bootup with the Xorg failure screen, but after 30 seconds or so it'll eventually start up normally after that file triggers. Unfortunately while this worked decently, it would also hang up my keyboard and I would need to use Ctrl-Alt-F3 to get to a terminal, then run: service xorg restart;service kodi restart (I think) in order to fix the keyboard issue.

    I attempted to rebuild Escalade's git repo in order to edit the nvidia udev config file, which I think would force it to use the legacy driver for my problematic cards, but after messing with it for hours I gave up and just ended up using my Intel NUC device.


    Not related, but I also find that I can't launch VIDEO_TS directories from the Movie sections with Escalade's build, but MP4 files seem to work okay. I'm guessing this is just a bug in the Libreelec repo that'll get sorted out, so I haven't worried about reporting it, but thought I'd at least mention that here too since I'm typing all sorts of stuff.


    One last thing, since it probably sounds like I'm complaining a lot above: This build is awesome, and I've had so much fun messing around with it. Great stuff!

  • I don't know if this is something with the mame2014 engine, or how it's been configured under the Community Extended build, but I cannot figure out:

    1) saving of high scores

    2) saving game states (says Core does not support state saves)

    3) Enabling cheats

    This is all for traditional Arcade based games (Galaxian, Donkey Kong, etc).

    Anyone got any pointers? This is running on a x64 platform.


  • New build 20170609:

    google-chrome: depend on gtk3
    gtk3: initial package
    dolphin: update to d7faba5
    retroarch: update to 0c32835
    linux: update to 4.11.4
    xf86-input-libinput: update to 0.25.1
    libinput: update to 1.7.2
    libnfs: update to 128ac2f
    mesa: update to 4908b1e (17.1.2)
    alsa-lib: update to

    Added gtk3 so Chrome 59 works ;)

  • In the latest build I am having issues with Samba. I no longer see the devices within my network from Windows 10 and when I attempt to connect manually through the IP it will not accept the user and password. It also asks for a user and password even when this option is disabled in the libreelec config. Any suggestions?

    Edit: Nevermind. Somehow my samba.conf was causing the problem after upgrade.

    Edited once, last by c0m3r ().

  • I'm guessing it's because of the updated samba version in my build and Kodi's extremely sucky SMB implementation. Better safe than sorry. Convert your DVD's to MKV's ;)