RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)


  • Thanks for the great info. This may sound dumb, but how do I get in there to edit it? I am a noob with LibreElec/Linux. My experience is with Windows and Mac. Thanks.

  • You must edit the es_system.conf
    \\LIBREELEC\Configfiles\emulationstation\es_system.cnf


    In windows go to network and search for the libreelec share
    Then configfiles emulationstation
    The file must be there just open it with wordpad


  • You are the man!!! much appreciated. in the line <path>>/storage/roms/YOURROMDIR</path>, you accidentally typed 2 ">". Once I caught it and removed the extra character, it worked perfectly. I did change "YOURROMDIR" to the appropriate name. I am so happy to have TG16 working in here now.


    If I can get info on how to add the Emulator Home Menu option in another custom build, that would be great.
    [hr]
    I completely missed a comment by dekani on the first page who showed how to add the menu option.


    Code:
    XBMC.System.Exec(/usr/bin/emulationstation.sh)


    In the Vibe build (Xonfluence skin), I went into skin settings to the home menu options. I selected "Library" which I wanted to replace. In the pop up window, I chose "Kodi Command". The first text entry window, I typed the above command. In the second text window, I replaced the text "Kodi Command" with "Emulators". I went back to the Home Menu and it works great.


    I just never knew what the Kodi command was or the path to emulationstation.sh.


    Thanks dekani. That was a great help. I love this community.


    Thanks Waspoeder for giving me the info to copy/paste to get my TG16 to show up.

    Edited once, last by Pauly01 ().

  • After much frustration I must ask a few newbie questions:


    1. How do you make the game lists display different metadata and cover themes? I don't mind the vanilla list, but I can't seem to figure out how to work with themes. Most information I have read pertains to Windows installs of EmulationStation.

    2. Currently, to play scummvm games, I start Retroarch via a system on my list, load up the scumm core, and then my classic game via the content option. The EmulationStation website says that a scummvm game list can be populated with .sh files just the same as I can list my Genesis rom zips. What do these scummvm specific .sh scripts say?


    3. Any tips for viewing a remote desktop via Libreelec? I use an unRAID server to host a Windows 7 gaming VM (headless, nVidia 970 streams to household clients via Steam or Lime/Moonlight) and a Libreelec VM (with nVidia 730) passed through to my living room TV. I often find myself needing to manipulate something on the Windows VM so that I tweak a game or install something new. I have no idea how to containerize programs, but Docker + Linux version Splashtop/Teamviewer = Profit or are there better options?

  • LE8 is awesome, thanks for your time recreating this release.
    I have a couple questions/issues


    With emulation station can i remap buttons for the gui, say like a hotkey to quit back to kodi?
    Issues
    1# When starting Wiii games about 25% of the time it boots to the main screen of dolphin and no game is loaded.
    2# The scraper does not save anything after quitting back to kodi.


    Also can i update to Kodi 18 or do i need to wait for a new release.


    Cheers


  • Definitely do not buy the Wintel. Wireless and bluetooth is not working, there's random crashes and the BIOS is very buggy. If you want a cheap device, the Tronsmart Ara X5 Plus works good. It has minor issues as well but wifi/BT works and it's a lot more stable than the Wintel.


    If you want a real upgrade, get a NUC.


    Thanks for the heads up I've just installed your build on my old Lenovo x201 i7 :-) Any tips on what usb bt 4 adapter to buy to connect the DS4 that's supported?


  • For #2, you need to remove a line from you es config files. It's in escalades original post:


    "Gamelists are disabled, if you want to use scraping edit /storage/.config/emulationstation/emulationstation.conf and remove --ignore-gamelist from the arguments. Out of the box it will look for roms in /storage/roms. BIOS files are under /storage/roms/bios. Configured input controllers are DS3/DS4 (bluetooth) and keyboard."


  • For #2, you need to remove a line from you es config files. It's in escalades original post:


    "Gamelists are disabled, if you want to use scraping edit /storage/.config/emulationstation/emulationstation.conf and remove --ignore-gamelist from the arguments. Out of the box it will look for roms in /storage/roms. BIOS files are under /storage/roms/bios. Configured input controllers are DS3/DS4 (bluetooth) and keyboard."


    Thankyou I worked it out

  • I have another issue/question. I managed to edit the asound.conf file to get audio working in ES. Then, I had to edit retroarch.cfg to get audio working in the roms as well. When I reboot my Zbox Nano, the audio is lost again. If I open those 2 files and save again without making any changes, the audio returns. I read all over the place about editing the config.txt file for boot. I do not know where this is. I have LE installed directly on an internal hard drive. Not on an SD card. Any help or suggestions would be greatly appreciated.

  • confix.txt and SD card only on Raspberry Builds not on Zotac x86 Device. I also use Zotac Nano ID62 for the build and everything is great! Use the generic build X86


  • confix.txt and SD card only on Raspberry Builds not on Zotac x86 Device. I also use Zotac Nano ID62 for the build and everything is great! Use the generic build X86


    That is the build I am using. Why does my sound drop from ES and RA after a reboot?

  • Would it be possible to add "native" support for "Moonlight" (Nvidia gamestream)? The addon is broken and the author doesn't know how to fix the issue (cannot pair after successful connection to host). Would be great to have support for that to build the ultimate gaming/retro box.


  • confix.txt and SD card only on Raspberry Builds not on Zotac x86 Device. I also use Zotac Nano ID62 for the build and everything is great! Use the generic build X86


    I left the Nano turned off last night. I turned it on this morning and all sounds are working. Sometimes I get the GUI sounds in Kodi and sometimes I don't. I don't know why the audio works or doesn't work after each boot.


  • Pauly01 do you use passthrough?


    Apparently I do have passthrough enabled. I have shutdown and turned on the computer 3 times today (not reboot) and the audio seems to be working fine now in both ES and RA. Kodi GUI sounds are not working. But videos play fine with audio. Just an anomaly I guess. Maybe it just needed to settle down after the install.

  • 20170216:

    Code
    1. - rebased on latest le8
    2. - kodi updated to latest krypton
    3. - mesa updated to latest git
    4. - xf86-video-nvidia updated to 378.13
    5. - linux updated to 4.10-rc8
    6. - retroarch updated to latest git