RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • Hi again escalade,

    Don't know if you want to look further on this subject but I check on retropie, it seems they've done a fork of reicast here :
    GitHub - RetroPie/reicast-emulator: Reicast is a multiplatform Sega Dreamcast emulator
    perhaps it will allow to compile...

    See you

  • It doesn't compile I've tried. They forked an older version and hacked it together to compile in their environment as they do with many others. I prefer to include up to date and well maintained emulators.

  • Hello and thank you for this incredible build. I have a question I just installed the latest build for first time and setup the asound.conf like you described on page 1 however when running a test I get this message:

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 1 channels
    Using 16 octaves of pink noise
    Playback open error: -16,Device or resource busy

    Also EmulationStation log file shows:

    ConfigPath /storage/.config/emulationstation
    lvl0: AudioManager Error - Unable to open SDL audio: ALSA: Couldn't open audio device: Device or resource busy

    Kodi already frozen, nothing to do.
    lvl0: AudioManager Error - Unable to open SDL audio: ALSA: Couldn't open audio device: Device or resource busy

    What could I have done wrong? My asound.conf file is as follows:

    pcm.!default {
    type plug
    slave.pcm {
    @func getenv
    vars [ ALSAPCM ]
    # Device name can be found using the command 'aplay -L'
    default "hdmi:CARD=PCH,DEV=0"

    I still can't get sound out of Chrome and EmulationStation what am I doing wrong?

  • I got it working but now when I run these commands before running chrome to get sound working EmulationStation sound stops completely

    # touch /storage/.config/usepulse
    # pactl load-module module-udev-detect

  • Just curious, could we add systems to the frontened that aren't initially supported that are supported by RA such as PC-Engine?

  • Hi,

    I want to start Emulationstation from the main menu. Mainly I want to use FS-UAE. I have all needed files (kick13.rom, kick30.rom, yojoe.fs-uae) copied to the prefered folders in /storage/roms.

    Now, if I choose "Emulators" and Emulationstation starts, I get this message:


    What I doing wrong? Is there a HowTo to configure this?

  • Thanks for your reply. Now I can start games. But get only one disk added to the floppy list. What to do, if a game have more than one disk?

    FS-UAE also runs a bit slow. I must figure out how to make it faster. Maybe with JIT?

  • Name them disk1.adf disk2.adf etc and put them in a zip. JIT is only for OS level stuff, won't make games faster. Try "video_format = rgb565" in /storage/.config/fs-uae/Configurations/Default.fs-uae. Still not fast enough, try accuracy=0.

  • Had tried these settings in Default config. Makes not a big difference.

    Will try this with a zip archive, thanks.
    Ok. The zip thing was a very good hint :)

    Work's perfect now...

    Next step: Controller

    In FS-UAE the controller is recognized, but only the analog sticks of my PS3 controller from Hama. How I setup controllers for FS-UAE?

    Emulationstation same thing but here the controller is completelly unrecognized. The same: how to setup my controller?

    In RetroArch the controller is recognized fully. Trsted with picodrive for Sega Genesis.

    Edited once, last by nexusle ().

  • I just updated to the latest release LibreELEC-Generic.x86_64-7.95.1 but started having funny issues with my keyboard and DS4 controller within retroarch, couldn't select on either and ds4 seamed buggy. Tried with my 8bitdo controller and it was fine.

    Went back to down to LibreELEC-Generic.x86_64-8.0-devel-20170108 and it's fine now?.

    Edited once, last by bbyr ().

  • Try setting "keep audio device alive" to off in system audio settings.

    Thank you! That worked however now no audio in chrome, what else can I try?
    I even tried this

    LibreElec:~ # aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: ALC283 Digital [ALC283 Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    LibreElec:~ # pacmd list-sinks
    No PulseAudio daemon running, or not running as session daemon.
    LibreElec:~ # pactl load-module module-alsa-sink device=hw:0,3

  • nexusle

    You're on your own regarding controller configuration. There isn't a universal tool to configure all the apps, you'll need to dig into each respective documentation. FS-UAE can be configured through the Launcher (not included in this build), Emulationstation can be configured through the menus.


    Probably simplest to just don't use pulse.

    Edited once, last by escalade ().

  • doesn't work without pulseaudio. Hard to say if that goes for other sites, as I don't know why it needs pulseaudio in the first place. So far I haven't found a way to work around it. I really hate pulseaudio, since it was introduced to Linux it has caused me a lot of grief.

  • thank you for helping escalade! I will remove for now until an alternative solution can be implemented if at all possible in the future

    Back to gaming!

  • It's weird that I can open terminal with ctrl+alt+F3 on Acer Notebook. But on Zotac mini pc it opens just black screen, no terminal access.

    It's no big deal anyway. Just curious if this is only me or it is a bug or something else. (I can always use a Chrome app to get terminal access.) :)