S802/S812-Libreelec images for 7/8/9

  • You had made a Kodi 17.3 LIBREELEC version (8.0.1) exclusively for me around 7 months ago and it worked perfectly, many thanks for that.

    Do you have a link for this file? I used the latest and got the error (pictured) above on my S89.

  • I have an Acemax M8N running the 702 drieschel LE release. If use this file (LibreELEC-S8X2.arm-8.2.2-M8.tar )to update to 8.2, my remote stops working. Any ideas?

  • Hi Demetris i have seen you start working on S802 Images after Drischel stopped the image building.

    I have an Orbsmart S82 with an S802 inside what is the newest build for this device and how to flash the image to the box?

    MFG Thomas

  • I have an M8S running s802 and I'm trying to install this. Is there a guide anywhere?

    I booted to the boot menu, then chose "Install from EXT" and then chose SD Card, but nothing shows up with means I'm doing it wrong.

    Any links would be great, thanks!

  • 1: Get file LibreELEC.USB-SD.Creator.Win32.exe

    2: Use it to burn IMG file (xxx.img.gz) to SD or USB as appropriate.

    3: Plug sd or usb in and boot device using 'toothpick method' or whichover is appropriate for your device to boot to bootloader.

    4: Give it a few minutes to start up. USB may or may not be detected on all or any ports. Try another port if failed.

  • Hi Demetris,

    thank you for your hard work! I've tried all images which I tought might work for me, but unfortunately I'm not able to get wifi and sleep to work.

    I can live without sleep, just with LED being turned off, but wifi is a must have for me.

    I have OTT M8S box with s812 cpu.

    On Android the bcmdhd kernel module is being used.

    This is photo of wifi chip being used. It looks like clone of bcm4335 (look below on command output)


    After executing:

    udevadm info /sys/bus/sdio/devices/sdio\:0001\:1/

    I get:

    P: /devices/platform/aml_sdio.0/mmc_host/sdio/sdio:0001/sdio:0001:1 
    E: DEVPATH=/devices/platform/aml_sdio.0/mmc_host/sdio/sdio:0001/sdio:0001:1 
    E: DRIVER=bcmsdh_sdmmc 
    E: MODALIAS=sdio:c00v02D0d4335 
    E: SDIO_CLASS=00 
    E: SDIO_ID=02D0:4335 
    E: SUBSYSTEM=sdio 
    E: SYSTEMD_WANTS=brcmfmac_sdio-firmware-aml.service 
    E: TAGS=:systemd: 
    E: USEC_INITIALIZED=25962409

    conmactl is capable of enabling the device, but in libreelec no wireless connections are available. Also iwlist isn't able to scan available networks and states that device isn't capable of scanning.

    Do you think you could help me somehow ? Please?

    Edited once, last by haagen ().

  • Hello all,

    I have a M8s+ (Doo goo bang printed on it) that I want to install libreelec.

    I sucessfully installed the; Libreelec S8X2 default arm 7.0 devel .zip

    However, when I try to update to the latest Demetris files; S8X2.arm-M8S-plus, the installation goes well but when the device reboot it get stuck at the Goodoobang logo. I tried both .tar and the .gz files in the .update folder via shh and I get the same result. I can go back to the 7.0 dev version via thootpick reboot and .zip file on sd card.

    I've also tried the; LibreELEC-S802.M8.arm-8.0.RC4, also LibreELEC-S802.S82.arm-8.0.RC4 . zip still same results it install fine but stuck at reboot.

    The only file installing and running libreelec is the 7.0 devel mentionned at the beginning.

    Anyone might know what I'm doing wrong? thanks for your help

  • Demetris, I am running a Matricom G-box Q with an S802. I have your Libreelec 8.0, RC4 installed. This only gives me Kodi Krypton 17.1. Do you have a link or an update that has Kodi Krypton 17.6? Any help would be great.

    Edited once, last by vman1964: Can anyone help with this? ().

  • I would recommend this.

    1. Flash oem android firmware

    2. Burn LE image to sdcard

    3. Try to boot with toothpick

    4. Done

    Armada Mach 8 s802

    LAN Ethernet:10/100M

    2gb / 8gb

    Bit the Bullet and flashed OEM Android. (now no way going back to their Linux on this box)

    OEM Android Firmware

    Used OpenELEC-MX3G.arm-DualBootSD ZIP which applied script successfully for SD boot.

    I first tried LibreELEC-S802.M8.arm-8.0.RC4.img but booted to Black Screen.

    Then i tried LibreELEC-S802.S82.arm-7.0.3 which booted to libreelec splash screen with the following pic details.

    Edited once, last by kostaman: box name ().

  • So i have an mxiii 1gb that runs 7.x and 8.0.0 images fine but the new 8.x images cannot start kodi, which sigterms due to an illegal instruction.



    yes looks like your system doesn't like the mali userspace libraries we use anymore

    could be something i changed in the kernel config but i dont have any 1gb S8X2 to test sorry.