S802/S812-Libreelec images for 7/8/9

  • I have also installed AlexElec, and I'm having the same issue with the box not powering down, and having to pull the plug.

    Installing to the SD card isn't the problem here, as I did a full installation to the NAND (not running Android/LE/anything else underneath)

    The AlexElec forum is in Russian, so the information available there, via Google translate, isn't always easy to follow, if you aren't a native Russian speaker. From what I gather from the poorly translated page, Alex turned off the sleep mode by default, but this is something that should be configurable by SSH connection to the following location:


    So far, I haven't found the right "magic words" to solve the issue yet, but I haven't bricked the box either, so hopefully I'm on the right track. Given the lack of a LibreElec for this hardware (so far) at least, the AlexElec has been a great alternative.... apart from this one issue of having to yank the power cord if I want to turn it off.

  • Thank you FORD. So with what you said, I have been trying different parameters in the sleep.conf.d, but not much success.

    Forum [email protected] • Просмотр темы - CoreELEC-8.99.04 ae-fork (Amlogic S905/912) обсуждение

    on their forum, found the following information.

    I used fw_setenv and executed the following.

    Change did not save between power cycle, and also did not solve the problem.

    # fw_printenv preboot

    preboot=run factory_reset_poweroff_protect;run upgrade_check;run bootmode_check;run init_display;run storeargs;run update_key;run irremote_update;run switch_bootmode;

    # fw_printenv irremote_update

    irremote_update=irkey 0xba45ff00 0xba4594ca 1002000;if test ${irkey_value} = update; then run update;else if test ${irkey_value} = update_sdcard; then run update_sdcard;else if test ${irkey_value} = usb_burning; then run usb_burning;else if test ${irkey_value} = update_udisk; then run update_udisk;fi;fi;fi;fi;

    Edited once, last by baalho: tested with fw_setenv, so updating ().

  • Are there any tutorials for how to set up a dev environment for these boxes, where to get sources/drivers/config, modification as necessary and build (like real basic from scratch)? I have some programming experience and compiling software is something I'm familiar with in both linux and windows but where to get started building a linux kernel and rootfs for an amlogic tvbox is beyond me. The nearest I've probably come is when installing/bootstrapping Arch Linux on x86 and I'm aware that's not even close.

    I have ha a S802 M8 box for years and have very much preferred and enjoyed LibreELEC to the factory android firmware. As the original maintainer of these builds/images is no longer supporting some of the boxes anymore (thank you for all your work in the past), how can the community pick up and continue?

    Edited 4 times, last by Dr Fist ().

  • I have a MXIII 1GB S802 and the LibreELEC-S8X2.arm-8.2.1-MXIII-1G works fine

    Tough i had fixed it but nvm, i am using the following box (see link below) i tried every package so far using USB. if you have more idea's please let me know.


    the error i get is :

    E:footer is wrong

    E:signal verification failed

    Edited 3 times, last by r2range ().

  • Depending on who's M8S box you have and how old it is it should be something along the lines of the meson8m2_n200_2G dtb... Some of the specific ones to certain box will have the box model/brand in the naming scheme... I know the original ENY m8s was what i just posted but near the end of that boxes run the M8S were using the meson8m2_n200c_2G.dtd... the 2 at the end could be a 1 as that last number is based on the sram in the box... The clones of those boxes can be a real hit and miss as most will work somewhat but usually without wifi or ethernet depending on the chipset...

    Regarding the power on issues... Its been along time and for years i have used my own custom kernels that were heavily modded from the orginal 3.10 mainline but most likely the power control issues stem from the kernel your using not having the right patches applied as the fix(s) were slowly implemented as a few patches over a period of time... I did a quick look at AE's git sources and can see that most of his current releases used 3.10 kernels that don't appear to have many patches applied and may be the issue...

  • Hi,

    Boy oh boy what a frustrating experience these amlogic boxes can be. I've spent days and days reading all 90 or so pages of this topic, endlessly going back to some section or other to check back on newly gleaned nuggets of information, tried countless ways of getting all sorts of images of Librelec flashed on what I believe is an S802 MX III 1G/8G box from around 2014, to no avail, and only to end up bricking it.

    The main problem I never really got past was the file corruption error at boot time on the sd card. A usb attempt booted the Librelec install at the early stages when I still had an older Android image, but then got into a boot looop. Recovery mode seems sometimes reachable, sometimes not. Later I got the Remix image flashed and working (which also installed a working TWRP recovery) but it didn't help booting librelec from an sd card, and neither did any of the other fixes suggested (flashing 812 bootloader or image containing one, flashing dual boot fix, adding a nocompat file...). When I tried bypassing the sd card file corruption problem by flashing even earlier or different flavours of Librelec some got past boot but none ever managed to complete an install, freezing up instead or crashing with storage or memory errors.

    What's hard to comprehend is the variable behaviour of this box: sometimes one method will seem to work, then later it no longer works...very tough to proceed in a pragmatic way when the parameters keep shifting on you. I'm not sure who the manufacturer of my MX III is, I got it on Amazon and the two names mentioned in the original ad for it ("Andoer" and "Dodocool") seem at best to be very minor players so maybe I have some sub-standard clone. Under Android 4.4.x the box worked ok though but using that it seems tough to get a recent version of Kodi working properly.

    Anyway, to give merit where it's due, for the record I also have a Raspberry PI 1 B+ from around the same period, and I was able to flash Librelec 9.0.2 on it at the first try and it brought up Kodi 18.2 fine. The user experience is a bit sluggish for everyday use but it can run a 1080p video if you're patient enough for it to load up. What's annoying is I reckon the MX III hardware would probably do better than the PI...if only I had managed to get the pesky thing to make friends with Librelec.

    I guess I should just bite the bullet and buy the most up to date box for which an official Librelec image is available. Thanks to all those who contribute here and elsewhere for the ride.

  • Raspberry's and some of the other discrete vendors products usually are much easier to work with as the hardware typically comes from the same source or approved sources where as the Amlogic boards have my clones and other substandard makers and distributors that really do nothing firmware wise other then pilfer code from the bigger mainstream manufacturers which makes firmware builds a lot more picky on the box your trying to mess with...

    Things are better these days with the newer hardware then the older boxes but the same basics are still employed which is why come new boxes can still be touchy when it comes to making them work on anything other then the installed version of Android that is on the box when you buy it.

    Deciding whether or not your trying to maintain or keep a way of restoring the original version of Android is the 1st question to answer as it can change how picky things can be... basically meaning if your willing to loose the Android off the box to run something like LE or CE then you really don't have to worry as much about the signed parts of the makers bootloader as all you actually need is a boot loader with the right device tree for the hardware your messing with... where as if trying to maintain the boxes Android ability's mean that whatever you do you need to make sure to retain the properly signed and matched parts of the original makers setup or you open up a whole new world of hurt...

    Over time most none Android setups have gotten better and easier, as they basically are just altering the existing firmware bootloader to look for alternate bootloaders or bootable partitions while maintaining the matched signed parts intact allowing the original bootloader to be properly signed to load Android when you want... Even things like TWRP were created as methods of getting around the idea of having mismatched recovery bin files for the firmware your trying to load... Even with the newer hardware its still easily messed up if one totally erases the installed bootloader as the 2nd copy (backup) of the original firmwares signed parts are now gone which leads to having to find the original firmware and creating a proper boot stick or card to use something like Amlogics usb tool to try and reflash the original bootloader back into the box... Its either that or you need to setup a uart/serial debug rig to manually rebuild/repair the bootloader..

    To a large extent most of the issues stem from all the clones and people destroying the original bootloaders trying things and then not being able to find the proper firmware for the box which leads to the seemingly never ending loop of hunting/trying different firmware files trying to fix things and in the case of the older boxes it kinda comes down to is it worth the time trying to fix it for hardware that is kinda getting old by the standards of today...

    As well to be fare to the topic of the thread i will say that the builds here can be made to work on both S802 and S812 boxes as i have tested on both boxes awhile ago, so i know they can be made to work...

  • Guys I need help with my MX III 4K box.

    Used to have older version of LibreELEC flashed, and it was time for an upgrade. I've found the stock firmware and when I try any of theese:

    I tried this method, however the aml_autoscript.zip never appeared in the update&backup list. Didn't seem to pickup the SD card. So I tried the toothpick method. The box booted to the Google splash screen, sat there and eventually the screen went blank. I then tried booting to Recovery, but I could not install the script from there. Tried twice, no go. Then I booted without the toothpick and as soon as the Google splash came up I inserted the toothpick. The Libreelec boot came up and installed 18.2. So I am up and running on an MXIII-G 4K.

    Have to say, this box is still fast and runs great. Definitely worth the effort.

    Thanks again Demetris.

    i get "Filesystem corruption has been detected" error. Is this due to my SD card? Is there a way to install from USB?


  • A few days after my first post and I have a couple of breakthroughs to report!

    Thanks to a post I stumbled on elsewhere I found that my board's reset microswitch is flakey...and that by shorting its two pins on the back of the board I am able to activate the reset mode properly. This explains some of the inconsistencies I was seeing when trying to use the toothpick method to get the usb port detected, boot sd cards or go into recovery. So my device wasn't completely bricked and I got the usb burning tool back in business and flashed a working Android image to bring my MXIII back to life.

    Opening the box also yielded better information about what hardware I have...the sticker on the board says:

    NETXEON MXIII V3.1 S802/AP6181/1G/8G

    I made yet another pass at reading this topic and I noticed post #1572 (thanks Asxetos) which mentions starting by flashing and old OpenElec image from recovery and then upgrading to a more recent Libreelec image using a tar file. After hunting down a compatible image (OpenElec-Amlogic-MX3.arm-5.0.6.zip from MEGA), I tried it and sure enough, an alternative linux installation succeeded for the first time. Then I upgraded to LibreElec also without any issues (LibreELEC-S8X2.arm-8.2.3-MXIII-1G.tar from the link in post #1 of this topic).

    So my MXIII is now running LE 8.2.3 with Kodi 17.6, everything seems to work and, as I had hoped, it boots and runs *way* faster than my Raspberry Pi.

    This solution won't help anyone not prepared to sacrifice dual-boot...sadly I never found a device tree (dtb) file or any way to make a LibreElec install image boot from sdcard on my hardware.

    Now the next step would be to get an upgrade to a 9.x version of LibreElec to work (have not tried that) but as far as I understand the hardware platform I have is not being actively worked on by Demetris anymore (thanks alot for the 8.2.3 image though).


  • cool.... i am glad you got that sorted out and at least got something working...

    What you've got can be made to work on the newest stuff but unfortunately the older setup (like what you used) is not really the way anyone developing releases their packages anymore... if you noticed on the zip you used for the older stuff you can see the matched android recovery bin file that allowed the older openelec to install and being libreelec is really just a newer evolved version of OE making the switch from OE to LE works... Unfortunately it leaves you stuck at older 17,6 kodi which is starting to get a bit dated these days...

    Most newer releases these days are using scripts to patch the existing box's bootloader and open up a lot more flexibility and even tho it can be made to work on most newer boxes can sometimes be a pain to make work on some of the older (S8xx) boxes and can lead one to having to put in a lot more time trying to find the magic combination for the particular box...

    I am glad to see you at least got something going tho...

  • Hi, I want reflash my Minix X8-H, I'm not sure the exact rom to get, could someone give me a correct link?

    My device become brick at the moment. I tried everything.

    Burning Tool: running up to 95% and then crash.


    New bootloader: https://photos.app.goo.gl/nqd1w3cpgjqut6cb6 from LibreELEC 9.X / Kodi 18.X for Minix X8,X8H,X8H+

    Factory Rom: https://photos.app.goo.gl/Rdfep9T9yTCRTS7w6

    Then I tried with Burn Card Marker and I got the problem: L(0986) fail to partition the disk with 2 usb devices.

  • Sorry, but how come MXIII is not supported, when it says so in the first post?

    I will release LE9.x images for only for the two devices i own - MXIII-PLUS/MXIII-G/PROBOX2-EX-PLUS - S82/S82B/S82H/MXIII/S89/S89H and that's it.