Gamestarter: Retrogaming add-ons (RPi/Generic)

  • Hello everyone. I'm very sorry if I've over looked a solution to this in the thread, but I read through and didn't seem to see this..


    I have the latest version of LibreElec set up and functioning great. I am also using the latest version of the Gamestarter script (I believe 2.1.1). I can easily access Retroarch as it loads exactly as it should. I have setup all my game directories, thumbnails etc and again everything is fine. The problem I am running into is anytime I go to launch any rom (doesn't seem to matter for what system) Retroarch looks like it's going to load the game, the screen goes black and then I am kicked back out into the main menu of Kodi.


    I used the "Online Updater" option inside of Retroarch and updated all files as I believe mentioned.


    Has anyone else encountered this and if so can you point me towards a solution?



    Really love this app and am looking forward to using it. I guess I should add, I am using the exact same games that I previously used with several other builds on my Raspberry Pi 3 (such as Lakka, recalbox, retropie, etc) and I did not encounter this issue with those. I was able to play / load the roms without an issue.
    [hr]
    Ok so small update.. I navigated to the config area of the Retroarch UI and instead of using the regular retroarch.cfg I loaded the gamestarter version from the parent directy. After this I just tested Super Mario World for SNES and the rom opened up no problem (no sound though..have to figure out what that's about).


    I will tinker further and see if everything is sorted and post another update.


    Thanks
    [hr]



    Ok so I managed to get my HDMI audio working (thank god, this killed me on Lakka and I could never get it to work). I followed the instructions on Page 7 and added this to my config.txt


    hdmi_force_edid_audio=1
    hdmi_group=1
    hdmi_mode=16


    With that said. As of now the only emulator that doesn't kick me back to the main screen is SNES 9X Next. If I try to load games from any other system such as Sega Genesis I get booted out of Retroarch. Any ideas?


    Out of curiosity I also tried Emulation Station (though I prefer the XMB style UI of Retroarch and I encounter a similar issue there. No matter what game the system is for I just get booted back to the main Emulation Station menu.


  • If you updated cores, this can be the problem, because the ones downloaded from retroarch's repo are not optimized for raspberry. If so, yo must reinstall Gamestarter addon.

  • I recommended


    Megaddrive - Genesis Plus Gx
    Snes - Snes9x_next
    GBA - mGBA

    from the currently selected emulators in your build.


    Does anyone elese have issues with their Bluetooth controllers not automatically syncing?. I have both a 8BitDo SFC30 and NES30 Pro Bluetooth pads and both of them each time i turn the RPi device on i have to manually sync them they NEVER auto sync, any ideas why??


    Also how do you turn off all video filtering??, i have disabled HW Bilinear Filering in the video setting, but when i got back to the game there is still some sort of filtering on the screen and doesnt give a sharp pixel look??

  • If you updated cores, this can be the problem, because the ones downloaded from retroarch's repo are not optimized for raspberry. If so, yo must reinstall Gamestarter addon.


    Ah I see. For some reason I thought I read something about updating them, but that's my fault for always tinkering. So anyway I uninstalled the add-on completel and reinstalled the 2.1.1. I actually had the same issue even once I uninstalled it. What I ended up doing was using the gamestarter version of the retroarch config again and now everything seems to be working.


    I think I'll just get rid of the default retroarch.cfg and replace it with the game starter version so I don't have to keep switching everytime. Unless I can set the gamestarter version as default somehow in the menu?


    Thanks for your help it is much appreciated =)

  • Ah I see. For some reason I thought I read something about updating them, but that's my fault for always tinkering. So anyway I uninstalled the add-on completel and reinstalled the 2.1.1. I actually had the same issue even once I uninstalled it. What I ended up doing was using the gamestarter version of the retroarch config again and now everything seems to be working.


    I think I'll just get rid of the default retroarch.cfg and replace it with the game starter version so I don't have to keep switching everytime. Unless I can set the gamestarter version as default somehow in the menu?


    Thanks for your help it is much appreciated =)



    you can load reroach_gamestarter.cfg, edit all your desired options/settings, then save as retroarch.cfg, so everytime you start retroarch it will use it as your default config file.

  • you can load reroach_gamestarter.cfg, edit all your desired options/settings, then save as retroarch.cfg, so everytime you start retroarch it will use it as your default config file.


    Thank you that's exactly what I'm going to do. Honestly I really love this addon and I am glad I found it. I've had the PI for about a month and have been changing the image around nonstop. Honestly I'm not a fan of Retropie and it's very "strung together" type feel between the base / retroarch / emulation station etc. Lakka was nonstop headache for me. I had other issues with Recalbox. LibreElec is nice and simple, I get the media center capability and with this addon get a nice clean simple efficient method of playing the games with Retroarch.


    Keep up the good work!


  • What bluetooth dongle are you using?


    Did you install any extra pad driver/add-ons?


    I'm not using a bluetooth dongle ... i have a Raspberry Pi 3


    Did'nt install anything except Kodi and Gamestarter add-on ... Sony PS3 Dualshock Controller paired with RPi3 Bluetooth 1st go, and auto connects (when i press the PS button on the Controller) everytime without issue.


    *EDIT* dug out my Raspberry Pi 2 and my Orico BTA403 Mini USB Bluetooth 4.0 adaptor ... syncs fine as well with the PS3 Dualshock

    Edited once, last by Sevren68 ().

  • I'm not using a bluetooth dongle ... i have a Raspberry Pi 3


    Did'nt install anything except Kodi and Gamestarter add-on ... Sony PS3 Dualshock Controller paired with RPi3 Bluetooth 1st go, and auto connects (when i press the PS button on the Controller) everytime without issue.


    *EDIT* dug out my Raspberry Pi 2 and my Orico BTA403 Mini USB Bluetooth 4.0 adaptor ... syncs fine as well with the PS3 Dualshock



    Yeah just tried my Rpi 3 device, it neve seems to auto connect when i turn it on, and if i go to connect it manual i usually get a Bluetooth Error message, this time is was an 'Input/Output Error'.

  • Regarding RetroArch, has anybody had issues with using overlays?. Im trying to load up a Gameboy overlay for when i play gameboy games, i have the same overlays on my mian PC which work fine in RetroArch and have copied these over the the Raspberry Pi 3, but when i loaded them up i just get slightly darker screen, if i changed the Opacity via the overlay options the screen gets darker or lighter and if i change the shrink the scale i just get a 16:9 darker (depending on the Opacity ive set) square scaling smaller on the screen. Any ideas why the actual overlay doesnt show and just a black 16:9 rectangle?

  • bite_your_idols, is there any chance to include residualVM in your addon? Stumbled upon that emulator on the retropie homepage, and the possibility to play "Grim Fandango" on the pi would be great! Any thoughts about that?


    I see it is an experimental core in retroarch, also, in its github page they say it has some glitches and bugs...


    The easiest way I see to use it is compiling the colre (using retroarch's experimental compiler) then copy the core binary and paste into your own libreelec installation in retroarch's cores folder... That is how I get mame2010 and some other experimental cores...

  • Hi !!


    First, thanks for this wonderful addon.
    I'm the proud owner of a self made arcade cabinet, running with Recalbox, but being able to run old games on my main TV too, and directly from Kodi, is really a must !!


    bite_your_idols, any chance to replace the mupen64plus-libretro core with the actual mupen64plus emulator ?


    That's how it is in recalbox, and performances are really much better (for example Mario Kart 64 runs like a charm with no stuttering at all, even in menus and startscreen).
    Retropie recommends it too : Nintendo 64 · RetroPie/RetroPie-Setup Wiki · GitHub


    I can test anything if needed, I can also try and do it myself if you point me to the right direction (not sure where to put config files and so on...)
    Thx !!

    Edited once, last by NeB ().

  • It's very easy to do if the Kodi "Skin" you use supports custom entries on the main menu eg.
    i'm using an older version of Aeon Nox


    here's a list of skins that support custom home items.
    (note it's an old list and some skins are not supported / compatible with later versions of Kodi)



    Edited once, last by Sevren68 ().