Gamestarter: Retrogaming add-ons (RPi/Generic)

  • Hi,

    Does the version of emulation station that comes with this support other themes?

    For instance if I was to download one from retropie would I be able to put it into the version of emulation station and it work.


  • Strange thing.

    Gamestarter add-on on LibreELEC (official): 8.95.001 (Generic.x86_64).

    Within Kodi both keyboard and ps3 gamepad works perfect.

    Within Retroarch only keyboard works.

    I navigated to set gamepad user bind, system asks me to enter a key, but does not recognize the ps3 gamepad

    When disconnecting ps3 gamepad message states Device disconnected Port 0 .... controller not configured

    can anybody help?

  • Did you try binding from Emulation Station instead of RA?

  • I installed Emulation Station, but messages about missing systems (while retroarch sees eg snes9x core).

    Somehow I managed to be able to use a single ps3 controller (via bluetooth) within Retroarch. I applied user 1 bind all to set the buttons of controller1. However when I start the controller2 then the controller1 starts acting strange in the menu. E.g 'Down' acts same way as pagedown (all to the end of menu). When I disable controller2 behaviour is back to regular.

    Controllers seem to interfere each other?

    Fix: I have fixed the problem by turning off controller2, go to user bind 2 all (with controller1). When system asks for key input, quickly turned on controller2 and keyed in all the buttons. Now everything works fine.

    Edited 2 times, last by wtrz: Fixed ().

  • Is it normal that black system mouse stays visible within retroarch & games via retroarch? Using kodi retroplayer no black mouse.

    Solution: you have to enable full screen mode

    Edited once, last by wtrz: Solution ().

  • Hi bite_your_idols

    should retroarch + AEL work in Libreelec 9 RPI2?

    I'm asking because just updated and when i click on a game in AEL kodi is just restarting?


    I just updated and tried it.

    First try, Retroarch addon works ok, I can load roms and play it as usual.

    Then I go back to kodi and launched a game with AEL, it worked ok too.

    Let's take a look to your logs...

  • Thanks...I'll try again when back home..just got to work now sorry..

    I'll let you know and post logs if it doesnt work...

    Another question is can I load a rom from AEL into retroplayer instead of retroarch?

    Edited once, last by Mario77: Just to let you know it's working ok with Retroplayer...just need to change settings for every launcher to use retroplayer instead of retroarch...easy enough. Just wanted to try...although I m now back to LE 8 again. ().

  • Hi I've posted a issue on your GitHub.

    It seems the PS3 controller does not work withing retroarch on libreelec 9 but the controller works in emulation station and Kodi.


  • Hi I've posted a issue on your GitHub.

    It seems the PS3 controller does not work withing retroarch on libreelec 9 but the controller works in emulation station and Kodi.


    As we have discussed in github, DualShock 3 works ok (it is the controller I use in my RPi2) in LE9, the problem is when you try to connect a second DS3... Since I just have one of those (the rest of controllers I use are DS4) I can not try it by myself and I told you all solutions I would try with no luck... maybe another user over here can try it.

  • The thing is the dual shock 3 doesn't work.

    Out of the box, fresh install of LE9 nothing else installed except your retroarch, launch retroarch and the PS3 controller doesn't work in retroarch.

    As it doesn't work and does not navigate through the retroarch menu the only option is to unplug the pi which isn't good for the SD card.

    I encourage you to install LE9 on a fresh SD card then install your retroarch.

    Connect your PS3 controller and launch retroarch and then you will see, it does not work.

    Hopefully soon there will be others that also have this problem once running LE9 that way something might be done about it.


  • tested by myself, IAGL works pretty nice with Gamestarter's Retroarch addon in LibreELEC 9.

    After installing Retroarch I suggest a first run to set it up (and check downloaded cores), then, back in kodi, go to IAGL's settings > Wizard tab.

    Select "external" as launcher emulator, and then execute wizard and follow the steps.

    Pick "Gamestarter Addon" from the list and, if asked, select retroarch path "/.kodi/addons/game.retroarch/"

    Then you can launch IAGL and pick the game you want and launch/download it like a charm.

    *When in a list you can use context menu to edit launcher command and change default core/emulator per system.

    enjoy the netflix of emulation!