Blank screen on new LG TV UQ70 worked on older LG

  • I was using LE 10.something when I had to buy a new TV. The old one was an LG I don't remember the model, it worked fine for years. Installed the new TV. I hooked up my Rpi 4 and it flashed on screen for a few secs the first time but then went blank. following power cycles and moving hdmi around and LG just says no signal. I hooked it up to a monitor to verify it still worked and it worked fine on my 1080P monitor. I thought I might need to do the upgrade. So I did a fresh build of LE 11. I got to see the boot screen, had to plug and unplug a few times but then it started to work. I thought I had it. I worked for maybe 5 min, the screen flashed a few times over that 5 min. After 5 min, the screen went blank, a couple of minutes later LG says no single. That is what happens on subsequent reboots.

    I have changed the config.txt to include



    I have followed the instructions given about HDR TVs. My gui is locked in at 1080P I white listed the recommended options that I could, using a monitor obviously. Now when I plug it into the TV, sometimes I see the rainbow screen pre-boot sometimes not, then a blank screen. I know it is up because the kore remote works. I can play a movie, via Kore, but the TV just always says no signal. I have disabled CEC and enabled it and neither setting seems to work. For the short time that it did work, the CEC was working and the TV remote would control kodi.

    I have been a Linux admin for years but never very good with display issues. I don't even know where to look or what tools to tell me what the issue is. Any help would be appreciated.

  • On my LG 65CX one after the other the HDMI gave the "No signal", when 3 of 4 was unusable LG replaced the motherboard, since then there have been no problems.

  • the TV works fine with other devices. The pi4 works on other monitors. I have used osmc on this pi on this TV. But I prefer LE and kodi which is not working on this TV.

  • Add "video=HDMI-A-1:1920x1080M@60" to boot params in cmdline.txt (add to the same line). I'm wondering if it's trying to auto-select a 4K mode for desktop output and failing. That will force the DRM layer to use 1080p for the desktop instead.

  • I'm not sure what you meant when you said "add to the same line" I just put the line you suggested toward the bottom of the file above the hdmi_group stuff.

    It did not work. I did hear a garbled chime of kodi starting, then some of the clicks from using the kore remote. But still blank. I noticed the back light was flashing on and off like it kept switching resolutions but nothing ever came up. Then the sound stopped too.

  • Okay, yeah I'm dumb sorry about that. I removed the line from the config and put it before quite in the cmdline.txt file.

    After a reboot, I still get a blank screen. I get the audio from clicking buttons on kore. The screen is still blank but the backlight does not flash any more. I started a movie using kore and it is still a blank screen. The audio for the movie is all pops and crackling sounds that sound very bad for the speakers.

    Thank you for your help. What should I do next?

  • It is a brand new cable. I have tried other cables with the pi all with the same result. OSMC worked fine on this pi on this TV. I go through an HDMI switch and the other devices work fine. I believe my troubleshooting has shown it to be an issue with LE.

  • At 4K?

    I don't know at the default settings, it just booted right up. I don't really care if it is at 4k nothing I have is in 4k. So if I can disable that to make it work I will be happy.

    Try without that switch.

    I was trying it without the switch before I installed the switch for the other devices. So that does not seem to be the problem. My xbox ran through the switch for a few hours yesterday with no issues.

  • Okay so I have learned a few things.

    I switched back to see if I could get OSMC running again. It is not working. So I don't know why it worked for a while. Does the working for a while indicate the video driver hardware is being overwhelmed or requiring to send too much signal, or it is not enough signal?

    I learned that the config.txt and the cmdline.txt are pi configs not specific to LE.

    so it seems that the pi is just unhappy and that is not necessarily LE so I was wrong in using that terminology.

    I made the update you suggested, I also remove quite from the boot. So now when I turn it on I see the boot process. So it can show something. After it booted, it showed the kodi screen for about a sec then went black and had clicking from the audio.

  • Different result with the "D"?

    HDMI cables have to be conform to HDMI 2.0 or 2.1 to deliver 4K. It's a common problem that users lose HDMI connection when they switch to 4K, and most of the time a new cable is the fix.

    • try the "D"
    • try the other HDMI port of the RPi 4

    If that makes no difference...

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem
    4. Generate a log URL (do not post/upload logs to the forum)

    use "Settings > LibreELEC > System > Paste system logs" or run "pastekodi" over SSH, then post the URL link
  • So since i cannot see anything when it posts the link does it post more than one boot cycle? Because i will have to boot it then turn it off then boot it on another monitor to be able to post the logs? If not is there a cmd line way to do it?