Thoradia Add-ons

  • I have removed the Kodi settings to limit the interfaces to settings.json and web UI

    For now, set "rpc-whitelist": "*.*.*.*", in /storage/.kodi/userdata/addon_data/service.transmission/settings.json

    I will change the default rpc-whitelist accordingly for future releases of of the add-on

    Keep it legal and carry on

  • Hello,

    I try to use deluge add-on installed on a fresh libreelec on an old Raspberry 1.

    LibreELEC (official): 8.2.5 (RPi.arm)

    Everything seems to work, web-ui etc... except that deluge cannot connect to tracker (connection timed out).

    I can see UPnP redirections on my router. Deluge work well on a laptop with exactly same settings.

    Is there a way to get log or debug somehow ?

    Thanks for answers, and for the job.


    Edit: after a few a hours of confinement... it works :-)

    Edited once, last by mages ().

  • Firstly, thanks for your work on all these amazing plugins. I've been using qBittorrent with success, but recently my login details didn't work. I tried admin/adminadmin and tried to reset to defaults and uninstall/reinstall, but that hasn't worked. I saw that it was suggested to change the qbittorrent.conf file but that doesn't exist (and didn't before the uninstall). Hoping someone can help, thanks

    I have the same problem with the difference I haven't used qBittorrent before.

    I install qBittorrent, I can access the web UI, but admin/adminadmin doesn't work.

    qbittorrent.conf exists, but there's not much in it, only a few lines


    Raspberry Pi 4/LibreELEC 9.2/Kodi 18.6 (Linux Kernel 4.19.x)

    (I couldn't connect to the repo at first by choosing yes in the empty popup. Choosing no rebooted the system and it solved it. No idea what was that)

    Edited 11 times, last by number67o ().

  • How do i setup flexget with transmission (if i can) or with deluge im finding no documentation online on how to do it trough the addons.

    Thanks in advance

  • StopDirectory is set to /storage in /storage/.kodi/addons/service.rutorrent/rutorrent/conf/config.php. The highest directory rutorrent can reach is therefore /storage.


    To solve your problem, symlink your SD card somewhere under /storage.


    I recommend against editing config.php, because changes will be lost whenever rutorrent is updated.

    I was going to ask that today. Glad it has already been answered.

    I case someone wants this too, just need to do this:

    Code
    1. ln -s /path/to/file /storage

    Source: How can I symlink a file in Linux? - Stack Overflow

    Supercalifragilisticexpialidocious! (inscribed in large friendly letters)

    My hardware is a Raspberry Pi 3b

  • Hi all,

    I'm having a smallish issue, restarted my server recently and since then I can't connect to the sonarr install. radarr, deluge, bazarr, jackett etc still work but port 8989 shows unable to connect.

    I've tried looking through the logs (both sonarr and kodi) but there wasn't anything obvious to me, I tried updating through the kodi interface, also tried disabling and re-enabling but still no dice.


    last log entries are for sonarr

    Code
    1. 20-4-10 12:16:35.6|Info|Bootstrap|Starting Sonarr - /storage/.kodi/addons/service.sonarr/sonarr/NzbDrone.exe - Version 2.0.0.5344
    2. 20-4-10 12:16:36.7|Info|AppFolderInfo|Data directory is being overridden to [/storage/.kodi/userdata/addon_data/service.sonarr]
    3. 20-4-10 12:16:37.8|Info|Router|Application mode: Interactive
    4. 20-4-10 12:16:38.9|Info|Bootstrap|Starting Sonarr - /storage/.kodi/addons/service.sonarr/sonarr/NzbDrone.exe - Version 2.0.0.5344
    5. 20-4-10 12:16:39.9|Info|AppFolderInfo|Data directory is being overridden to [/storage/.kodi/userdata/addon_data/service.sonarr]
    6. 20-4-10 12:16:41.2|Info|Router|Application mode: Interactive

    any suggestions of where to look or what to do? also any idea where/how I can backup my settings and database for sonarr if I need to re-install?

  • Hi!

    First at all, deluge & its webui are working great, although I cannot connect via deluge client from PC (it says Offline despite my best efforts.)


    I did:
    -enable remote connections in daemon settings (confirmed by /storage/.kodi/userdata/addon_data/service.deluge/core.conf)
    -add new login:pass:10 in /storage/.kodi/userdata/addon_data/service.deluge/auth


    I already tried:
    -adding new connection on PC using: local ip [which should work right away, as all other services work with no issue], hostname, public ip - all offline

    -changing daemon port to different one [webui with new auth account and new daemon port works fine, PC still says offline]

    -rebooting after every single change


    Notes:
    -Webui sees PC daemon and connects to it just fine (works other way around)
    -Raspberry Pi 4 + Libreelec 9.1/9.2 + deluge addon 9.2.0.31

    -firewall in librelec options is off

    Hope someone can help :)


    Turned out it was version mismatch. Gave up on using the addon in favor of using docker container with deluge 1.3.5 cos there was no RPi4 build for last 1.3.5 as an addon.
    inb4 going other way around (2.X on PC) didnt work as expected due to YaRSS2 2.X Python3 requirement.

    Edited 3 times, last by TheRadziu ().

  • Hello. Will there ever be an update to webgrabplus version 3?


    when I tried to copy the "bin" folder, the add-on writes an error at startup. it would be good to update "mono" to the latest version.


    thanks

  • Hi,


    After a download starts I keep geting this error on trasmission: "No data found! Ensure your drives are connected or use "Set Location". To re-download, remove the torrent and re-add it."


    My drive is OK, I can acess it through DLNA or SSH. I belive this has something to do with what user Transmission is using and it's permissions. Something similiar to this: raspbmc - Transmission: permission denied on USB disk - Raspberry Pi Stack Exchange


    Can someone help me configuring the right Trasmission user and it's permission on Libreelec?


    Tks

  • ok I have a slightly worrying update, I tried uninstalling sonarr and re-installing and then restarting and now radarr, sonarr, and jackett (although I'll have to check if that was uninstalled) are not web accessible and I can't tell if they are running at all?

    Bazarr and deluge works after I started the daemon.

    still hoping someone can give advice or direction on where to start troubleshooting or anything really at this point.

  • Hello. Will there ever be an update to webgrabplus version 3?


    when I tried to copy the "bin" folder, the add-on writes an error at startup. it would be good to update "mono" to the latest version.


    thanks

    What error?

    Provide a log

    Keep it legal and carry on

  • Try updating the Sonarr addon (not uninstall/install, simply update)

    Keep it legal and carry on

  • ok I have a slightly worrying update, I tried uninstalling sonarr and re-installing and then restarting and now radarr, sonarr, and jackett (although I'll have to check if that was uninstalled) are not web accessible and I can't tell if they are running at all?

    Bazarr and deluge works after I started the daemon.

    still hoping someone can give advice or direction on where to start troubleshooting or anything really at this point.

    Provide logs

    For Sonarr: journalctl -u service.sonarr

    Got enough storage space?

    Keep it legal and carry on

  • Provide a log: journalctl -u service.transmission

    Is your drive a network drive? How did you mount it?

    Keep it legal and carry on

  • Thanks thoradia, and apologies for my lack of knowledge/research

    I've attached both the radarr.log and sonarr.log logs to this message but seems to be a mono error?


    for references since I haven't mentioned it yet, running libreelec 9.0.2 on a HP Proliant N54L

    not sure it's storage space as my 4 data drives have at least a terabyte each, although /storage has only 120mb but i'm not sure what's actually taking up space in it...

  • what I have to do to check if a service is connected with thoradia virtual interface? for example with libtorrent.conf?

  • Is this what you're looking for?

    I'm using a oulet powered USB HD. Using the automount.


    Tks

    Thank you for the log, but I see nothing relevant to the error you mention

    Transmission is using root, as everything on LibreELEC, eg you when you ssh

    ssh into LibreELEC, try to write something to the directory Transmission is pointing to, and tell me what happens

    Keep it legal and carry on