VC1 audio lag

  • Hi, I'm hoping for some advice, please.

    The issue seems to be related to VC1 MKVs. With every file I've tried, the image is about a second ahead of the audio. I've tried alternating resolutions, passthrough, adjusting refresh rate, interlacing, etc. Nothing seems to make any difference. I've also tried adding the VC1 and Mpeg Foundation decoding keys, but the issue remains. Neither H264/Mpeg seems to have a problem with playback so far.

    Grateful for any thoughts on why this might be happening. I'm using 10.0.2 on a Pi 3B. Not at all sure why, but I just couldn't get my Pi 4 to run LibreElec smoothly, at all. Even navigating menus was sluggish, let alone attempting to play VC1, hence reverting to the 3B.

    That said, thank-you to the team for your continuing hard work!

  • Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem
    4. Generate a log URL (do not post/upload logs to the forum)

    use "Settings > LibreELEC > System > Paste system logs" or run "pastekodi" over SSH, then post the URL link
  • The problem is quite simple - the Pi3 and Pi4 does not have enough power to software decode 1080p VC-1 with the current ffmpeg software decoder. This decoder is single-threaded.

    Pi3 can hardware decode VC1 if you buy the key but LE 10 no longer supports these decoders.

    If you want to use these hardware decoding, you must stay on LE 9

    Pi4 does not have VC1 hardware decode at all.

    The good news is that some developers are working on some NEON optimisations for the decoder. So maybe in the future it is possible to play 1080p VC1 on these platforms.

    See this thread for more details: