Upgrading from pi 3 to pi 4, maybe, what do you think

  • Hi there, first time poster here. I've been on libreelec for about it year on my Raspberry pi 3, works very well BUT sounds skips sometimes. I was thinking about upgrading to a Raspberry pi 4 in the hope the boost would help out. Would I be able to just plug the old SD card into the pi 4 or would I need to start over from scratch? Many thanks. BUT, is it worth it? Would I notice an improvement? I have the guide turned off on my IPTV because it takes too long to load but maybe it would be faster on the pi 4.

  • No, you have to install an RPi 4 image. However, I suggest to find the issue of your RPi 3 first, just to avoid a useless purchase...

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem
    4. Generate a log URL (do not post/upload logs to the forum)

    use "Settings > LibreELEC > System > Paste system logs" or run "pastekodi" over SSH, then post the URL link
  • Thank you, I'll do my best to reproduce it. I notice it most when watching live tv and the audio is of someone talking but in a very stop-start way. Like if someone is talking but not continuously then the audio doesn't always kick back in straight away when they resume talking. My limited knowledge has my thinking it might be due to "50/60fps H264 HW decoding may need force_turbo=1 or core_freq_min=500 in config.txt to avoid AV-sync-issues/skipping" but I think h264 works better on pi 4? Am I reading https://libreelec.tv/2022/03/09/libreelec-matrix-10-0-2/ correctly? :) Is H264 likely to get better?

  • Thank you friends! For me "pastekodi" does not work, I get the message

    error=1 error_msg="Command not registered"

    Use 'vcgencmd commands' to get a list of commands

    So I am using pastebin :) I'm guessing the problem is with

    "WARNING: ActiveAE - large audio sync error"

    I know I am to upload the full log but it's making pastebin page crash for me on my browser, I think it's too big. When I tried to paste less of my log it will still beyond its 512 KB limit. So this is the best I could do :)

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

  • It's an AAC audio error. Expect the same error on RPi 4. So I don't suggest to purchase one. Install latest LE 10.0.2 from scratch (don't upgrade), play some free AAC demos, and report.

  • Cheers :) one small issue though. One reason I switched to libreelec is because osmc wouldn't allow me to use my 3.5 mm analogue for speakers anymore. I see the same issues is in the latest update of libreelec. That is, under sound, the analogue option is gone and I only see hdmi for sound output. Why do you think that is? I use a hdmi pc monitor for video and a small speaker in the 3.5 mm for audio you see. So at present I have no sound.

  • Cool cool, I don't know why that didn't work in osmc :P anyway working now! My wife has been watching TV and has reported no sound skipping so, so far so good. Many thanks Da Flex.

  • Ok.. this is a very similar problem to mine.. Rpi4 4g .. fresh libreelec install... nothing else added and I have read all I can.. this is the closest I have come.. and followed the instructions from post #10... confirmed that all hardware is working.. boot up Raspbian and play youtube videos with sound no problem... libreelec plays the video but no sound from the 3.5 jack..

    BTW... extremely new to this...

    Well it didn't work for me... any suggestions...

  • Ok... well did a bunch more reading and testing and finally came up with the solution.. first it was the fact that I was trying to play a movie from a dvd player plugged into the Rpi.. this still seems to be a problem.. but may come down to a codec..

    Originally I had missed the option in the /settings/system menu and selecting the the headphone jack option because it was not highlight to be able to change.

    Once you add this... "Add the line , dtparam=audio=on " to the config.txt file.. you can then go back to the setting/system menu and select the output headphone jack option..

    At this point you should or at least I did.. start hearing " system " sounds.. if you hear this the this has worked..

    As for playing a dvd movie... that's a tomorrow problem..

  • took a look @hifiberry , however, there seem no board offered for 3.5 mm headphone jack (the last remaining is sold no longer, besides OEM) , so would be nice if the 3.5mm headphone jackbe accessible OOTB.

    Shop | HiFiBerry

    EDIT: oh, i did not look carefully enough, ther are some "pro" variant DAC that have also the 3.5mm jack, but those cost around the size of a complete Raspberry Pi, therefore not so attractive.

  • The Raspberry Pi DAC+ and DAC Pro (formerly IQaudio DAC+/Pro) come with a 3.5mm jack and cost about 20-25 bucks.

    Buy a Raspberry Pi DAC+ – Raspberry Pi
    Raspberry Pi DAC+ is a high-performance audio HAT compatible with any Raspberry Pi computer that has a 40-pin GPIO header. With the Texas Instruments PCM5122,…
    Buy a Raspberry Pi DAC Pro – Raspberry Pi
    The Raspberry Pi DAC Pro is our highest-fidelity audio HAT, and is compatible with any Raspberry Pi computer that has a 40-pin GPIO header. With the Texas…

    so long,