[rpi2 addon] moonlight wont launch

  • Ive been messing with this and i cant get it so play any sound. Ive had some help but still no solution to the sound issues.


    LibreELEC


    Has anyone got sound working on this on x64?

    Edited once, last by stuCONNERS ().


  • I have the same issue on a GTX650ti. I see you have PULSE;CEC in your moonlight log, could it be you are using the Pulse Eight CEC adapter? I also use this adapter, maybe thats whats causing the issue.

  • It works fine on RPi 2, however, it does not change resolution or bitrate, tried doing it manually to settings.xml in /storage/.kodi/userdata/addon_data/script.moonlight/, doesn't work:
    Tried even changing settings-default.xml in /storage/.kodi/userdata/addons/script.moonlight/, didn't work eiter :/
    So no change. Tried updating Geforce Experience to Beta and tried to remove the device and paired again..
    Any ideas?


    EDIT:
    Works now. It seems you have to restart Libreelec before new settings get loaded.


    However, triggers on 360 controller did not work. X and y buttons were swapped, on the d-pad: up and left were swapped, same with down and right. Here is my working xbox360.conf, should be placed in addons/script.moonlight/share/mapping/, rename the other one to xbox360.conf.old and try it out:


    Have fun

    Edited once, last by siz ().

  • The addon doesn't work for me on raspi 3, with LibreELEC 7.0.2, Moonlight 7.0.101. Where can I find the logs regarding moonlight?


    The addon is installed and shows my games (pairing worked flawlessly) but if i click on a game, nothing happens. I use the following settings:

  • I tried this also still no luck.


    Steam - OpenELEC


    I`m still to get a bluetooth controller to work on x64. My PS3 controller if wired and controller support in kodi is disables works. Bluetooth connections dont work, I found the same on a Rpi 3. Only wired controllers work.

  • Did anyone mange to get sound with moonlight? I'm using the lastest x86_64 generic build #0902.


    I can play a test.wav with the following commands:

    Code
    1. aplay -D hdmi:CARD=HDMI,DEV=1 test.wav
    2. aplay -D hw:0,7 test.wav


    But using hdmi:CARD=HDMI,DEV=1 or hw:0,7 as audio device doesn't work. Can anyone point me in the right direction please?


    @Rumo, snixel & Zoba: I had the same problem with SDL: could not create window - exiting. After upgrading to the latest nighty build, it was working like a charm besides my audio issue.

    Edited once, last by raynetec ().


  • I fixed my image problem by disabling 'Force HW acceleration'. Turns out you need to reboot before the changes take effect.
    Cant get sound to work either, also tried with hw:x,x but it doesnt change anything.


    Same for my controllers. I use wired logitech chillstreams with the same layout as xbox360 but using default or xbox360 mappings doesnt work. They do work in kodi tho

  • I'm pretty sure that hw:0,7 is the right audio device, because every other addon and aplay -D gives me an output but i checked every other device as well by starting moonlight with:

    Code
    1. moonlight stream -audio hw:X,Y 192.168.1.10


    The moonlight addon is running as intended on my raspberry pi 3 (with audio!). My x86_64 system still gives no audio in moonlight with nightly build #0912.


    snixel Did you try the xbox360.conf posted by siz? It works for me though i'm using an original xbox360 controller.


    //edit
    moonlight console log:

    Edited once, last by raynetec ().

  • Hi, could some one tell me who is updating add-ons on LibreELEC repo? I am curious when will be 2.2.3 Moonlight version available on repo for LE?


  • Hi, could some one tell me who is updating add-ons on LibreELEC repo? I am curious when will be 2.2.3 Moonlight version available on repo for LE?


    It was (probably) the 2.2.3 but Iwan forgot to update CMakeLists.txt. Anyway latest version is now 2.3.0 ...

  • But it is not in official LibreELEC repo yet. I'm not that skilled to compile it my self, so question stands, is there any one able to update repos version of Moonlight?

  • Hi, I'm having problem with this addon too, the moonlight emb official has been updated to 2.3.0 and the addon has not been updated. It seems 2.2.2 and 2.2.3 don't work with latest's GFE version, so I'm wondering how can we get it updated. Any way to help to do this ?


    Thanks.