Black screen and no sound on some files after 10.0.2 update

  • Hi,

    I've updated to 10.0.2 yesterday (on a Pi4 2gb) and since then, I do have a strange behaviour with files that worked previously (10.0.1)

    It is a batch of almost 300 files, coming from a TVShow, small files of 5min duration.

    They played perfectly under LibreElec 10.0.1

    Now with 10.0.2, I get a black screen and no sound with all of them.

    TV still gets a signal, but black screen and no sound, I can't even display the OSD.

    BUT, I can see the progress bar still running in Yatse remote, and I can even stop the playing...


    I've downgraded to 10.0.1, and files are now playing without any problem.

    Didn't touch any setting between update/downgrade.


    FYI this is one of the files that I have problem with, if anyone want to try and find why they don't work anymore with 10.0.2... :-/ :-/

    Kaamelott.S01E004.Le_Chevalier_Mystere.mkv
    Shared with Dropbox
    www.dropbox.com


    and the mediainfo part :

    Edited 2 times, last by NeB ().

  • I have (almost) the same issue. After updating to 10.0.2, a couple of 4K files simply won't play anymore whereas with 10.0.1 they played flawlessly. Don't know what changed, seems like a major bug to me.

  • Same problem with Pi 4 4GB and LibreELEC-RPi4.arm-11.0-nightly-20220323-9390f49

    LG 65CX and certified cable, no problems with other 4k 10bit HDR files.

    Edited once, last by MatteN ().

  • NeB the file also plays fine here on RPi4 - both on LE10.0.2 and nightly and both on my HD monitor and 4k TV.


    Note that this is a 10bit video so RPi4 may now output it in 10 or 12bit, depending on the capabilities of your TV.


    Check your TV's settings, try a different HDMI cable (bandwidth could now be 50% higher than before) and post a debug "pastekodi" log if the issue persists.


    so long,


    Hias

  • TV is 10bits compatible, and I have no problem with some other 4k 10bits videos, this one is only 1080p.

    HDMI cable is 2.0 4k 60hz certified.

    Will try and make a debug log during the week-end.


    That file plays totally fine for me on a Pi4 4GB (Tested 10.0.1, 10.0.2 and LibreELEC-RPi4.arm-11.0-nightly-20220317-859d6eb). Display is a Philips 55OLED936.


    What happens when you guys try to play my sample file? See: LE 10.0.2 on RPi4 not playing files that 10.0.1 had no problems with.

    Will give it a try this week-end too, I may even try to remove enable-4k-60 from my config.txt, even if I do not think it is the same problem as you (that file is 1080p)

    Edited 2 times, last by NeB: Merged a post created by NeB into this post. ().

  • I couldn't get that file to fail to play.

    NeB are you using a whitelist?

    I suspect your issue is probably related to hdmi cable, but having a whitelist set up (allowing lower resolution/refresh rates to be chosen) will make it less likely you'll hit issues.

    See: https://wiki.libreelec.tv/configuration/4k-hdr


    The debug log would be useful to see exactly which hdmi is being chosen.

  • I'm having a similar issue in that that most h265 files stopped playing for me after upgrading to 10.0.2 (Rpi4 2GB), my tv displays 'no signal' but pressing stop brings me back to the UI and signal returns.


    Turning off 'Allow Using DRM PRIME decoder' in 'settings | player | video' gets them playing again, but with very low framerate.


    NeB's test file plays back fine with DRM prime decoder enabled or disabled however.


    EDIT, got it working:

    Changing 'settings | system | display | resolution' to 1920x1080p instead of 2840x2160p fixed it, all videos now play fine with DRM prime decoder enabled.


    With the UI set to 4k (60hz refresh) I got 'no signal' when playing back 1080p SDR h265 videos but the few 4k HDR h265 vids I have worked OK.

    With the UI set to 1080p (60hz refresh) everythign works.


    Not sure why changing the menu res fixed 1080p h265 video playback but a fix is a fix :)

    Edited once, last by CountDuckula: Found a solution ().