[UNOFFICIAL][RK3228/RK3229]Libreelec builds

  • Hi ochentay4

    yes, installing on nand is supported.

    The best tool is the multitool from armbian.

    Another method is with usb cable and rkdevelop tool.

    yeah, problem is multitool doesnt work/boot/display anything so I cant use it (reported it here: https://forum.armbian.com/topi…s/page/59/#comment-160946) and rkdeveloptool is for linux only am i right? tried to flash the img with RockChip_FactoryTool_v1.64 and RockChip_Batch_Tool_v1.8 and img isnt recognized. Any tips?

  • Hi ochentay4,

    but what did you install in nand!? Android or legacy libreelec!?

    Anyway for the multitool keep asking for help in the armbian forum and follow any indications from jock2 and fabiobassa . They are my mentors, but it's not always easy for someone on the other side of the forum to help if someone just says "it doesn't work".

    However I'm working on a script that automates the installation to internal memory, but it will take me a while.

  • I have tried several Android roms on nand and frankly they all suck, used FactoryTool and Batch Tool just fine to install them to nand.

    I hope you get a script working, and on my side I will try to learn how to flash IMGs with rkdeveloptool using a live Ubuntu (im not good with linux but I can learn).

    Multitool does not work at all in this box so I posted on Armbian forum so someone could tell me how to diagnose, as I dont know what to do next. "fabiobassa" suggested a USB TTL converter and give him a serial log and will try to get one or do one, but it will take time. I even scanned my network to see if some random Android device showed and it didnt. I suspect that the issue you fixed for LibreELEC could be similar for multitool. What do you think? Sadly, multitool doesnt boot at all, with any methods that i tried.

  • I suspect that the issue you fixed for LibreELEC could be similar for multitool. What do you think? Sadly, multitool doesnt boot at all, with any methods that i tried.

    you are right, but multitool is a little operating system based on legacy u-boot and legacy rockchip kernel etc etc.

    My Libreelec instead, is based on legacy-uboot but 5.10.x mainline kernel.

    I hope you get a script working, and on my side I will try to learn how to flash IMGs with rkdeveloptool using a live Ubuntu (im not good with linux but I can learn).

    I suggested you wait for my script because it's a safer choice.

    You can though, but it's a thing for those who know what they're doing, do it directly from the sd card.

    If you copy the libreelec image to the sd card and run the following command

    dd if={path_of_image} of=/dev/rknand0

    the internal memory will be overwritten.

    But keep in mind:

    - to allow booting, libreelec build scripts tag partitions with unique ids. These ids change with each build and are used to detect the boot partition.

    So if you download an image and flash it to both nand and sdcard, then boot will always go to sd card if you reinsert the same.

    You don't run the risk of breaking anything, I see you handy in the flash of the box and therefore you can easily restore it. But I just wanted to tell you what you can get into.

  • Hi all,

    new build available with:

    - linux 5.10.172

    - mesa 23.0.0

    - updated libreelec to the latest upstream changes

    - fix for rk3228 voltages (thanks Habitual6824)

    - fix for sdcard boot on some board (thanks ochentay4)

    - fix for USB Bluetooth dongle

    - readded common whitelist video resolution for kodi player

    - added t95vpro box (rk3228, ddr3, without spdif output)



  • Hi ilmich / Michele,

    Thank you for all your (and the other contributors @jock2  knaerzche  fabiobassa  oneillb  Habitual6824  ochentay4 ) efforts. Using your images has been fun and made my hardware far more usable than it was when opened from the original box.

    As a note for your awareness..... I can report an ongoing instability in the newest (and previous newest) where by around 12-18hours the box just freezes. I typically come home and turn on the TV to see a frozen screen with a clock time from many hours before hand not changing and no response to any remote queries, http queries. Ive not tested network connectivity, will try and do that tomorrow. I was hoping with all the changes and tweaks provided in LibreELEC-RK322x.arm-10.0-nightly-20230306-088ac81-rk322x I would notice an improvement from LibreELEC-RK322x.arm-10.0-nightly-20230206-b1e877a-rk322x

    For me, I have been running LibreELEC-RK322x.arm-10.0-nightly-20230112-2f2eb71-rk322x since first noticing the issue in the 2023/02/06: kernel 5.10.167 version. That 2023/01/13: kernel 5.10.162 does not suffer from the same instability and freezing.

    I have attached a number of dmesg logs for your consideration and review. I have attempted to try different dtb selections earlier - shown in the filename.

    I am primarily using the rk3229-box-mxq4kpro.dtb as this functions the best overall, plus it shows the LEDs on the front of the unit where as others like rk3229-box.dtb does not.

    kind regards


  • thanks Gul-Dukat , that's my goal :)

    but then the freeze is after a period of inactivity!? Normally it works without problems?!

    However, studying legacy kernel I discovered that each box has tolerances for voltages. Who tolerates low voltages and who doesn't.

    I have to create a small driver to handle this, but in this period I can work very little on it :(

    But I'll try to give you some dtb's as soon as possible.

    You can also continue to use the installation that works for you, and help me with troubleshooting by simply switch dtb.

    There are no significant evolutions in the latest builds.

    In the meantime, I also found this patch which looks very promising

    Implement front to back rendering by sarbes · Pull Request #22919 · xbmc/xbmc
    Description The PR splits the GUI rendering into two passes, if enabled in the advanced settings. In a first pass, all opaque elements get rendered in front to…

    and would seem to greatly improve the UI performance on our beloved boxes. Fingers crossed.

  • Wanted to report that my box boots fine with "LibreELEC-RK322x.arm-10.0-nightly-20230306-088ac81-rk322x.img.gz". Thanks ilmich! Now this box stopped being useless!

  • Hi all

    I released the first build of libreelec 11 and then libreelec 10 goes into maintenance mode for a while.

    This build is an alpha release (not for daily usage), it contains some changes that break the update from 10 and it is strongly recommended to install only on sdcard (currently) and stay with libreelec 10 if something doesn't work.

    I also changed my approach, in the past release I backported some drivers from the legacy kernel for better usability.

    With this version, I don't want to do it because my goal is to make my project an official port.

    This doesn't mean that it will be less functional, but that it will take time to develop the missing drivers.

    What I know is not working

    - some remote controls (tested only mine). please follow this guide https://wiki.libreelec.tv/configuration/ir-remotes and I'm happy to add yours

    - some strange wifi chip (only 6051p works for now)

    - some strange usb wifi chip (I can add it if you help me)

    - NAND (this is the hard part and the only legacy piece that remains)

    - DDR3 frequency scaling (work in progress)

    - blue/red/green leds (work in progress)

    - wakeup from remote

    - only one generic box supported (work in progress)

    What is not working

    - let me known and help me to fix :)

    Extra Features

    - nice UI improvements thanks to backported patches https://github.com/xbmc/xbmc/pull/22919 https://github.com/xbmc/xbmc/pull/21557



  • Hello Michele. I am writing you here for the rk322x-box with an mpv binary. Is it possible to add it to your current Libreelec 11 build via a simple "addon" or there's some more work for it ?


    Vittorio Mori

  • Heya. So far good things to report with latest (LibreELEC-RK322X.arm-11.0-nightly-20230315-8b01ceb-rk322x.img) nightly image.

    I will try and get to test a few things, and see if I can get the remote working. Didnt have much luck with previous v10 - last time remote worked was in 9.2

    Attached is my dmesg if helpful.

    Will see how the unit survives tomorrow, and if any freeze / lock up occurs.

  • Hi the Mitch today I installed your libreelec March 11th on my MxqPro android box it is going very well with November release LibreELEC-RK322x.arm-10.0-nightly-20221122-32b2e05-rk322x.img just some hang every now and then and inserting this dtb rk3229-box-mxq4kpro.dtb , but unfortunately I can install libreelec 11 but it does not see any network , my radio is the 6051p and I also tried to insert the November dtb but with the same result, what's wrong of different?

    Can something be done while waiting for your next buildings?

  • Hi Gul-Dukat,

    it's very strange, libreelec 9.2 and libreelec 10 have the same driver for remotes.

    Instead on libreelec 11 I wrote that they may not work :) Please try the linked guide in the first post and share results

    MIKMXIII I need some logs please (follow this guide https://wiki.libreelec.tv/support/log-files). The 6051p is supported on libreelec 11 because I've a board with same chip.

  • Code
    Hi Mitch but since I don't have a network connection I can't do any of the log file methods, how can we do it?
    • New
    • Best Answer

    Thank you chewitt,

    I noticed it too. I will try to support sarbes, hoping his patches land in kodi. It's doing a great job with the help of renderdoc, and 'less powerful' devices benefit much more than others (where the changes aren't even noticeable).

    With other patches, I reached 30fps at 720p resolution, which for the rk322x is a miracle with Estuary skin.

    Gul-Dukat please wait next build, I've removed the offending patch :) (but I will use your pictures as a sample to explain the issue better to the developer)

    MIKMXIII you don't have the possibility to use ethernet?! In that case, I try to share something useful for debugging.