HDR on x86 Hardware

  • Try this one

    Dear smp would it be possible to make a new build (which includes the updates since 18.6.22) of that (which will also work on my NUC7 as the build from 18.6. did)?

    And a question (out of lazyness, because pressing a button on my remote is like heavy lifting *hahaha*): do you mayhaps know, why the "automatic" 3D switch isn't happening when playing 3D mkvs?

    Howsoever: thanks a lot for you builds!!!!!!!

  • Updated build in post #1.

    I can't seem to boot your image on a NUC7 gemini lake (J4005) - you mention somewhere that it might be tigerlake only but unclear if that applies to your main posts? It gets to the prompt, I choose live and then it hangs forever.

    I also compiled the tip of your gbm-bt2020 branch on an archlinux install running 5.19 to see if I could get HDR working but to no avail. Any ideas/tips? I'm trying to understand if I have a chance to make this work or if I have to go out and buy some new hardware.

    Edited once, last by arfikk (August 9, 2022 at 1:47 PM).

  • Updated build in post #1.

    Thanks for this.

    Working nicely for me (MSI Cubi N with Gemini Lake N5000) - updated from your 06/18 build.

    I notice that the VAAPI hardware acceleration for VC-1 is now working again too which is a nice bonus.

  • Does the nightly image boot?

    I don't have a git branch named gbm-bt2020 and I know nothing about archlinux.

    Sorry I got confused, I'm building kodi from https://github.com/lrusak/xbmc - I figured from reading here that this was the sources you where using - mind telling me which commit you're using? You seem to be using git sha 3d12daa7f7a71d89c4740193948c64e341fa5b73but I'm not sure where this is from :)

    Turns out i'm an idiot, seems librelec has a well known bug on NUC7 where F10 boot doesnt work but boot from F2 does. Image boots and HDR is working well with my LG C2.

    Edited 3 times, last by arfikk: Seems my posts are still moderated so I'll keep correcting :) (August 10, 2022 at 10:34 AM).

  • Updated build in post #1.

    So that build I suppose is based on sw dated 2022-08-07. I used previously nightly build as of 2022-08-06 and on NUC 10 it was hanging around every one hour on regular MPEG4/AC3 movies , which was pretty annoing.

    This one is not hanging at all (so far), so I wonder what else is different comparing to regular nighties?

  • Updated build in post #1.

    Thanks for the new build. I installed on my two NUC8i3 LE boxes today and played a variety of movies, music videos and multichannel music and looks good! No issues.

    The previous build would crash Kodi if I switched between those types of files, but was quite stable if I just played music or a movie.

    Thanks again for all your HDR builds!

  • I have a 5700u ryzen APU with an OLED HDR-capable laptop display. This build boots fine and classifies my display as HDR10 capable in the System Information but HDR doesn't work, the picture is washed out unless I disable the "Use display HDR capabilities" option. It's also worth mentioning that my laptop monitor is displaying 10-bit HDR content using the 8bit + FRC method.

  • just tried with the ubuntu install currently on there and i can go from 4k60 to 1080p24 but won't then let me go to 4k24 only 4k60, it does list all the modes my TV can support though

    when i hit apply i loose signal and tv goes to the default 1080p60 no signal mode until it auto reverts back as not been able to confirm it

    hoping to have at least some logs and info from the box which might be able to help, i inititialy gave up as i couldn't compile my own kernal, but i am hoping these will be better than nothing

    nearly bedtime though so tomorrow's fun

    I'm running a NUC11TNHi3 connected to a Sony KD-55XF9005 and I can change refresh rate between 4k30p and 4k60p on the following OS/Kernels:

    Ubuntu 20.04.3 HWE (5.15)

    LibreELEC 10.0.2 (5.10)

    LibreELEC nightly-20220819-354884a (5.19)

    I have some sound errors though which I will post separately...

  • I'm having some issues with build nightly-20220819-354884a running on a NUC11 (Tiger Lake). Video works well with the formats I have tried, but passthrough audio is not working.



    This setup has worked well before, but only running 1080p, running Kodi 18.x on Ubuntu 16.04:

    NUC5PPYH (Braswell) + PulseEight HDMI-CEC dongle <-> (hdmi ?) Sony KD-55XF9005 (hdmi ARC) <-> Onkyo TX-NR646

    HDMI-CEC works, audio passthrough works, etc

    So, the TV+AVR is tested to work in this way


    NUC11TNHi3 (hdmi 1) <-> (hdmi ?) Sony KD-55XF9005 (hdmi ARC) <-> Onkyo TX-NR646

    Test scenarios:

    - Ubuntu 20.04.3 HWE (kernel 5.15) + Kodi 19.4: No audio and I didn't manage to sort out anything with regards to audio and/or audio passthrough...

    - LibreELEC 10.0.2 (kernel 5.10): Audio settings and passthrough channels are recognized and shown in the GUI (says HDMI #3 fwiw). Setting the passthrough and all formats enabled I get GUI sounds after reboot. No audio in any videos I tried, except for one video file at one time. After reading up, I understood that Tiger Lake is not supported on this kernel.

    LibreELEC nightly-20220819-354884a (kernel 5.19), upgraded from stable 10.0.2 above. No audio at any setting after the upgrade. Audio passthrough is different from the stable release above, now recognizing the TV at "DisplayPort #0". Still no audio after several reboots, but after I pressed "Revert all settings" under Audio and then doing some basic settings (enabling passthrough) it actually started working, both GUI sounds and passthrough. The AVR picked up the different formats aswell.

    However, after one movie the sound stopped working and after that it doesn't come back until a restart. I think it was at a DTS audio file. I'll try to narrow it down...

    Here's a log for now: (should work better than before.

    Edited once, last by crotale: New paste of log. (August 20, 2022 at 6:56 PM).

  • crotale

    your log isn't accessable without ubuntu pastebin log in !

    is the NUC11 a new device (cause talking about an NUC5 first) ?

    if so:

    recheck your bios setting regarding audio.

    on my nuc8 with audio jack I've two bios entries (HDMI and DSP something; the last is off) seems not the case for an NUC11TNHi3 (not audio jack)

    running audio via hdmi through the headphone jack on the monitor (maybe a test scenario for you too, before running CEC stuff ?)

    recheck if new bios available what maybe fixes a media device related bug

    Edited 4 times, last by GDPR-7 (August 20, 2022 at 7:03 PM).

  • New log paste fixed. (http://sprunge.us/tUrPwY)

    Yes, I mentioned the NUC5 I had before the NUC11 just to say that the video+audio to the TV+AVR worked with the NUC5.

    I have checked the BIOS and I have not found a setting for a DSP setting. I have also tried removing the CEC-USB adapter and disabled all CEC in BIOS.