Lip sync issues / audio drop out

  • Hi,

    I just changed to Libreelec yesterday from running Kodi on Windows, because I don't like the PC feel and it defaulting to windows login all the time.


    I am using the same hardware but am experiencing audio drop out and sync issues.

    I have it set to passthrough audio and auto change refresh rate. I have also tried all the available audio output options "hdmiO, hdmi1, analog etc, but all similar results. If I set my AVR from video passthough to video adjust that fixes the audio drop out but not the sync.


    The only ad-in I have installed is PlexKodiConnect (PKC) which I also used in my previous windows setup.

    Hardware is : ntel NUC 10th Gen BXNUC10I5FNH4 i5-10210U


    Any assistance would be great.

  • Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Full logs only. No modified logs.

    Do not post your logs directly into the forum,
    use Settings > LE Settings Addon > System > Paste system logs
    and post the link.
  • I've no idea for/against (?) your issue, but maybe trying nightly might help


    be aware: I've also no idea if the addon "PlexKodiConnect" is available for nightly, so check that first !


    hint:

    you could run nightly also from an usb stick to test before iron your disk

    DigiBit R1, NUC8i3BEH

  • Hi,

    Can I get a reply from developer after uploading my log?

    If not then I’m going to have to drop libreelec and go back Kodi on windows. ☹️

  • The out-of-sync issue is visible at the log:

    Code
    2022-01-14 21:47:58.606 T:1011    DEBUG <general>: CVideoPlayerVideo - CDVDMsg::GENERAL_SYNCHRONIZE
    2022-01-14 21:47:58.607 T:1008    DEBUG <general>: CheckPlayerInit - dropping packet type:2 dts:2034824000.000000 to get to start point at 2035783000.000000
    2022-01-14 21:47:58.607 T:1008    DEBUG <general>: CheckPlayerInit - dropping packet type:1 dts:2034827000.000000 to get to start point at 2035783000.000000
    2022-01-14 21:47:58.607 T:1011    DEBUG <general>: CVideoPlayerVideo - Stillframe left, switching to normal playback
    • play the same file from USB stick instead of using Plex, and report the result
    • if Plex has cache settings, increase the cache

    DNB music-addicted finger drummer.

  • Thanks,

    Played same file from usb and still has same issues. Audio drop out for first 30 seconds or so, the lip sync out.


    Any suggestions?

  • Then I also suggest the latest nightly LE. Copy the .img.gz file into the .update folder, and reboot. You can downgrade back to LE 10.0.1 the same way.

    DNB music-addicted finger drummer.

  • Also, try disabling HW decoding of video codec (don't know which it is, for me it was VAAPI), I had simmilar issues in the past, but I have old Celeron class CPU with bugged GPU. Couldn't even watch SD resolution x264 without desync. x265 worked, but only because it has no HW acceleration and it decodes by software.

  • Also, try disabling HW decoding of video codec (don't know which it is, for me it was VAAPI), I had simmilar issues in the past, but I have old Celeron class CPU with bugged GPU. Couldn't even watch SD resolution x264 without desync. x265 worked, but only because it has no HW acceleration and it decodes by software.

    You've been posted a tweak for another Intel user with nearly the same issue:

    RE: Librelec Matrix 10.0.1 freezes randomly when playing video


    So maybe this is also helpful for grandnagas . Try it!

    DNB music-addicted finger drummer.

  • Thanks Guys,

    I downloaded the file but could not find the .upgrade folder, or figure out how to create one.

    I tried rolling back to version 9, but that broke the whole system.


    So alas I am back on windows, but at least everything works.

    When I have some time I'll try again booting from USB and looking further at the suggestions.

  • I downloaded the file but could not find the .upgrade folder, or figure out how to create one.

    It's a hidden folder, use cd /storage/.update.

    You can also use wget https://test.libreelec.tv/LibreELEC-Generic.x86_64-11.0-nightly-20220123-baa84f0.img.gz to download the file when you're in that folder.


    Yes, switching among LE 9 and 10+ will break things, but any switch among LE 10+ versions should work fine.

    DNB music-addicted finger drummer.

  • Hi, I spent a couple mores hours on this today, but sadly problems still exist.


    I installed on a usb as not to alert my windows install.

    Firstly big problems with video sync. Was able to resolve these mostly if added a white list.

    Audio only dropped out a couple of times in the first 10-20 sec then was ok and no noticeable lip sync issue.


    The biggest problem in video sync every time you select a menu in the Kodi os I lost sync and went in a unusable loop.


    Overall still unusable and unstable, compared to windows which has no issues.