failed to start xorg

  • what I can find is this:

    [SOLVED] No Graphic Driver Offered for Gigabyte Brix GB-BMCE-5105 - Linux Mint Forums


    long story short:

    it seems you need a newer kernel, what is in nightly.

    and that's here:

    Index of /


    key in "gen" in the grey box to filter the images for your device


    I wonder how you were able to install LE ?!

    shouldn't it be: "same kernel, same (driver-)fun" ?


    *I* would also check for a new BIOS:

    GB-BMCE-5105 (rev. 1.0) Unterstützung | Mini-PC Barebone (BRIX) - GIGABYTE Germany


    => F4 from 2021.07.29

    => "BIOS Fixed : Random Boot Failures issus"


    that's might answer my question ... :cool:

    DigiBit R1, NUC8i3BEH

    Edited once, last by JoeAverage ().

  • LE10 uses Linux 5.10 kernel and support for the latest Intel chips/GPUs was still WIP at the time 5.10 shipped. If you update to a current LE11 nightly image from: https://test.libreelec.net the latest kernels (5.15, and we bumped to 5.16 last night) should have support. Nightlies are running pre-Alpha Kodi Nexus but should be fairly stable to use.

  • I have an Asrock J5005 ITX board with UHD605 graphics, but I didn't have the boot problem. Perhaps the Brix BIOS/UEFI is being a d!ck again.


    Something that is necessary (at least on my board), is that I had to change to a different/older driver:

    Create /storage/.config/kodi.conf and add:

    Code
    LIBVA_DRIVER_NAME="i965"

    Without it, h265/HEVC video won't play correctly.

  • Thanks.

    I downloaded the nightly version and it worked.

    Now I'd like to ask if the add-ons for matrix will work in this version.

    Also, is there any way to add greek language? (but not a big deal if it cant be done)

  • Most Kodi repo provided add-ons are either available in Nexus specific versions or are Matrix compatible. For non-Kodi add-ons /shrug but most Matrix add-ons will probably work fine. You can install Greek under Kodi settings > Interface > Regional > Language.

  • Screen works at 4k 30hz. When i change to 60 hz it crashes.

    That could be a software or hardware problem?

    Hardware specs says it supports 4k 60hz

    Edited once, last by surveyor81 ().

  • Screen works at 4k 30hz. When i change to 60 hz it crashes.

    Try running a Ubuntu Live distro on a bootable USB stick.

    Change the screen to 4K60. If it works then LE has a problem. If not... well, then it's something else.

  • I'm running Ubuntu 21.10 on UHD605 with a 2560x1440 monitor with 60hz. It is not crashing.

    I know it's not 4K but I don't think it makes much of a difference.

  • If it occasionally switches back to 30Hz, then go for that cable approach.

    DNB music-addicted finger drummer.

  • Hi, I am a long time user of libreelec and have decided to upgrade my hardware however get the following error message:

    "failed to start xorg/is your GPU Supported.

    My new hardware is as follows:

    CPU - Intel 12th gen Core i5 -12400 which has "Intel UHD Graphics 730"

    Motherboard - Gigabyte B660 LGA 1700 and states it has Onboard Graphics Processor - Intel HD Graphics Support

    Any help would be appreciated as I have just spent a lot of money on the upgrade.